Jump to content
Sign in to follow this  
Schnaplo

Win XP Pro ignoriert hosts Datei??

Recommended Posts

Hi Leudes, ich hätte da gerne mal ein Problem! :)

 

Folgendes: ich habe einen Schwung Einträge in der Hosts Datei, das auf mehreren Laptops.

 

Bei allen funktioniert auch die Namensauflösung gemäß den Einträgen in der Hosts-Datei, nur bei einem nicht.

 

Die haben alle XP Pro und auch sonst fällt mir kein Unterschied in den Netzwerkkonfigurationen auf.

 

Jetzt frag ich mich: warum werden die Einträge in "hosts" denn wohl ignoriert? Ein Ping auf die IP-Adresse funktioniert, ein Ping auf den Hostnamen funktioniert nicht.

 

Über sachdienliche Hinweise wäre ich SEHR dankbar!! :D

 

Gruß,

Schnaplo

Share this post


Link to post

hallo,

 

hmm, mir ist kein weg bekannt, wie man die auswertung über die hosts-datei abschalten kann, höchstens die ntfs-rechte stimmen nicht.

starte doch mal den ntfilemon von sysinternals, dann setz nen ping ab und schau im filemon, ob die hosts benutzt wird.

 

gruß

Share this post


Link to post

Hast du auf dem einen Laptop evtl. einen WINS-Server eingetragen oder per DHCP zugewiesen oder so und es 'irgendwie' geschafft, dem höhere Priorität zu geben als der DNS-/hosts-Auflösung?

 

Normal wird erst die "hosts", dann DNS befragt und dann notfalls NetBIOS / WINS bemüht.

 

Grüße,

SIGSEGV

Share this post


Link to post

Naja, *ich* hab gar nix gemacht - es is der laptop von meinem Chef (ausgerechnet) und er hat (natürlich) auch nix gemacht.

 

Und ich kann jetzt nicht nachvollziehen was da gelaufen ist. Denn das als erstes hosts abgefragt wird ist ja eigentlich etwas worauf man sich verlassen kann.

 

Die Einträge in der Hosts-Datei brauche ich nämlich damit die Leute von daheim per VPN die Rechner im Firmennetz finden. Denn einen WINS - Server o.ä. hab ich hier nicht laufen, der Aufwand mit der hosts-Datei ist da kleiner.

 

Nur plötzlich scheint dieser eine Laptop die Hosts-Datei eben ganz und gar zu ignorieren.

 

Ich gucke mir da gleich die Netzwerkverbindungen nochmal genauer an speziell mit Augenmerk auf WINS Einträge.

 

Verstehen tu ich´s trotzdem nicht, da ja eigentlich HOSTS zuerst gefragt werden sollte.

Share this post


Link to post

Hi,

 

wurde die hosts evtl. mal auf einer UNIX-/Linux-Maschine editiert? D.h. kann's sein dass Windows mit "falschen" Zeilenumbrüchen durcheinander kommt oder einfach nicht alles liest? Hatte ich schon mal bei Konfigurationsdateien... findet man natürlich auch "sofort";-)

 

Grüße,

SIGSEGV

Share this post


Link to post

Nein du, das kann sehr wohl sein!

 

Ich habe nämlich tatsächlich eine 2. Hosts-Datei entdeckt und diese gelöscht. Daraufhin hat mein McAfee auch rumgenölt QHosts-1

 

Da ich die ja aber zu dem Zeitpunkt gesäubert habe, habe ich mir nichts weiter bei gedacht. Den falschen DNS-Eintrag habe ich auch ersetzt, jetzt guck ich doch mal genauer in den Artikel, ob ich da auch die nötigen Clues kriege...

 

Vielen Dank schonmal vorab!!

Share this post


Link to post

Bingo, der QHosts Trojan war drauf - wenn ich heute heise genauer gelesen hätte wär ich schlauer gewesen :D

 

Ich hab die Symantec-Anleitung nun befolgt und die registry saubergemacht, ich hoffe das klappt jetzt.

 

Danke nochmal für den Hinweis!!

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...