Jump to content

iSCSI + Freigaben


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo,

 

auf einer VM habe ich eine 250GB große Partition per ISCSI verbunden. Auf dieser Partition/Festplatte liegen unter anderem einige Freigaben.

 

Folgende Problematik:

Sobald ich den Server neustarte, werden die Freigaben nicht automatisch wiederhergestellt. Ich habe nun schon den MS iSCSI Initiator Service vom Computerbrowser/Backup Exec/DFS abhängig gemacht, sodass er erst gestartet wird, sobald diese Dienste auch laufen.

 

Leider funktionierte auch das nicht. Die Lösung die ich mir bisher "gebastelt" habe ist, dass ich mir eine batch-Datei geschrieben habe, die die Freigaben wieder anlegt.

 

Den Artikel der kb870964 habe ich bereits durchgearbeitet - leider auch ohne Erfolg.

 

Hat vll. noch jemand einen Tipp für mich, damit ich das ganze nicht immer händisch durchführen muss? Ich gehe mal davon aus, dass das in irgendeiner Form funktionieren müsste.

 

Gruß Nils

Link to post

Das kann ich zur Zeit ein bischen schlecht ausprobieren, müsste damit bis Feierabend warten, damit die Mitarbeiter weiterhin auf Ihre Freigaben zugreifen können... aber ich meine 'nen anderer Kollege hätte das getestet und es hätte nicht funktioniert... aber ich versuchs nachher nochmal!

Link to post

Nutzt Ihr den Intiator in der Version 2.x?

 

Ja, mal das Prozedere von Deinem KB Artikel im Wartungsfenster in Ruhe durchführen.

 

Am besten mit dem englischen KB Artikel: File shares on iSCSI devices may not be re-created when you restart the computer

 

Siehst Du die Verbindungen als Persistente Verbindungen?

Note If you see the target on the Persistent Target tab, the following steps are not required.
Link to post
Nutzt Ihr den Intiator in der Version 2.x?

 

Ja, mal das Prozedere von Deinem KB Artikel im Wartungsfenster in Ruhe durchführen.

 

Am besten mit dem englischen KB Artikel: File shares on iSCSI devices may not be re-created when you restart the computer

 

Siehst Du die Verbindungen als Persistente Verbindungen?

 

Wie vorhin schon geschrieben, habe ich das ganze schon durch... unter Persistent Targets sehe ich den Target. Version ist 2.x...

Link to post

Es gab Mitte Mai ein Update (v2.07).

 

Ich würde mal die bestehende Version deinstallieren, die neueste Version installieren und wie oben gesagt das Prozedere nochmal durchlaufen.

 

Hast Du irgendwelche Events im Log?

Link to post

Ereignisanzeige hat keine Fehler, jedoch werde ich nachher mal den iSCSI Initiator auf Version 2.07 updaten, habe derzeit noch 2.06 im Einsatz.

So... nachdem ich alles neu installiert und konfiguriert habe, scheint nun wieder alles wunderbar zu funktionieren.

 

Danke dir Lian für den Tipp mit dem Update!

 

Schönen Feierabend!

Link to post

Dazu kann ich nichts sagen, ESX in Verbindung mit FreeNAS hatte ich noch nie vor mir.

Wenn Ihr noch ein anderes iSCSI Target habt, probiere es mal damit testweise.

Dann kann man den Fehler evtl. eingrenzen. StarWind kann ich empfehlen:

:: Rocket Division Software :: StarWind iSCSI Target for Microsoft Windows

 

Ok, stimmt das so?

 

-Im iSCSI Intitiator siehst Du Persistent Targets, auf diesen sind die Shares

-Der LanManServer Service ist abhängig vom MSiSCSI Service

-Die Registry Parameter sind zu jedem Zeitpunkt gleich (LanmanServer\Shares)

-Du hast kein Event ID 2511 o.ä.

Link to post

Mit dem anderen iSCSI-Target werde ich mal versuchen, muss mir aber erst ne vm installieren, auf der ich das mal testen kann. Ereignisanzeige hat immernoch keine Fehler...

 

-Im iSCSI Intitiator siehst Du Persistent Targets, auf diesen sind die Shares korrekt

-Der LanManServer Service ist abhängig vom MSiSCSI Service jap

-Die Registry Parameter sind zu jedem Zeitpunkt gleich auch korrekt(LanmanServer\Shares)

-Du hast kein Event ID 2511 o.ä.nein, weder 2511 noch ähnlich

Link to post

Hallo Lian,

 

auch mit StarWind wurde das Problem nicht behoben...

 

Ich habe nun versucht, die Freigaben per Script beim Systemstart zu setzen, leider auch ohne erfolg, ich habe das Gefühl, das Script wird garnicht erst ausgeführt. In der Ereignisanzeige ist hierzu nichts zu finden.

 

Eventuell noch eine Idee, wie ich die Freigaben nach Neustart wieder herstellen kann?

Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...