Jump to content
Sign in to follow this  
WeBO

ADO-Sicherheitswarunung

Recommended Posts

Hallo Forum,

Ich bin immernoch an der Arbeit an meiner HTA, mit der ich das Active Directory abfrage. Das ganze passiert über ein ADODB.Connection-Objekt. Dieses Objekt bringt aber einige Sicherheitsprobleme mit sich.

 

Wenn ich die HTA nun zentral im Netzwerk zur verfügung stelle, bekommt man beim öffnen dieser immer eine ADO-Sicherheitswarunung. Diese kann man umgehen, wenn die Sicherheitseinstellungen im IE für das Lokale Intranet auf sehr niedrig stellt. Das möchte ich aber nicht unbedingt.

 

Hat vielleicht jemand eine Idee, wie man dem Inhalt dieser HTA vertrauen kann oder ihr ein Zertifikat geben kann oder ähnliches um diese Meldung zu verhindern?

Share this post


Link to post
Share on other sites

Öhm.... versteh ich das richtig? Du vertraust deinem lokalen INTRANET nicht? Wenn du den Internet nicht vertrauen würdest, kann ich das noch verstehen. Aber deinem Intranet solltest du doch vertrauen können oder?

Share this post


Link to post
Share on other sites

Naja, man weis ja nie was die User über E-Mails alles einschleppen. Sicher ist sicher. Dabei würden dann auch manche Fehlermeldungen unterdrückt werden, die einem vielleicht die Suche nach einigen Fehlern erleichtern würde. Also es wäre schon wirklich wichtig, dass es eine andere Möglichkeit gibt.

Share this post


Link to post
Share on other sites

Und wenn du die zentrale Stelle (sprich URL) im Netz als Trusted Site zur Verfügung stellst? Sollte das nicht mehr Erfolge bringen? Bzw. wie in deinem genannten Artikel einen alternativen Browser in Betracht ziehen.

Share this post


Link to post
Share on other sites

Danke, das ist eine super Idee mit den Vertrauenswürdigen Seiten. Manchmal sieht man den Wald vor lauter Bäumen nicht :rolleyes: .

Ein Problem ist aber noch, dass ich die richtige Schreibweise nicht hinbekomme. Ich habe mir die Seite gerade als Favorit hinzugefügt:

 

file://Fileserver1/file/home/alle/Telefonlisten/Werk1.hta

 

Wenn ich den Pfad genau so angebe und hinzufüge, springt es immer auf

file://Fileserver1

zurück. Damit habe ich aber auch nichts gekonnt, dann kann ich auch das ganze lokale Intranet auf sehr niedrig stellen :p

(habs natürlich auch schon mit ettlichen anderen Schreibweisen probiert, mit dem selben Ergebnis)

 

Anderer Browser kommt leider nicht in Frage.

 

MfG WeBO

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...