Jump to content

2k-Server auf 2k3-Server updaten...


ag1
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo,

momentan laufen hier im Büro 2 W2KServer mit AD und DNS. Die Repliaktion zwischen beiden läuft einwandfrei.

Jetzt hab ich mir gedacht, einen davon auf Win2003 zu aktualisieren (keine Neuinstallation). hab auch schon einige Artikel gelesen und mir folgenden Plan gemacht:

 

1. Ich erstelle eine komplette Sicherung des betreffenden Servers (Server2)

2. Mit "/checkupgradeonly" Server 2 auf Kompatibilität prüfen

3. auf Server 2 EFS-Zertifikat sichern

4. auf Server 1 (auf ihm liegen die FSMO-Rollen und ist GC) ADPREP (von R2 CD2) mit der Option "/FORESTPREP" und anschließend mit "/DOMAINPREP" ausführen (muß ich das auf Server 2 auch ausführen)

5. Zusätzlich noch auf Server 1 "ADPREP /DOMAINPREP /GPPREP" ausführen (nur auf Server 1 erforderlich?)

6. Auf Server 2 das Win2003-Server-Setup ausführen...

 

 

Hab ich irgendwas wichtiges vergessen oder gibt es sonst noch was wichtiges zu beachten?

 

 

Ich würde mich sehr über Tipps freuen. Vielen Dank schon mal!

 

 

MFG

ag1

Link to comment

Salut,

 

hab auch schon einige Artikel gelesen

 

falls du den noch nicht kennst, kennst du ihn jetzt ;):

Yusuf`s Directory - Blog - Migration von Windows Server 2000 auf Windows Server 2003 (Inplace-Update)

 

 

1. Ich erstelle eine komplette Sicherung des betreffenden Servers (Server2)

2. Mit "/checkupgradeonly" Server 2 auf Kompatibilität prüfen

 

OK.

 

3. auf Server 2 EFS-Zertifikat sichern

 

Ist denn der Server2 der allererste DC gewesen?

Denn das EFS-Zertifikat liegt auf dem erst installierten DC.

 

4. auf Server 1 (auf ihm liegen die FSMO-Rollen und ist GC) ADPREP (von R2 CD2) mit der Option "/FORESTPREP" und anschließend mit "/DOMAINPREP" ausführen (muß ich das auf Server 2 auch ausführen)

 

Nein, du führst das ADPREP mit dem Parameter /FORESTPREP auf deinem Schemamaster aus und mit dem Parameter "/DOMAINPREP /GPPREP" auf dem Infrastrukturmaster.

Du kannst die beiden Schalter DOMAINPREP sowie GPPREP zusammen ausführen und musst diese nicht gesondert ausführen. Beides geht in einem Rutsch.

 

Das ADPREP musst du auf den FSMO-Rolleninhaber (Schema- sowie Infr.master) ausführen und nicht auf dem anderen.

 

5. Zusätzlich noch auf Server 1 "ADPREP /DOMAINPREP /GPPREP" ausführen (nur auf Server 1 erforderlich?)

 

Wie bereits geschrieben, führe ADPREP mit "DOMAINPREP /GPPREP" in einem Schritt zusammen auf dem Infrastrukturmaster (bei dir der Server1) aus. Du kannst das zwar auch getrennt ausführen, ist aber nicht nötig und somit ersparst du dir einen Schritt.

 

6. Auf Server 2 das Win2003-Server-Setup ausführen...

 

Jawollja.

 

Hab ich irgendwas wichtiges vergessen oder gibt es sonst noch was wichtiges zu beachten?

 

Nö, sieht gut aus der Fahrplan. Schau noch einmal auf meinen oben verlinkten Artikel... dann bleibt nur noch zu sagen: Viel Glück and Have Fun :) .

Link to comment

Hallo,

 

danke für deine Antwort. Den genannten Artikel hab ich bereits in meinen Lesezeichen gespeichert, genauso wie einige andere von der gleichen Seite. Da hab ich schon viele wertvolle Tipps gefunden.

 

Nur noch eine kurze Frage zu 4.: Bei mir ist der Server 1 Schemamaster, Infrastrukturmaster und FSMO-Rolleninhaber. Ich führe also ADPREP mit den genannten Schaltern auf diesem Server 1 aus. Wenn das erfolgreich abgeschlossen ist, starte ich auf Server 2 das Update auf Win2003. Hab ich das so richtig verstanden?

 

 

Grüße

ag1

Link to comment

Hallo,

hab am Samstag das Update durchgeführt (ich kann's halt nicht lassen ;) ). Bis auf kleinere Probleme (zuerst musste ich noch Reste einer alten Exchange-Installation aus dem AD beseitigen; Windows-Update lies sich sehr viel Zeit) lief das Ganze einwandfrei durch.

Hab dann noch alles auf mögliche Fehler überprüft, aber so wie es aussieht läuft alles fehlerfrei (kein außergewöhnlicher Eintrag im Ereignisprotokoll, kein Fehler bei dcdiag und netdiag).

Hab bei dieser Gelegenheit auch noch von SCSI mit einer HDD auf ein SATA-RAID1 umgestellt, was ebenfalls einwandfrei klappte (SATA-Controller eingebaut und RAID1 eingerichtet, System über SCSI-Platte hochgefahren, SATA-Treiber installiert, System runtergefahren, System auf RAID1 geklont, SCSI-Platte abgesteckt, System über SATA wieder hochgefahren).

 

So, die Aktion hat mich zwar den Samstag Nachmittag gekostet, aber nun ist es erledigt.

 

Vielen Dank nochmal für eure Hilfe!

 

 

Grüße

ag1

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...