Jump to content

Problem bei Terminal-verbindung


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo,

 

folgendes Szenario habe ich vorliegen.

 

Windows 2000 Advanced Server mit Windows 2003 Domänencontroller (Domänenfunktionsebene Windows Server 2003, Gesamtstrukturfunktionsebene Windows 2000), als Clients sind für die Benutzer ausschließlich Windows 2000 Professional im Einsatz, für Administratoren und Testumgebung auch Windows XP Professional und Vista.

 

Es soll jetzt auf dem Windows 2000 Server der Terminaldienst aktiviert werden (läuft auch schon problemlos, Lizenzen werden sauber erstellt) und einige Clients sollen sich nur auf dem Terminal anmelden anstatt auf dem lokalen PC. Dieses habe ich per AutoLogon eines Standard-Benutzers und automatischem Start einer vordefinierten RDP-Datei per GPO realisiert. Hier kommt nun der Knackpunkt. Die Systeme sind teilweise schon etwas betagt, dazu kommt eine LAN das auch über Funkstrecken und/oder Standardfestverbindungen aufgebaut ist (viele räumlich getrennte Benutzer), d.h. der Benutzer schaltet den PC ein und geht erstmal was anderes machen, Kaffee trinken oder ähnliches.

 

Jetzt kommt der große Haken: bei Nicht-Anmeldung an der Terminalsitzung wird der Remotedesktop automatisch nach 2 Minuten beendet und zwar auf allen gestesten System, auch bei einer administrativen Consolenverbindung von XP auf Windows 2003 - daher gehe ich davon aus, das hier eine Einstellung für das Remotedesktop vorliegt. Gleiches Problem ist ebenfalls bei dem Windows Server 2000 integrierten Terminalclient (tsclient.exe). Ansich wäre das alleine kein großes Problem, jetzt ist allerdings für den auf dem lokalen PC automatischen Client das Desktop und das Startmenü soweit ausgeblendet, das der nur noch heruntergefahren werden kann, und das soll laut Unternehmensvorgabe so bleiben, also kann der Benutzer die Terminalserver-Verbindung nicht manuell herstellen - auch das ist eine Unternehmensvorgabe.

 

Was ich jetzt logischerweise benötige ist eine Lösung entweder das Timeout des Remotedesktop bzw. TS-Client zu beseiten, oder die lokale AutoLogon Anmeldung gleich auf einen Terminal umzulenken, eine solche Funktion ist mir allerings nur mit Citrix bekannt.

 

An den Zeiten zum Beenden getrennter Sitzungen oder bei Leerlauf liegt das Problem nicht, diese sind sowohl mit AD im Benutzer auf "Nie" eingestellt und im RDP-Protokoll auf dem TS wird die Benutzer-Einstellung nicht überschrieben.

 

Für Vorschläge, Denkanstöße und Lösungsansätze bin ich jederzeit dankbar.

Link to comment

Das Verhalten ist "by Design" und mir ist momentan leider auch kein Weg bekannt das zu umgehen. Eventuell ist es eine Einstellung im RDP File oder eine Einstellung in der Registry des TS bzw. des Clients....

Hab mich damit noch nicht auseinandersetzen müssen/wollen.

 

Aber mal ganz eherlich. Wenn die Nutzer auf dem "PCeinschaltenDannKaffeetrinken" Trip sind müssen sie einfach umlernen. Was nicht geht das geht nicht und wegen der Bequemlichkeit von ein paar DAUs sollte man sich nicht mehr Streß machen als nötig.

 

Ich kenne solche Fälle zu genüge, wir betreuen viele kommunale Kunden...

Was meinst Du wie die reagieren, wenn deren Zeiterfassung nicht mehr über Hardwareterminals sondern über die EDV läuft und sie sich erst an den PCs anmelden müssen um sich dann an der Zeiterfassung anmelden zu können.

Die ersten Schockreaktionen sind dann "Oh Gott, dann muss ich ja früher aufstehen, damit ich mich rechtzeitig anmelden kann, weil mein PC so langsam ist."

 

Alternativ bestünde vielleicht die Möglichkeit via script prüfen zu lassen, ob der Prozess mstsc.exe läuft. Läuft dieser nicht, wird automatisch das Autostart RDP File geladen. Damit hättest Du einen Mechanismus, der ständig prüfen würde, ob die Nutzer am TS angemeldet sind. Wenn das nicht der Fall ist startet die RDP Verbindung... wie man sowas realisieren könnte ist eine andere Frage.

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...