Jump to content
Sign in to follow this  
nkm

Routing Problem mit drei Subnetzen Class B und Class C

Recommended Posts

Hallo zusammen!!!

Heute ist mein erster Tag auf dem Board und schon die ersten Probleme!

So was habe ich vor:

Ich habe einen W2K Server der als PDC, DHCP, DNS, Printspooler und als "Router" fungieren soll.

Dieser ist ausgestattet mit 3 Netzwerkkarten:

Alle haben eine Mask von 255.255.255.224 /27

 

Alle Testsysteme sind jeweils mit zwei Netzwerkkarten ausgestattet die in Subnetzen sind. Das 3 Netz(192.30.0.1-30) ist ein BNC Netz wo HPs angeschlossen sind.

Das 10.20.0.x Netz soll als Arbeitsnetz und das 128.30.0.x Netz soll als eine Art Backbone benutzt werden. Leider habe ich keinen Hardwareroute zur Verfügung.

 

An bei: route Print

Interface List

0x1 ........................... MS TCP Loopback interface

0x2 ...00 04 76 0b 55 48 ...... 3Com EtherLink PCI

0x3 ...00 08 a1 3c 0d e7 ...... Realtek RTL8169/8110 Family Gigabit Ethernet

 

0x4 ...00 08 a1 3c 09 2e ...... Realtek RTL8169/8110 Family

Active Routes:

Network Destination Netmask Gateway Interface Metric

0.0.0.0 0.0.0.0 10.20.0.1 128.30.0.1 1

0.0.0.0 0.0.0.0 10.20.0.1 192.40.0.1 1

0.0.0.0 0.0.0.0 128.30.0.1 10.20.0.1 1

10.20.0.0 255.255.255.224 10.20.0.1 10.20.0.1 1

10.20.0.1 255.255.255.255 127.0.0.1 127.0.0.1 2

10.255.255.255 255.255.255.255 10.20.0.1 10.20.0.1 2

127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1

128.30.0.0 255.255.255.224 128.30.0.1 128.30.0.1 1

128.30.0.1 255.255.255.255 127.0.0.1 127.0.0.1 1

128.30.255.255 255.255.255.255 128.30.0.1 128.30.0.1 1

192.40.0.0 255.255.255.224 192.40.0.1 192.40.0.1 1

192.40.0.1 255.255.255.255 127.0.0.1 127.0.0.1 1

192.40.0.255 255.255.255.255 192.40.0.1 192.40.0.1 1

224.0.0.0 224.0.0.0 10.20.0.1 1 0.20.0.1 2

224.0.0.0 224.0.0.0 128.30.0.1 128.30.0.1 1

224.0.0.0 224.0.0.0 192.40.0.1 192.40.0.1 1

255.255.255.255255.255.255.255192.40.0.1 192.40.0.1 1

Default Gateway: 10.20.0.1

 

So was ich probieren will:

Es sollte in allen Subnetzen auf einen Drucker zugegriffen werden. Dieser befindet sich im 10.20.0.0 Netzwerk.

Über ping sollte ich alle Subnetze egal von welcher Adresse aus erreichen können. Der DCHP soll alle Netzwerke versorgen. Dabei habe ich eine Superscope mit 3 Scopes jeweils für jedes Netz eingerichtet. Geht nicht.

An bei die ipconfig:

Windows 2000 IP Configuration

Host Name . . . . . . . . . . . . : fileservw2k

Primary DNS Suffix . . . . . . . : als00018_TEST

Node Type . . . . . . . . . . . . : Hybrid

IP Routing Enabled. . . . . . . . : Yes

WINS Proxy Enabled. . . . . . . . : No

DNS Suffix Search List. . . . . . : test

Ethernet adapter 192.40.0.1 10 100MBit Administration:

Media State . . . . . . . . . . . : Cable Disconnected

Description . . . . . . . . . . . : 3Com EtherLink 10/100 PCI For

Ethernet adapter 10.20.0.1:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : Realtek RTL8169/8110 Family

DHCP Enabled. . . . . . . . . . . : No

IP Address. . . . . . . . . . . . : 10.20.0.1

Subnet Mask . . . . . . . . . . . : 255.255.255.224

Default Gateway . . . . . . . . . : 128.30.0.1

DNS Servers . . . . . . . . . . . : 10.20.0.1

128.30.0.1

192.40.0.1

Primary WINS Server . . . . . . . : 10.20.0.1

Secondary WINS Server . . . . . . : 128.30.0.1

Ethernet adapter 128.30.0.1:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : Realtek RTL8169/8110 Family

DHCP Enabled. . . . . . . . . . . : No

IP Address. . . . . . . . . . . . : 128.30.0.1

Subnet Mask . . . . . . . . . . . : 255.255.255.224

Default Gateway . . . . . . . . . : 10.20.0.1

DNS Servers . . . . . . . . . . . : 10.20.0.1

128.30.0.1

192.40.0.1

Primary WINS Server . . . . . . . : 10.20.0.1

Secondary WINS Server . . . . . . : 128.30.0.1

 

Das Problem ist: Zum ersten funktioniert das Routing hierbei nicht! Der Drucker ist im 10.20.0.0 Subnetz und es ist einfach nicht möglich diesen aus dem 128.30.0.0 Subnetz anzusprechen. Hatte bereits lt. MS das Gateway vom jeweiligen Netzwerk des anderen angegeben.

Worin liegt das Problem? An Class B zu C Netz oder fehlen hierbei Statische Routes? Oder liegt ein Design Problem vor?

 

So, auch wenn ich hier noch recht neu bin, freue ich mich über alle Infos Anregungen und Lösungsvorschlägen.

Gruss Klaus

Share this post


Link to post

Morgen nkm,

Vorab Frage hast du routen manuell hinzugefügt oder sind alle systemseitig aufgebaut worden.

Und ist Routing und RAS installiert.

 

thorgood

Share this post


Link to post

Moin thorgood,

so die Routings sind seitens des W2K Servers manuell eingegeben worden.

Die Routing und RAS wurden installiert.

Gruss Klaus

Benötigst du noch Angaben?

Share this post


Link to post

Als erstes würde ich den Default Gateway: 10.20.0.1 wieder entfernen der zeigt ja auf sich selbst.

 

Dann hatte ich die 192.40.0.1 im ipconfig gesucht habe sie aber gerade gefunden, sie hat nur kein link status. bitte mal connecten.

 

Dann sind mir die default(0.0.0.0) routen nicht klar denn die bedeuten ja für den router,

wenn du keinen direkten eintrag auf den host oder das netz in der routing-tabelle hast,

sende das paket an das gateway über das interface. Da müssen gateway und interface im gleichen netz liegen.

Das heisst er müsste z.b im ersten fall eine gateway 10.20.0.1 über das interface 128.30.0.1 erreichen und das geht nicht.

Also mal alle 0.0.0.0 routen löschen.

 

Da kein dem Server unbekanntes netz zu erreichen ist, müssten seine standard-eintrage die er selbst aufbaut reichen.

 

Die Frage welches Netz bevozugt genutzt wird hängt von der Client Configuration ab.

192.40.0.0 255.255.255.224 10.20.0.1 10.20.0.x metric 1

192.40.0.0 255.255.255.224 128.30.0.1 128.30.0.x metric 2

 

thorgood

Share this post


Link to post

Konfiguration Server

- Mit route -p delete 0.0.0.0 alle Routen ins Internet löschen

- In welchem Netz liegt das GW zum Internet? Nur bei dieser NWK des Servers die IP des Internet-GWs eintragen, bei den anderen beiden NWK kein GW eintragen, alternativ

+ route -p add 0.0.0.0 mask 0.0.0.0 IP Router metric 1 IF 0x0? ("?" mit Nummer Interface ersetzen, in dessen Netz das GW ins Internet liegt)

 

Konfiguration Clients/Drucker

- als S-GW die zum Netz gehörige IP des Servers eintragen, also für das 10.20.0er-Netz die 10.20.0.1, usw.

 

Konfiguration Internet-GW

Routen zu den beiden zusätzlichen Netzen mit GW Server-IP eintragen (nur notwendig, wenn die Clients in diesen Netzen auch ins Internet kommen sollen)

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...