Jump to content
Sign in to follow this  
Ciscler

ISDN mit Cisco 836 Router

Recommended Posts

Hallo,

 

habe hier einen Cisco 836 Router für eine ISDN Einwahl. Der Router wählt sich soweit auch ein.

 

Dort wo er angeschlossen wird muss ich eine Null davor wählen da der ISDN Anschluss über eine TK-Anlage läuft. Bin also einfach hingegangen und hab beim Dialer-String einfach eine Null davor geschrieben sprich "dialer string 00191011". Der Router wählt sich nun aber nicht ein mit debug ISDN events kommt die Meldung unfound B-Channel....

Der ISDN Anschluss ist aber geprüft worden er funktioniert.

 

Dann bin ich hingegangne und hab den Router direkt an den NTBA angeschlossen hab die zusätzliche 0 beim dialer string entfernt und siehe da er wählt sich ein.

 

Habt ihr irgendwelche Vorschläge woran es liegen könnte?

 

Config:

 

interface Ethernet0

description Inside

ip address 10.24.239.11 255.255.255.0

ip nat inside

no cdp enable

!

interface BRI0

description Outside

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface Dialer1

description Internet

ip address negotiated

ip access-group Outside in

ip nat outside

encapsulation ppp

dialer pool 1

dialer string 00191011

dialer-group 1

no cdp enable

ppp authentication pap chap callin

ppp chap hostname xxxxxxxxxxxxxxx

ppp chap password xxxxxxxxxxxxx

ppp pap sent-username xxxxxxxxx

ppp ipcp dns request

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

no ip http secure-server

ip nat inside source list 1 interface Dialer1 overload

!

!

ip access-list extended Outside

remark OUTSIDE

permit icmp any any

permit tcp any any established

permit udp any any

access-list 1 permit 10.24.239.0 0.0.0.255

dialer-list 1 protocol ip permit

no cdp run

!

control-plane

!

!

line con 0

login local

transport preferred all

transport output all

line vty 0 4

login local

transport preferred all

transport input all

transport output all

!

scheduler max-task-time 5000

no rcapi server

!

!

!

end

Share this post


Link to post

Hi,

 

häng den router an die anlage, dann show isdn status und show interface bri... posten

 

 

gruss

 

 

rob

Share this post


Link to post

Hallo,

 

bin jetzt leider nicht mehr vor Ort der Standort ist weiter weg den Router habe ich mitgenommen. Jetzt habe ich aber gerade erfahren das der 1 B Kanal von der Telefonanlage geblockt wird sprich der Cisco muss den 2 B Kanal für die Einwahl nehmen.

Macht er dies automatisch wenn der 1 gesperrt ist kann ich dem Router sagen das er nur über den 2 B Kanal raus wählen darf?

 

Gruß Dirk

Share this post


Link to post

Hi,

 

 

möglicherweise kannst du subinterfaces konfigurieren bri 0:1 und bri0:2, musst du mal probieren und eines von beiden ist es dann, hoffe ich, habe ich aber auch noch nie probiert, normalerweise müsstest du immer erst den einen freien kanal bekommen und könntest dann kein multilink machen. oder hängt da noch ein anderes gerät mit dran, das den einen freien kanal benutzt hat?

 

 

gruss

 

 

rob

Share this post


Link to post

Ja da hängt noch ein anderes Gerät dran.

Auf dem ISDN Port werden immer 2 MSN konfiguriert von der Anlage.

Jetzt kann ich doch auf dem Bri interface sagen "isdn calling-number msn" dann müsste er doch darüber immer raus wählen oder?

Share this post


Link to post

das ist richtig, er wählt aber nur raus, wenn der eine zur verfügung stehende kanal auch frei ist oder ist ein kanal pro gerät programmiert?

 

 

gruss

 

rob

Share this post


Link to post

Hallo,

 

wir haben das jetz hier mal nach Simuliert. Einen ISDN Anschluss Telefon mit MSN 23 (abgenommen so das das Telefon einen Kanal belegt) angeschlossen und den Cisco. Der Router wählt sich ein. Wenn ich jetzt hingehe das Telefon mit MSN 22 anschließe und den hörer abnehme wählt sich der Cisco nicht mehr ein. Dann bin ich hingegangen und habe auf dem Bri 0 Interface "isdn calling-number 23" angegeben.

 

Hier mal ein Paar Logs hoffe ihr könnt damit was anfangen:

 

Sending 5, 100-byte ICMP Echos to 195.202.38.140, timeout is 2 seconds:

 

*Mar 1 00:33:57.551: ISDN BR0 SERROR: L2_Go: at bailout DLCB is NULL

L2: sapi 0 tei 65 ces 255 ev 0x63

*Mar 1 00:33:57.575: ISDN BR0 SERROR: L2_Go: at bailout DLCB is NULL

L2: sapi 0 tei 65 ces 255 ev 0x1

*Mar 1 00:33:57.723: ISDN BR0 Q931: RX <- SETUP_ACK pd = 8 callref = 0x81

Channel ID i = 0x89

Progress Ind i = 0x8088 - In-band info or appropriate now available

*Mar 1 00:33:57.723: ISDN BR0 SERROR: L2_Go: at bailout DLCB is NULL

L2: sapi 0 tei 65 ces 255 ev 0x0

*Mar 1 00:33:58.863: ISDN BR0 EVENT: UserIdle: callid 0x8017 received ISDN_CALL (0x0)

*Mar 1 00:33:58.863: ISDN BR0 EVENTd: UserIdle: Call to 00191011 at 64 Kb/s

*Mar 1 00:33:58.863: ISDN BR0 SERROR: isdn_get_guid: Cannot allocate a GUID (5)

*Mar 1 00:33:58.867: ISDN BR0 EVENTd: isdn_get_guid: Got Guid 00C19628FFFF

*Mar 1 00:33:58.867: ISDN BR0 EVENT: process_bri_call: call id 0x8017, called_number 0019

1011, Guid 00C19628FFFFspeed 64, call type DATA, calling_number none

*Mar 1 00:33:58.867: ISDN BR0 EVENTd: pr.ocess_bri_call: No name in GTD

*Mar 1 00:33:58.871: ISDN BR0 EVENTd: calltrkr_setup_received: isdn_info=2172418972l, cal

l_id=0x8017 ORIGINATE

*Mar 1 00:33:58.871: ISDN BR0 EVENTd: calltrkr_setup_received: calltracker disabled

*Mar 1 00:33:58.875: ISDN BR0 Q931: TX -> SETUP pd = 8 callref = 0x14

Bearer Capability i = 0x8890

Standard = CCITT

Transer Capability = Unrestricted Digital

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x81

Called Party Number i = 0x80, '00191011'

Plan:Unknown, Type:Unknown

*Mar 1 00:33:59.043: ISDN BR0 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x94

Cause i = 0x81A2 - No circuit/channel available

*Mar 1 00:33:59.047: ISDN BR0 BACKHAUL: L3IF_rx_L2_pak: received data 0x0801945A080281A2

*Mar 1 00:33:59.051: ISDN BR0 EVENT: process_rxstate: ces/callid 1/0x8017 calltype 1 HOST

_DISCONNECT_ACK

*Mar 1 00:33:59.051: ISDN BR0 EVENTd: process_rxstate: cause=0x22 (34), cause_present=1

*Mar 1 00:33:59.051: ISDN BR0 EVENTd: call.trkr_call_cleared: isdn_info=0x817C7B9C, call_

id=0x8017

*Mar 1 00:33:59.051: ISDN BR0 **ERROR**: host_disconnect_ack: Unfound B-channel on Discon

nect_Ack call id 0x8017..

*Mar 1 00:34:05.735: ISDN BR0 SERROR: L2_Go: at bailout DLCB is NULL

L2: sapi 0 tei 65 ces 255 ev 0x1.

Success rate is 0 percent (0/5)

Share this post


Link to post

rou-glt-1#

*Mar 1 00:34:07.315: ISDN BR0 Q931: RX <- DISCONNECT pd = 8 callref = 0x81

Cause i = 0x80EF - Protocol error; unspecified

Progress Ind i = 0x8088 - In-band info or appropriate now available

*Mar 1 00:34:07.315: ISDN BR0 SERROR: L2_Go: at bailout DLCB is NULL

L2: sapi 0 tei 65 ces 255 ev 0x0

*Mar 1 00:34:15.323: ISDN BR0 SERROR: L2_Go: at bailout DLCB is NULL

L2: sapi 0 tei 65 ces 255 ev 0x1

*Mar 1 00:34:20.235: ISDN BR0 SERROR: L2_Go: at bailout DLCB is NULL

L2: sapi 0 tei 65 ces 255 ev 0x1

*Mar 1 00:34:20.275: ISDN BR0 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x81

Cause i = 0x809F - Normal, unspecified

*Mar 1 00:34:20.275: ISDN BR0 SERROR: L2_Go: at bailout DLCB is NULL

L2: sapi 0 tei 65 ces 255 ev 0x0

*Mar 1 00:34:27.791: ISDN BR0 SERROR: L2_Go: at bailout DLCB is NULL

L2: sapi 0 tei 65 ces 255 ev 0x63

*Mar 1 00:34:28.863: ISDN BR0 EVENT: UserIdle: callid 0x8017 received ISDN_HANGUP (0x1)

*Mar 1 00:34:28.863: ISDN BR0 EVENTd: process_disconnect: call id 0x8017, call type is DA

TA, b_idb 0x817C61D0, ces 1, cause Normal call clearing(0x10)

*Mar 1 00:34:28.863: ISDN BR0 EVENTd: calltrkr_call_disconnected: isdn_info=0x817C7B9C, c

all_id=0x8017

*Mar 1 00:34:28.863: ISDN BR0 EVENTd: process_disconnect: Raw Release Message 0x050001801

7040802FF9008028090

*Mar 1 00:34:28.867: ISDN BR0 **ERROR**: CCBRI_Go: NO CCB Src->HOST call id 0x8017, event

0x5 ces 1

*Mar 1 00:34:28.867: ISDN BR0 EVENT: process_rxstate: ces/callid 1/0x8017 calltype 1 HOST

_QUERY_RESPONSE

rou-glt-1#

rou-glt-1#

*Mar 1 00:34:46.551: DSL: Connection has reached max retries, toggle to other mode

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 195.202.38.140, timeout is 2 seconds:

 

*Mar 1 00:07:54.347: ISDN BR0 EVENT: UserIdle: callid 0x8011 received ISDN_CALL (0x0)

*Mar 1 00:07:54.347: ISDN BR0 EVENT: process_bri_call: call id 0x8011, called_number 0191

011, Guid 00C5C518FFFFspeed 64, call type DATA, calling_number none

*Mar 1 00:07:54.411: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 65 changed to up.

*Mar 1 00:07:54.615: ISDN BR0 EVENT: process_rxstate: ces/callid 1/0x8011 calltype 1 HOST

_INFORMATION.!

*Mar 1 00:07:57.843: ISDN BR0 EVENT: process_rxstate: ces/callid 1/0x8011 calltype 1 HOST

_ALERTING

*Mar 1 00:07:57.971: ISDN BR0 EVENT: process_rxstate: ces/callid 1/0x8011 calltype 1 HOST

_CONNECT

*Mar 1 00:07:57.971: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up

*Mar 1 00:07:57.979: %DIALER-6-BIND: Interface BR0:2 bound to profile Di1

*Mar 1 00:07:58.427: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 65 changed to do

wn

*Mar 1 00:07:58.439: ISDN BR0 EVENT: process_rxstate: ces/callid 1/0x8011 calltype 1 HOST

_DISCONNECT_ACK

*Mar 1 00:07:58.439: %ISDN-6-CONNECT: Interface BRI0:2 is now connected to 0191011 stacki

ng

*Mar 1 00:07:58.439: %LINK-3-UPDOWN: Interface BRI0:2, changed state to down.

*Mar 1 00:07:58.443: %DIALER-6-UNBIND: Interface BR0:2 unbound from profile Di1

*Mar 1 00:08:00.395: ISDN BR0 EVENT: UserIdle: callid 0x8012 received ISDN_CALL (0x0)

*Mar 1 00:08:00.395: ISDN BR0 EVENT: process_bri_call: call id 0x8012, called_number 0191

011, Guid 00C5C518FFFFspeed 64, call type DATA, calling_number none

*Mar 1 00:08:00.459: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 66 changed to up.

Success rate is 20 percent (1/5), round-trip min/avg/max = 52/52/52 ms

rou-glt-1#

*Mar 1 00:08:00.671: ISDN BR0 EVENT: process_rxstate: ces/callid 1/0x8012 calltype 1 HOST

_DISCONNECT_ACK

*Mar 1 00:08:00.675: ISDN BR0 **ERROR**: host_disconnect_ack: Unfound B-channel on Discon

nect_Ack call id 0x8012

*Mar 1 00:08:04.479: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 66 changed to do

wn

Share this post


Link to post

Nachdem ich im Bri 0 Interface "isdn calling-number 23" eingegeben habe und den Ping abgesetzt habe ging ja wie man sieht ein Ping durch dann bricht er aber wieder ab.

Share this post


Link to post

Hi,

 

 

finde aber gar keinen connect, wie kann da ein ping durchgehen? die eine antwort <<_INFORMATION.!>> war eher da, als der dialer connected war?! Telefon und Router dürfen nicht die gleiche MSN haben, sonst können Sie auf Layer 3 Ebene nicht addressiert werden, es sei denn es wird das Voice/daten bit ausgewertet, das hängt von den geräten und der telefonanlage ab...

 

 

gruss

 

rob

Share this post


Link to post

Hier geht doch ein Ping durch:

 

*Mar 1 00:08:00.395: ISDN BR0 EVENT: process_bri_call: call id 0x8012, called_number 0191

011, Guid 00C5C518FFFFspeed 64, call type DATA, calling_number none

*Mar 1 00:08:00.459: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 66 changed to up.

Success rate is 20 percent (1/5), round-trip min/avg/max = 52/52/52 ms

rou-glt-1#

 

Mit dem Befehl "isdn calling-number 23" auf dem bri 0 interface verwendet der Router die MSN 23 richtig ?

Share this post


Link to post

richtig, wenn das die telefonanlage auswertet,

 

mit isdn answer1 23 würde er auch auf die 23 hören...

 

 

die eine "antwort" hatte ich auch gefunden, aber dein dialer war nicht connected... oder da ist irgendwo zeitversatz drin

Share this post


Link to post

da gabs grad noch nen isdn threat, versuch doch spassenshalber auch mal einen statischen TEI zu vergeben?! weil bei dir im log ähnliche fehlermeldungen auftauchen auf dem layer 2

Share this post


Link to post

Danke erstmal am Montag wird erstmal die Telefonanlage überprüft ich denke nicht das es am Cisco liegt.

 

Gruß Dirk

Share this post


Link to post

auch bei cisco gibt es bugs... gerade das isdn wird in amerika sehr stiefmütterlich behandelt...

 

gruss

 

rob

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...