Jump to content
Sign in to follow this  
kaineanung

auto. in Domäne aufnehmen: netdom bringt Fehlermeldung

Recommended Posts

Hallo,

 

habe ein Problem beim Aufnehmen eines PC in die Domäne mit NETDOM.exe.

 

Ich bekomme immer die Meldung

 

'Es sind mehr Daten verfügbar'

 

und eine kurze Zeit später:

'The command faild to complete successfully'

 

 

Kann mir einer Sagen was da los sein könnte ?

 

DC: Windows 2003

Client: XP SP2

 

(Netodom.exe wurde auf den Client per copy übertragen....kann es sein dass das so nicht geht?)

Share this post


Link to post

Ja klar, das hätte ich noch posten sollen:

 

Ich habe folgende Batchdatei:

 

net use * /d /y

NETDOM join %computername% /Domain:meineDomain /UserD:Administrator /PasswordD:***** /OU:"OU=Computer,OU=TEST,DC=dt,DC=local"

 

Ich bin als lokaler Administrator auf dem PC, der in die Domäne soll, angemeldet.

 

1. Schritt: alle Verbindungen kappen

2. Schritt: PC in die Domäne aufnehmen (Logindaten sind korrekt), OU sagt mir nicht viel, bin Anfänger :shock:

Share this post


Link to post

Tatsache, ohne OU-Parameter funktioniert es....

 

OU=AD-Gruppen ? Da ich keine habe konnte er nicht in der Angegebenen Objekte erstellen, oder ?

 

Wie auch immer, besten Dank......das Forum ist gleich in meinen Favoriten gelandet....

Share this post


Link to post

Nein , OU heisst Organizational Unit, also Organisationseinheit. Wenn Du also unterhalb der Domäne, die z.B. TEST.DE heisst, eine OU engelegt hast, die "Computerkonten-TEST" heisst, dann wäre der OU-Parameter

OU=Computerkonten-TEST,DC=TEST,DC=DE

Dort würde das Objekt dann erzeugt werden und nicht im Default Container "Computers"

Share this post


Link to post

Jo genau...stell dir eine OU mehr als einen Container in dem Objekte sind vor...und nicht wie eine Gruppe. Ein User z.b. kann in mehreren Gruppen sein, aber nur in einer OU.

Share this post


Link to post

Hallo,

 

ich hätte doch noch ein kleines Problemchen mit der Batch:

 

wenn ich die Netzwerkverbindungen kappen will blinkt plötzlich mein Explorer und fordert Anmeldename und Passwort auf.

Beim ausführen des Scripts befindet sich der Explorer noch im Netzwerk und zeigt den Inhalt eines Verzeichnises auf dem Server (Batchdateien-Verzeichnis von wo ich diese lokal rüberkopiere). Was kann ich machen dies zu unterdrücken ?

Wenn ich die geforderten Daten eingebe springt er in ein Verzeichnis welches ich nie und nimmer benötigte....??!?!? Wie auch immer, der Ablauf der Batch bricht dieser Stelle ab...

 

Ich benutze folgenden Befehl:

 

net use * /d /yes

 

Ich würde gerne alles automatisieren sodass ich nichteinmal den Explorer vor dem Batchablauf beenden muss......muss doch irgendwie gehen, oder ?

Share this post


Link to post

mhm...im notfall kannst ja den explorer vorher in der batch killen...

sonst weiß ich auch nicht, warum du beim entfernen der netzlaufwerke nach nem user gefragt wirst...

Share this post


Link to post

Explorer killen ?

Hört sich gut an....

 

Bevor ich jetzt wieder lange Google kannst du mir nicht zufällig den Befehl sagen ?

 

Nebenbei bräuchte ich auch noch den netdom-Befehl (bzw. Parameter) um einen bestimmten PC aus der Domäne rauszunehmen......wenns geht

 

 

Danke

Share this post


Link to post

ich nehm dazu einfach immer die kill.exe...googelt einfach danach und zieh sie dir.

 

und wegen netdom: schonmal netdom /? probiert?

Share this post


Link to post

Ich habe noch ein kleines Problemchen:

 

Wenn ich per netdom ein Rechner in die Domäne aufnehme wird dieser im AD mit einem roten Kreuz angezeigt -> deaktiviert.

 

Was mache ich da falsch bzw. wie kann ich ein PC in die Domäne aufnehmen sodass dieses Computerkonto aktiv ist ?

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...