Jump to content
Melde dich an, um diesen Inhalt zu abonnieren  
willingness

Exchange 2007: OAB kann nicht heruntergeladen werden (0X8004010F)

Empfohlene Beiträge

Seit wir auf Exchange 2007 (Single Server) gewechselt haben, haben wir das Problem, dass die Clients (Outlook 2003 & 2007) im Cache Mode das Offlineadressbuch nicht herunterladen können.

Im Outlook Ordner Synchronisierungsprobleme steht die Meldung:

 

07:40:03 Synchronisiererversion 12.0.4518

07:40:03 Postfach "Administrator" wird synchronisiert

07:40:03 Hierarchie wird synchronisiert

07:40:03 Vorgang abgeschlossen

07:40:08 Microsoft Exchange-Offlineadressbuch

07:40:08 Die Offlineadressbuchdateien werden nicht heruntergeladen. Es wurde kein Server (URL) gefunden.

07:40:08 0X8004010F

 

Google hat eine Menge an Lösungsvorschlägen, da dieses Problem wohl verbreitet ist.

Allerdings gelten diese fast immer für Exchange 2003 und lassen sich nicht auf Exchange 2007 übertragen.

 

Ich habe nun in einer Testumgebung eine frische Installation von Windows Server 2003 R2 & Exchange Server 2007 aufgesetzt.

Bei der Installation habe ich angegeben, dass kein Outlook 2003 mehr vorhanden ist, entsprechend wurde also kein Second Storage Group für Public Folder Database erstellt.

Übers LAN ist nun ein Outlook 2007 im Cache Mode verbunden. Aber auch hier kommt sofort die Fehlermeldung in Synchronisierungsprobleme.

 

Ich weiß nun nicht mehr weiter und hoffe, dass mir jemand von Euch helfen kann.

 

Sebastian

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

 

hast Du das OAB auf den Exchange Server 2007 verschoben? Hast Du das OAB manuell aktualisiert?

 

Ein Outlook 2003 braucht zwingend öffentliche Ordner - denn von dort aus wird das OAB für alle Outlook Versionen vor Outlook 2007 bereitgestellt.

 

Ist der Ordner "ExchangeOAB" unter C:\Progamme\Microsoft\ mit Inhalt gefüllt?

 

User7070

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Hast Du das OAB auf den Exchange Server 2007 verschoben? Hast Du das OAB manuell aktualisiert?

 

Nein, zumindest bei der Testumgebung ist alles jungfräulich.

 

Ein Outlook 2003 braucht zwingend öffentliche Ordner - denn von dort aus wird das OAB für alle Outlook Versionen vor Outlook 2007 bereitgestellt.

 

In der Testumgebung habe ich keine Öffentliche Ordner und kein Outlook 2003, um den Fehler einzugrenzen. In einer reinen 2007 Umgebung tritt der Fehler also genauso auf.

 

Ist der Ordner "ExchangeOAB" unter C:\Progamme\Microsoft\ mit Inhalt gefüllt?

 

Ja, der typische Ordner mit einem generierten Namen in dem 102 LZX Dateien und eine oab.xml Datei sind.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich habe heute Abend mal den Exchange Server 2007 VHD, also den vorkonfigurieren virtuelle Server vom MS laufen lassen und auf einem Laptop Outlook 2007 im Cache Mode verbunden.

Erstens wollte ich wissen, ob auch da der Fehler auftaucht und zweitens, wenn er das nicht macht, die dann runtergeladenen oab Dateien vom Client sichern und die dem echten Outlook Profil ins ost Verzeichnis reinlegen. Angeblich versucht dann nämlich Outlook nicht mehr (und leider nur dann) das OAB runterzuladen, wenn man in den Übermittlungseinstellungen „Offlineadressbuch runterladen“ ausmacht.

Aber: Es kommt genau der selbe Fehler!

Mich bringt das nicht wirklich weiter. Aber vielleicht jemand anders? :confused:

 

Kann mir vielleicht mal jemand die runtergeladenen (natürlich leeren) oab Dateien schicken?

Evtl. hat ja jemand gerade eine Testumgebung laufen, in der keine sensiblen Daten gespeichert sind.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo

 

Die haben mir auch schon geholfen. Ich habe ein Feedback in den Blogg geschrieben, hab da was ähnliches gehabt wie in nem blogg von denen. S dauert halt manchmal n bissel und is auf englisch.

 

Gruss,

Matthias

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

hallo zusammen.. ich schliesse mich hier mal dem beitrag an.

habe gestern nacht einen Ex2K3 auf einen Ex2K7 verschoben... alles prima bis auf den

besagten Fehler....

nun habe ich auch schon alles mmoegliche durchgegoogelt aber keine

loesung brachte hilfe!

 

die clients hier laufen auf Outlook 2003 SP2... Aber auch meine workstation mit OL2007

will nicht.

 

dankbar fuer jedes update! ;)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich habe es mittlerweile hinbekommen, allerdings nur in einer reinen 2007er Umgebung.

Der Fehler war bei mir, dass das Zertifikat nur auf die <domian> ausgestellt war, nicht auf autodiscover.<domain>.

Das ist bei Exchange 2007 mit Outlook 2007 wichtig, da Autodiscover Outlook 2007 das OAB zeigt. Wenn Autodiscover wegen eines ungültigen Zertifikats nicht funzt, dann kommt die 0X8004010F Meldung.

Allerdings habe ich es testeshalber auch mit einer gemischten Umgebung (mit Outlook 2003) probiert, aber dort hat das schon wieder nicht gefunzt. Ich habe es da nicht weiter verfolgt, da ich es nur aus Interesse probiert habe und echt die Schnauze voll hatte von diesem ewigen Zertifikat Mist. :mad:

 

Um Autodiscover im Zertifikat mit einzuschließen, muss entweder bei der Zertifikaterstellung über die Shell „-IncludeAutoDiscover“ nach der domain angehangen werden, oder gleich die autodiscover.<domain> zusätzlich angegeben werden. (s.u.)

Das Zertifikat ist dann also für zwei Domains gültig, was bei einem gekauften leider auch meist das Doppelte kostet. (Mir egal, da wir nur eigene nutzen)

Für meinen dyndns Exchange Server musste ich also als domain angeben:

 

New-ExchangeCertificate -generaterequest:1 -domainname xxx.no-ip.com -IncludeAutoDiscover -privatekeyexportable:1 -path c:\certreq.txt

 

oder eben:

 

New-ExchangeCertificate -generaterequest:1 -domainname xxx.no-ip.com, autodiscover.xxx.no-ip.com -privatekeyexportable:1 -path c:\certreq.txt

 

Hier ist alles noch mal bestens erklärt: The Exchange 2007 Wiki - cascert

 

Ich hoffe, dass es bei Dir auch am Zertifikat liegt, denn es scheint eine Menge weiterer Fehlerquellen zu geben.

Ist das OAB aber korrekt generiert und repliziert (bitte zuerst checken), ist es wahrscheinlich das oben beschriebene Problem.

 

Wenn das Zertifikat korrekt ist, dann sollte auch der E-Mail Autokonfigurationstest (Strg Rechtsklick auf Outlooksymbol in der Taskleiste) glatt durchgehen. Dazu aber eine E-Mail Adresse mit der im Zertifikat angegebenen Domain nehmen, also bei mir Administrator@xxx.no-ip-com, sonst funzt auch das wieder nicht.

 

 

Viel Glück!

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Tja, zu früh gefreut.

Bei einer weiteren Installation bei gleichem Vorgehen funzt es schon wieder nicht mehr.

 

Es ist ein Kreuz mit dem OAB. - Wieso kann man es nicht einfach abstellen?

Wir haben es noch nie gebraucht, aber seit Exchange 2003 nervt mich diese ewige 0X8004010F Sache.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

 

habe das gerade auch probiert - nachdem ich das OAB von Exchange 2003 auf den Exchange 2007 verschoben habe, habe ich das OAB direkt aktualisiert.

 

Alle öffentlichen Ordner und Systemordner verschoben. Postfächer ebenfalls verschoben.

 

Wichtig ist, dass das OAB auf dem Exchange 2003 einmal erstellt wird - ob nun manuell oder automatisch ist egal.

 

Exchange 2003 deinstalliert und bis jetzt habe keine Probleme festgestellt.

 

User7070

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ja also ich habe genau den gleichen Fehler.Hatte diesen auch schon hier rein gepostet. Und bist jetzt keine Lösung was das wirklich sein kann.

Ich habe auch Umstellung von 2003 auf 2007 durchgeführt und das OAB übernommen. Clients haben Outlook 2003 SP2. Aber halt immer die Fehlermeldung

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden
Melde dich an, um diesen Inhalt zu abonnieren  

×