Jump to content
Sign in to follow this  
Minti

IIS https aktivieren

Recommended Posts

Hallo zusammen.

Ich habe versucht https für meinen IIS zu aktivieren. Allerdings kann ich nicht per https auf den Server zugreifen. Folgende Einstellugen habe ich vorgenommen:

 

Webseite -> Erweitert -> Netzwerkadresse angegeben

Verzeichnissicherheit -> Bearbeiten -> Sicheren Kanal vorraussetzen

 

Anschließend habe ich den IIS neu gestartet. Wo ist der Fehler? (Eine Firewall ist nicht eingerichtet)

 

Gruß

 

Minti

Share this post


Link to post

Hallo,

 

vielleicht hast Du noch ein paar Zusatzinformationen zu Deiner Umgebung? Sonst wird eine Fehleranalyse eher schwierig. ;)

 

SSL-Zertifikat ist korrekt installiert?

 

Gruß olc

Share this post


Link to post

Ich habe eine Zertifizierungsinstanz auf diesem Rechner und wollte das Root Zertifikat verwenden. Dieses wird auch angezeigt im IIS.

Share this post


Link to post

Hallo,

 

wo genau wird das Zertifikat im IIS "angezeigt"?

 

Was heißt, daß Du nicht zugreifen kannst? Was wird Dir im Browser angezeigt, wenn Du Dich per https verbindest?

 

Gruß olc

Share this post


Link to post

Das Zertifikat wird unter Standardwebseite -> Eigenschaften -> Verzeichnissicherheit -> Zertifikat anzeigen angezeigt.

 

Im Firefox bekomme ich dann die Meldung:

 

Fehler: Datenübertragung unterbrochen

 

Im Internet Explorer:

 

Die Webseite kann nicht angezeigt werden.

Share this post


Link to post

Von wo aus versuchst Du den Zugriff? Von einem Client?

Versuch doch mal bitte direkt vom Server aus die Seite aufzurufen. Unter Umständen ist in den Proxy-Settings Deines Clients etwas nicht korrekt eingestellt.

 

Wird Dir das Zertifikat auf dem richtigen virtuellen Verzeichnis angezeigt bzw. auf der übergeordneten Webseite? Soll heißen - liegt es überhaupt im korrekten Bereich?

 

Viele Grüße

olc

Share this post


Link to post

Vom Server aus ist es ebenfalls nicht möglich.

 

Das Zertifikat liegt im Bereich der Standardwebseite dort wo es hin soll.

 

Habe es nun auch in anderen Bereichen versucht aber das funktioniert ebenfalls nicht.

Share this post


Link to post
und wollte das Root Zertifikat verwenden

 

Das kann für SSL nicht verwendet werden.

 

Erstelle dir ein neues Zertifikat mit dem Verwendungszweck "Server-Authentifizierung" bzw. Webserver und weise dieses zu.

 

Christoph

Share this post


Link to post

Mh, komisch. Die HTTP-Seiten kannst Du aber problemlos aufrufen?

Schau doch mal in die Logfiles des IIS --> vielleicht findest Du dort einen Hinweis?

 

Läuft vielleicht zusätzlich etwas auf dem Server / den Clients, was den Verkehr blocken könnte (z.B. Firewalls, IIS URLScan etc.)?

 

[EDIT] Aua, das mit dem Root-Cert habe ich glatt überlesen... [/EDIT]

 

Gruß olc

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...