Jump to content

Sebastian R

Members
  • Content Count

    101
  • Joined

  • Last visited

Community Reputation

10 Neutral

About Sebastian R

  • Rank
    Newbie
  1. So nochmal Rückmeldung: die grace period für den Shutdown habe ich verlängert. Dadurch kommt es nicht mehr zu den Fehlermeldungen auf den Gästen wenn der Host neu gestartet wird. Die Ursache warum die Gäste nicht, oder zumindest nicht zuverlässig, starten konnte ich auf die Starverzögerung zurückführen. Sobald dort ein Wert größer als 0 Sekunden eingetragen wird, startet der Gast nach einem Host-Neustart nicht (oder nur manchmal). Hat jemand dafür eine Erklärung?
  2. Danke für Eure Antworten. Ich glaube das geht schon in die Richtung, dass der Host zu schnell herunterfährt. Eben habe ich mal eine virtuelle Maschine gespeichert und anschließen wieder gestartet was ohne Fehler geschah. Ich werde mal dies ausprobieren, ggf. auch das was dort ind en Kommentaren gesagt wurde: https://www.altaro.com/hyper-v/extending-hyper-vs-guest-grace-period-host-shutdown/
  3. Sorry, dass ich mich erst jetzt wieder melden. Ich habe weiter "experimentiert", den Hyper-V Host kann ich nicht nach Belieben einfach neu starten. Es gab einige ältere Einträge in den Hyper-V Anwendungs-und Dienstprotokollen die auf mangelnden Arbeitsspeicher hinwiesen. Dies versuchte ich durch einen zeitversetzten Start der VM's zu beheben. Und scheinbar war genau das die Ursache für den unzuverlässigen Start der Gäste nach einem Reboot des Host! Jetzt sind alle drei VMs auf starten ohne Verzögerung eingestellt und sie werden nach einem Reboot vom Host nun auch alle zuverlässig gestartet. Nur was mir auffällt: meldet man sich dann auf einem der Gäste an, bekommt man einen Hinweis, dass der Computer unerwartet heruntergefahren wurde. Kann ich diesen Fehler getrost ignorieren oder wie kann ich ihne beheben? Wie gesagt, die Stop-Aktion bei den VMs ist auf speichern gestellt und alle Integrationsdienste sind verfügbar.
  4. Das hatte ich schon versucht (je 300 sek verzögert), leider ohne Besserung,
  5. Auf meinem HP Microserver Gen8 (G1610T, 16GB RAM) ist Windows Server 2016 als Host-OS installiert. Darauf laufen drei Gast-Betriebssysteme: zwei Windows Server 2016 VMs und einmal Ubuntu 16.04. Diese sind auch alle gleich konfiguriert: dyn. RAM (startup: 2GB, min: 1GB, max: 4GB), Stopaktion: speichern, Startaktion: immer starten, alle Integrationsdienste verfügbar. Nun ist es so, dass wenn der Host neu startet die Gäste nicht oder nur unzuverlässig gestartet werden. Sie bleiben dann in dem Status "gespeichert" und ich kann Sie auch über den Hyper-V Manager ohne Probleme bzw. Fehlermeldungen manuell starten - das funktoniert. Ich bin ziemlich ratlos wie ich die Ursache für dieses Verhalten herausfinden kann?!
  6. Seltsamerweise ist seit einigen Tagen bei den Clients (bisher nur Win10 getestet) die Netzwerkumgebung leer, es heißt es werden dort keine anderen Rechner, NAS etc angezeigt. Außer der eigene Computer und ein Win7 Client der nicht Mitglied in der Domäne ist. Aber alle anderen Windows-Clients, NAS etc. fehlen. Es handelt sich um eine Domäne mit Win2016 Server die u.a. DHCP, DNS, WINS und AD bereitstellen. Auf den Servern sind komischerweise alle Clients im Netzwerk brav aufgelistet in der Netzwerkumgebung! DNS funktioniert ebenfalls auf den Clients: ping auf hostname und FQDN geht. Ebenfalls per UNC Pfad (sowohl über den Computernamen als auch über die IP) kommt man auf die Freigaben. Per DHCP bekommen die Clients u.a. den WINS server übergeben und den Knotentyp (hybrid). Das ganze lief ja auch problemlos bis vor wenigen Tagen ohne dass etwas an der Konfiguration geändert wurde, lediglich Updates installiert.
  7. Da alle FSMO Rollen, also auch PDCE, auf den neuen Server umgezogen sind (siehe #1). Und nur diesen sollten die Clients als Zeitquelle nehmen.
  8. Und auch alle Clients nehmen als Zeitquelle weiterhin den alten Server. :nene:
  9. Danke für den Hinweis. Die Anleitung habe ich abgearbeitet, trotzdem taucht in der Ereignisanzeige immer wieder Event 144 auf. Das wechselt sich ab mit Event 143 (Der Zeitdienst wird als gute Zeitquelle angekündigt). :confused:
  10. Ich greife das nochmal auf, weil ich im Eventlog des neuen virtuellen DCs noch immer regelmäßig die ID 144 (Time-Service). Bei den Integrationsdiensten habe ich die Zeitsynchronisation schon deaktiviert. Dann auf externe Synchronisation umgestellt: reg add HKLM\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\VMICTimeProvider /v Enabled /t reg_dword /d 0 w32tm /config /manualpeerlist:"0.pool.ntp.org,0x1" /syncfromflags:MANUAL /reliable:yes w32tm /config /update w32tm /resync w32tm /resync /rediscover Danach mit /query /status und /query /source überprüft sieht auch alles gut aus. Nach einem Neustart jedoch habe ich wieder Lokal / CMOS Uhr als Zeitquelle. :confused:
  11. Danke für die schnelle Antwort! Auf dem alten Server sind die Optionen 02, 03, 06, 15, 42, 44, 46 und 66 definiert in den Bereichsoptionen (nicht Serveroptionen). Wie kann ich prüfen ob da auf dem alten Server zusätzliche Klassen angelegt wurden? Auf beiden Servern finde ich nur: Standard DHCP Options, Microsoft Windows 2000 Options, Microsoft Windows 98 Options und Microsoft Options. So, Problem "gelöst": über das GUI (Sichern & Wiederherstellen) hat der Umzug ohne Probleme geklappt.
  12. Ich möchte DHCP von meinem alten 2012 Server auf den neuen Server (2016) übertragen. Dabei habe ich mich an diese Anleitung gehalten: https://technikblog.rachfahl.de/losungen/migration-eines-dhcp-servers-von-windows-server-2008-r2-auf-windows-server-2012-r2/ Beim Import der Datei erhalte ich diese Fehlermeldung: import-dhcpserver : Fehler beim Hinzufügen der Optionsdefinition "1" auf dem DHCP-Server "w16-dc.home.local".: Der verwendete Klassenname ist ungültig. (20044) In Zeile:1 Zeichen:1 + import-dhcpserver -computername w16-dc.home.local -leases -file C:\sy ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : ObjectNotFound: (1:root/Microsoft/...ptionDefinition) [Import-DhcpServer], CimException + FullyQualifiedErrorId : DHCP 20044,Import-DhcpServer import-dhcpserver : Fehler beim Hinzufügen der Optionsdefinition "2" auf dem DHCP-Server "w16-dc.home.local".: Der verwendete Klassenname ist ungültig. (20044) In Zeile:1 Zeichen:1 + import-dhcpserver -computername w16-dc.home.local -leases -file C:\sy ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : ObjectNotFound: (2:root/Microsoft/...ptionDefinition) [Import-DhcpServer], CimException + FullyQualifiedErrorId : DHCP 20044,Import-DhcpServer import-dhcpserver : Fehler beim Hinzufügen der Optionsdefinition "3" auf dem DHCP-Server "w16-dc.home.local".: Der verwendete Klassenname ist ungültig. (20044) In Zeile:1 Zeichen:1 + import-dhcpserver -computername w16-dc.home.local -leases -file C:\sy ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : ObjectNotFound: (3:root/Microsoft/...ptionDefinition) [Import-DhcpServer], CimException + FullyQualifiedErrorId : DHCP 20044,Import-DhcpServer import-dhcpserver : Fehler beim Hinzufügen der Optionsdefinition "1" auf dem DHCP-Server "w16-dc.home.local".: Der verwendete Klassenname ist ungültig. (20044) In Zeile:1 Zeichen:1 + import-dhcpserver -computername w16-dc.home.local -leases -file C:\sy ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : ObjectNotFound: (1:root/Microsoft/...ptionDefinition) [Import-DhcpServer], CimException + FullyQualifiedErrorId : DHCP 20044,Import-DhcpServer import-dhcpserver : Fehler beim Hinzufügen der Optionsdefinition "2" auf dem DHCP-Server "w16-dc.home.local".: Der verwendete Klassenname ist ungültig. (20044) In Zeile:1 Zeichen:1 + import-dhcpserver -computername w16-dc.home.local -leases -file C:\sy ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : ObjectNotFound: (2:root/Microsoft/...ptionDefinition) [Import-DhcpServer], CimException + FullyQualifiedErrorId : DHCP 20044,Import-DhcpServer import-dhcpserver : Fehler beim Hinzufügen der Optionsdefinition "3" auf dem DHCP-Server "w16-dc.home.local".: Der verwendete Klassenname ist ungültig. (20044) In Zeile:1 Zeichen:1 + import-dhcpserver -computername w16-dc.home.local -leases -file C:\sy ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : ObjectNotFound: (3:root/Microsoft/...ptionDefinition) [Import-DhcpServer], CimException + FullyQualifiedErrorId : DHCP 20044,Import-DhcpServer Scheinbar lässt sich diese Anleitung so nicht ohne weiteres auf Server 2016 anwenden. Hat jemand Ideen woran es liegt?
  13. In dem Artikel ist doch auch ein Verweis auf robocopy / Registry-Export. Aber wenns auch mit dem Tool klappt umso besser :)
  14. Auf manches trifft das sicher zu was ich momentan auch tue, z.B. Trennung von DC und FS. Die Struktur der Freigaben und deren Berechtigungen auf dem alten sind aber OK und sollen so übernommen werden. Da stelle ich mir die Frage wie das am einfachsten zu realisieren ist. Auf dem neuen FS alle Freigaben von Hand neu anlegen und auch einzeln die ganzen Berechtigungen setzen, dann per DFS replizieren? Das wird aufwendig... kann man das vereinfach / automatisieren? EDIT: Ich glaube schon das passende Tool gefunden zu haben: https://www.tech-faq.net/windows-server/fileserver-umziehen/
×
×
  • Create New...