Zum Inhalt wechseln


Foto

MS SQL Server login fehlgeschlagen


  • Bitte melde dich an um zu Antworten
4 Antworten in diesem Thema

#1 votex

votex

    Member

  • 128 Beiträge

 

Geschrieben 20. Juni 2005 - 10:09

Hallo, ich habe zum folgenden Problem schon jede Menge gegoogelt, nur ist die Lösung, welche dort dauernd angesprochen wird nicht wirklich einleuchtend (auf mixedmode umstellen)...

Also zum Problem:

Ich will über MS Access eine Verbindung zu meinem MS SQL-Server herstellen...richte hierfür eine neue ODBC-Verbindung ein. Gebe meinen Server an und versuche über TCP/IP zu verbinden. Jetzt der Fehler (offensichtlich findet er den Server, nur will er mir keinen Zugriff gewähren):

----------------------------------------------------------------------------------------------
Connection failed:
SQL-State: 28000
SQL Server Error: 18452
[Microsoft][ODBC SQL Server Driver][SQL Server]Fehler bei der Anmeldung für den Benutzer '(null)'. Ursache: Keiner vertrauten SQL-Server-Verbindung zugeordnet.
----------------------------------------------------------------------------------------------

Ich versuche mich hier über MS Windows NT authentication anzumelden, weil ich am Server nur diesen Mode aktiviert habe (kein mixedmode)...und das soll auch so bleiben.

Habe testweise einen Benutzer angelegt der sich direkt an meiner Domäne anmeldet (nicht lokal) und mit diesem konnte ich die Verbdg. problemlos herstellen. Der Benutzer ist angelegt und hat auch die benötigten Rechte...und ich weiß nicht warums plötzlich nicht mehr funktioniert! Letzte Woche noch einwandfrei und jetzt...!

Habe letzte Woche am Server das "Named Pipes" Protokoll deaktiviert, aber da ich sowieso über TCP/IP connecte (letze Woche natürlich auch schon), kanns ja daran nicht liegen. Seltsam ist allerdings das ich das jetzt bei 3 PC habe, und alle drei sind in einer Arbeitsgruppe..hatte sie aber auch schon in der "Arbeitsgruppe"meiner Domäne...und das Problem blieb. Es werden auch Abfragen von andren Rechnern getätigt, aber komischer Weise tritt der FEhler nur bei denen auf, die nicht in der Arbeitsgruppe mit dem Domänennammen sind....

Bitte um Vorschläge...
mfg
If you never try,
you´ll never know!

#2 ckarbach

ckarbach

    Newbie

  • 12 Beiträge

 

Geschrieben 20. Juni 2005 - 16:52

Hi votex,

falls ich Dich richtig verstanden habe hast Du folgende Konstellation:

1. SQL Server auf einem Server der Mitglied einer Domäne ist
2. Clients die auch in der Domäne Mitglied sind, deren User sich
auch in der Domäne authentifizieren und auf denen die Abfrage funktioniert
3. Clients die nicht Mitglied in der Domäne sind(Arbeitsgruppe) also eine
lokale Anmeldung benutzen und auf denen die Abfrage nicht funktioniert.

Wenn das alles stimmt hast Du folgendes Problem:

Der SQL Server nimmt von Hause aus die User aus der lokalen(Mitgliedsserver)-
bzw. Domänen(Domaincontroller)-Administratorengruppe als "BuilIn" User.
Diese haben also generell Rechte für den Zugriff.
Weiterhin kannst Du noch User anlegen bzw. hinzufügen.

Bei Usern die nicht Mitglied der Domäne sind fehlt im endeffekt einfach die Domänenkennung bei der Anmeldung.

Beispiel einer Domänenanmeldung am SQL:

User: Domäne\User1
Pwd: 12345678
(diese Informationen werden aus dem aktuellen Login ermittelt)

Beispiel einer Anmeldung ohne Domäne am SQL:

User: Computername\User
Pwd: 87654321

Wenn Du in der Sicherheit vom SQL Server die User der "Standalone" PCs hinzufügen kannst funktioniert es.

cu

ckarbach
Greetz

Christian

#3 votex

votex

    Member

  • 128 Beiträge

 

Geschrieben 21. Juni 2005 - 05:33

Danke für die AW....zu den Punkten folgendes:

1. Mein SQL-Server läuft auf meinem Domänencontroller
2. Die User im NW (bei denen d. Abfragen funktionieren), melden sich lokal an, sind aber Mitglied!
3. Die, bei denen es JETZT nicht mehr geht, sind/waren in einer Arbeitsgruppe. Habe versucht sie an der Domäne zu registrieren (dann, wie die anderen auch lokal angemeldet) und es hat nicht funktioniert. Nur wenn ich mich direkt an der Domäne anmelde (nicht lokal), geht es auch bei diesen Usern.

Die Zugriffsrechte hab ich auch überprüft und nichts gefunden!

Danke, mfg
If you never try,
you´ll never know!

#4 votex

votex

    Member

  • 128 Beiträge

 

Geschrieben 21. Juni 2005 - 08:19

Noch etwas, was vielleicht wichtig ist:
Habe Freitag einige Windows Updates installiert und musste den Server neustarten. Kann´s möglicherweise an den Updates liegen, dass die irgendwas in meinen allgemeinen Richtlinien überschrieben/geändert haben?!

Danke schon mal...
mfg
If you never try,
you´ll never know!

#5 votex

votex

    Member

  • 128 Beiträge

 

Geschrieben 21. Juni 2005 - 11:42

Wenn Du in der Sicherheit vom SQL Server die User der "Standalone" PCs hinzufügen kannst funktioniert es.



Das hab ich jetz mit 2 der 3 betroffenen PCs gemacht....und es klappt wunderbar..DANKE! Zum 3. komm ich noch nich ran...der Chef sitzt in ner Besprechung.... ;)

Wär der Tag gerettet... :D
If you never try,
you´ll never know!