Jump to content
Sign in to follow this  
xxxomxxx

RPC for Exchange

Recommended Posts

Ich scheitere an der Konfiguration des RPC Services mit Exchange, bei einem einzelnen Exchange server. Der Exchange server lässt nur die option als Backend RPC zu, nicht aber als Frontend...

 

wenn ich mich verbinde wenn "kein RPC Server" angeklickt ist, dann kommt eine Eingabeaufforderung, aber die Verbindung ist immer TCP/IP...

 

Interessant, bei Ofiice 12, also Outlook 2007, fragt er immer wieder nach dem benutzernamen, aber dieser wird nicht akzeptiert??

 

verbindung schlägt dann fehl, gleiches verhalten ob "kein RPC server" oder "backend" gewählt ist...

Share this post


Link to post

Schildere mal, wie du das RPC/HTTPS Profil am Outlook 2003 Client eingerichtet hast.

 

- Basic (Standard) Authentifizierung ausgewählt?

- msstd:<fqdn-des-exch-servers> für gegenseitige Auth. angegeben?

 

Zert.-Name wäre in der Tat auch ein Ansatz: der Common Name des Zerts. muss genau dem FQDN des Exchange Servers entsprechen.

 

Christoph

Share this post


Link to post

https://fqdn bezw. domain.ch

 

SSL: ja

 

schnell:ja

langsam:ja

 

mehr gibt es ja eigentlich nicht

 

ich habe jetzt mal denn fqdn als ganzen server angegeben, also servername.domain.ch

 

dann öffnet er outlook und verbindet sofort über TCP/IP

 

aber server.domain.ch könnte ich via internet nicht auflösen... (test im lLAN)

 

beim versuch rpccfg vom ResKit mit /hd auf dem server laufen zu lassen, kommt: error: expected ':' in string ''

Share this post


Link to post

wo hast du das https:// ... eingegeben, da wo gegenseitige Auth. abgefragt wird?

 

Wichtig ist, dass da msstd:<fqdn> steht! Sonst wird das nix!

 

Die Verbindung über Outlook sollte in dem Fenster Verbindungsstatus als HTTPS Verbindung angezeigt werden, nicht als TCP/IP.

 

Falls das aus dem INet erreichbar sein soll, würde ich mir mal Gedanken machen, das über einen ISA zu publizieren. Ausserdem brauchst Du dann Split-DNS. D.h., der FQDN des Exchange Servers muss von extern auf den ISA aufgelöst werden, und der ISA muss das intern auf den Exchange auflösen können.

 

Christoph

Share this post


Link to post

ok, also ich habe jetzt folgende einstellungen

 

[https://] server.domain.ch

 

nur SSL: ja

Verbindung nur mit Proxy...:JA

msstd:domain.ch

schnell:ja

langsam:ja

 

trotzdem verwendet er tcp/ip...

Share this post


Link to post

Dann check bitte noch mal die Keys in der Registry. Und ändere msstd:domain.ch auf msstd:server.domain.ch.

 

Das Zert. muss natürlich auch auf server.domain.ch ausgestellt sein.

Und noch was:

Der client muss das Zert. akzeptieren können, d.h., das Root-CA Zert. (und ggf. Zerts. von Intermediate CAs) muss/müssen dem Client bekannt sein.

 

Christoph

Share this post


Link to post

scheint als müste ich ein neues root CA erstellen, dieses lautet auf domain.ch

 

nehme an mann kann ein zweites CA zert erstellen..

 

aber für den Gebrauch aus dem itnernet müsste ich die FQDNs sowieso auf domain.ch anstatt server.domain.ch ändern, korrekt?

Share this post


Link to post
scheint als müste ich ein neues root CA erstellen, dieses lautet auf domain.ch

 

nehme an mann kann ein zweites CA zert erstellen..

 

Hmm, eigentlich nicht notwendig.

 

aber für den Gebrauch aus dem itnernet müsste ich die FQDNs sowieso auf domain.ch anstatt server.domain.ch ändern, korrekt?

 

Nein, das Zert. muss auf den Namen des Servers ausgestellt werden, nicht auf den Namen der Domain.

 

Ich weiß jetzt leider nicht, wie du vorhast, den Server im Internet zur Verfügung zu stellen, aber du könntest den Namen auch öffentlich verwenden, wenn Du Split DNS anwendest (wie ich oben schon mal angedeutet habe).

 

Dann muss der Servername (server.domain.ch) auch der Name des Zertifikats sein.

 

Christoph

Share this post


Link to post
Hmm, eigentlich nicht notwendig.

 

also einfach für die Default Web Site eine neues Zertifikat erstellen? in dem Bereich kenne ich mich nicht so gut aus...

 

Ich weiß jetzt leider nicht, wie du vorhast, den Server im Internet zur Verfügung zu stellen, aber du könntest den Namen auch öffentlich verwenden, wenn Du Split DNS anwendest (wie ich oben schon mal angedeutet habe).

 

Dann muss der Servername (server.domain.ch) auch der Name des Zertifikats sein.

 

 

Split DNS ???

Share this post


Link to post

Ja, genau. Ein neues Zert. für die Def. Website auf dem Exchange.

 

Split DNS ist etwas komplizierter. Hängt auch davon ab, wie du den Exchange veröffentlichen willst. Dazu hast Du noch nichts gesagt...

 

Christoph

Share this post


Link to post

ok, habe das alte Zertifikat entfernt, mit dem wizard ein neues mit common name server.domain.ch erstellt.

 

nun fragt er aber nach login daten beim start von outlook, da kann ich eingeben was ich will, es funktioniert nicht...

 

DOMAIN\User

Passwort

 

geht nicht

 

sieht man nicht in einem logfile was fehl geht?? wäre hier glaube ich hilfreich

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...