Jump to content
Sign in to follow this  
chrismueller

IIS 6 - Probleme bei Zertifikatsinstallation

Recommended Posts

Hallo zusammen,

 

ich hab hier einen IIS6 Webserver auf dem ein SSl-Zertifikat ausgelaufen ist. Ich hab mittlerweile ein neues Zertifikat von Verisign ( .cer-Datei ). Bloß leider keine Möglichkeit es zu installieren:

 

Da ich keine Aufforderung habe, habe ich versucht das Zertifikat nach folgendem Technet-Artikel zu installieren:

Microsoft Corporation

 

Leider gibt es in den Properties keine Registerkarte Details. Desweiteren wenn ich auf die Datei doppelklicke kommt der Fehler: Die Datei ist für folgende Verwendung ungültig.

 

Wie kann ich das Zertifikat installieren ?

Share this post


Link to post

Hi, und willkommen an Board :)

 

Rufe am Webserver die MMC auf und füge das Snap-In für Zertifikate hinzu. Während dieses Vorgangs fragt dich der Rechner, ob du User- oder Computer-Zerts. verwalten willst. Wähle Computer aus und dann "Lokaler Computer".

 

Anschließend klickst Du links im Baum "Persönliche Zertifikate" an, wählst aus dem Kontextmenu "Alle Aufgaben" / "Importieren" und gibts bei diesem Assistenten die .cer-Datei an.

 

Christoph

Share this post


Link to post

Jo, dann musst Du wohl der Website noch das neue Zertifikat zuordnen.

 

Das machst du im IIS-Manager:

Eigenschaften der Web-Site aufrufen, Tabreiter Verz.-Sicherheit, Serverzertifikat anklicken und dann "Bestehendes Zertifikat zuordnen" (oder ähnlich; im engl. heißt es im Assistenten "Assign an existing certifcate") auswählen und das von dir eben importierte Zertifikat anklicken.

 

Falls immer noch Fehler auftreten sollten, bitte hier wieder mit genauer Meldung posten.

 

Christoph

Share this post


Link to post

Das hab ich bereits vorhin schon gemacht.

 

Allerding funktioniert der Zugriff über SSL immer noch nicht. Fehlermeldung gabs beim importieren und bei dem zuweisen keine. Wenn ich die Seite ohne SSL aufrufe funktioniert sie, wenn ich sie mit ssl aufrufe kommt nur "This Page cannot be displayed". Ich hab auch schon den ganzen IIS resetted.

 

Was ich merkwürdifinde dass ich nun auch bei den Zertifikaten einen Eintrag von Verisign drin hab. Ich nehme an das es egal ist, das ich den SSL Port auf 3401 liegen habe.

Share this post


Link to post
Wenn ich die Seite ohne SSL aufrufe funktioniert sie, wenn ich sie mit ssl aufrufe kommt nur "This Page cannot be displayed".

 

Ist das ein Fehler 404? Oder ein Fehler 500? Poste mal die genaue Fehlermeldung.

 

Ich nehme an das es egal ist, das ich den SSL Port auf 3401 liegen habe.

 

Naja, dann muss die Website mit https://<fqdn>:3401/ aufgerufen werden... Default ist ja 443.

 

Christoph

Share this post


Link to post

Er gibt gar keinen Error-Code aus...

 

Cannot find server or DNS Error ... hmh er lauscht aber auf den Port.

 

wenn ich auf das alte Zertifikat zurückgehen geht es wieder ...

Share this post


Link to post
Was ich merkwürdifinde dass ich nun auch bei den Zertifikaten einen Eintrag von Verisign drin hab

 

Das ist das Root-Zertifikat der Verisign-CA. Wenn du das schon in den Vertrauenswürdigen Stammzertifikaten drin hast, kannst du es bei den persönlichen Zertifikaten löschen. Sonst musst Du es dorthin verschieben.

 

Und: der Server kann zwar auf dem Port lauschen, aber der Client versucht SSL-Verbindungen über Port 443 aufzubauen; wenn dort keiner lauscht, kommt natürlich keine Connection zustande.

 

Christoph

Share this post


Link to post

Aha, das meinte ich doch vorhin mit <fqdn>:3401 ;)

 

Also mit dem alten Zertifikat gehts, mit dem neuen Zert. gehts nicht? Richtig?

/edit: grade beanwortet :D

 

Ist das neue Zert. auch auf den richtigen Namen (= alter Name) ausgestellt?

Und wird die Verbindung vom Client zum Webserver direkt oder über einen Proxy hergestellt?

 

Christoph

Share this post


Link to post

ja ich greife über <fqdn>:3401 zu. Der Name ist auch gleich. Ich habe nun auch von der Zertifikat-Truppe meiner Firma, das Zertifikat prüfen lassen, ist also auch fehlerfrei, und der Kollege, der den Krempel sonst einspielt ist in Urlaub...

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...