Jump to content
Sign in to follow this  
hobro

Zugriff auf Netzlaufwerke über VPN

Recommended Posts

Hallo!

 

Folgende Konfiguration:

Server SBS 2003, Notebook Win XP SP2, in Domäne eingebunden; Zugriff von extern auf das Netzwerk über IPSec im Router und entsprechende Client-Software auf dem Notebook.

 

Ist das Notebook im Netz eingebunden erhält es über die Benutzervorgaben im AD die Laufwerkszuordnung mittels einer Batch-Datei sowie zusätzlich ein individuelles U: - Laufwerk. Das funktioniert problemlos.

 

Ist Notebook aushäusig, wird der IPSec-Client gestartet und die Verbindung zum Firmennetzwerk aufgebaut. Outlook am Exchange sowie eine Remote-Desktop-Session auf einen firmeninternen XP-Rechner funktioniert problemlos. Aber:

Klickt man im Explorer auf die Laufwerksbuchstaben, so kommt die Meldung, dass die Laufwerke nicht zur Verfügung stehen.

Ich habe dann den logon.bat auf das Notebook kopiert und von dort aufgerufen (vorher werden alle Mappings gelöscht), dann wird der Benutzername abgefragt. Eingabe von Benutzername hilft aber nicht weiter.

Dann habe ich den Batch dahingehend geändert, dass beim ersten Mapping folgendes steht: net use f: \\server\freigabe /user:name passwort

Jetzt Läuft der Batch fehlerfrei durch - Mich stört aber, dass das Passwort im Klartext in dieser Datei steht.

 

Wie lässt sich die Laufwerkszuordnung sicher anders regeln?

 

Zusatzinfo: in der lokalen hosts-Datei steht xxx.xxx.xxx.xxx server; die digitale Signierung für Kommunikation ist in den Domäne-Controller-Richtlinien deaktiviert.

 

Vielen Dank für Tipps!!

 

Holger

Share this post


Link to post

Meldet sich der User, wenn er nicht im Hause ist, nicht mit seinem Domänenkonto an ? Welcher IPSec-Client ist auf dem Gerät bzw. was für ein Router ist das ?

Share this post


Link to post

Der Benutzer meldet sich ganz normal mit seinem Domänenkonto an.

Bintec-Router mit NCP-IPSec-Client

 

Noch zusätzliche Info:

Ich habe mir auf einem anderen externen Rechner lokal (!) einen Benutzer angelegt, der den gleichen Namen und das gleiche Kennwort hat wie der Netzwerkuser. Baue ich dann die IPSec-Verbindung auf (identische Konfiguration) und starte eine .bat-Datei, in der Benutzer und Kennwort NICHT angegeben sind, funktioniert die Laufwerkszuordnung ohne Nachfrage von Benutzername etc.

Share this post


Link to post

Passiert das auch, wenn Du die Laufwerke vor dem IPSec-Verbindungsaufbau trennst (via Batch oder gar nicht erst persistent machen) , dann die Verbindung aufbaust und das Script laufen lässt ? Wirst Du denn auch zur Eingabe eines Benutzernamens aufgefordert, wenn Du nur \\<Servername> eingibst ? Hm, die Benutzerkonten sind gleich (lokal und Domäne), die Credentials der Domäne sind gespeichert , die lokalen nicht ...

Share this post


Link to post
Passiert das auch, wenn Du die Laufwerke vor dem IPSec-Verbindungsaufbau trennst (via Batch oder gar nicht erst persistent machen) , dann die Verbindung aufbaust und das Script laufen lässt ?

Kann ich leider im Moment nicht testen - Das Notebook steht bei einem anderen Mitarbeiter und der ist froh, dass er mit der eingangs beschriebenen Lösung jetzt Zugriff auf seine Verzeichnisse hat ;-)

Hm,

auch hm :confused:

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...