Jump to content
Sign in to follow this  
AnK

Cisco 2620 - Callback einrichten

Recommended Posts

Hallo zusammen,

 

habe Probleme eine Callback Verbindung zwischen meinem 2620 und einem Cisco 3000 herzustellen.

 

Meine Konfiguration sieht so aus

username xyz callback-dialstring 012345678 password 0 xxx
!
interface BRI0/0
bandwidth 128
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
isdn T310 4000
no cdp enable
ppp authentication chap callin callback
!
interface Dialer2
description Wählverbindung zu XYZ
ip address 192.168.1.1 255.255.255.0
encapsulation ppp
dialer pool 1
dialer remote-name xyz
pulse-time 0
no cdp enable
ppp callback accept
ppp authentication chap
ppp chap hostname mein-router
ppp chap password 7 xxx
ppp multilink
!
ip route 192.168.2.0 255.255.255.0 Dialer2

Hier ein Auszug der Gegenstelle.

interface BRI3/1
description Verbindung zu ABC
bandwidth 64
ip address 192.168.1.2 255.255.255.0
ip nat outside
encapsulation ppp
no ip route-cache
no ip mroute-cache
load-interval 30
dialer idle-timeout 300
dialer map ip 192.168.1.1 name mein-router 087654321
dialer-group 1
isdn switch-type basic-net3
isdn caller 012345678
isdn caller 012345678
no cdp enable
ppp callback request
ppp authentication chap callin
ppp chap password 7 xxx

Eine normale Einwahl funktioniert, allerdings kommt kein Callback zustande,

habt ihr eine Idee woran es liegt?

Share this post


Link to post
Share on other sites

Hi, mach doch folgenes auf dem router, der callback machen soll:

 

 

auf dem dialer: dialer string 01234-5678

und dialer caller 12345678 callback

 

dann macht der router d-kanal callback...

 

setzt voraus, dass der router die rufnummer 12345678 eingehend sieht, wenn 0, 00 oder 0049 davorsteht, macht das auch nichts.. das ppp callback accept allein reicht nicht aus!

 

gruss

 

rob

Share this post


Link to post
Share on other sites

Hallo,

 

bei mir siehts jetzt so aus

username xyz callback-dialstring 012345678 password 0 xxx
!
interface BRI0/0
bandwidth 128
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
isdn T310 4000
no cdp enable
ppp authentication chap callin callback
!
interface Dialer2
description Wählverbindung zu XYZ
ip address 192.168.1.1 255.255.255.0
encapsulation ppp
dialer pool 1
dialer remote-name xyz
pulse-time 0
no cdp enable
dialer string 012345678
dialer caller 012345678 callback
dialer-group 1
ppp callback accept
ppp authentication chap
ppp chap hostname mein-router
ppp chap password 7 xxx
ppp multilink
!
ip route 192.168.2.0 255.255.255.0 Dialer2
!
dialer-list 1 protocol ip permit
!
end

Allerdings sehe ich im Debug Mode zwar das der Call rejected wird,

aber der Callback findet nicht statt.

 

Hier die Debug Informationen

20:01:15: ISDN BR0/0: Incoming call id = 0x0011, dsl 0
20:01:15: ISDN BR0/0: LIF_EVENT: ces/callid 1/0x11 HOST_INCOMING_CALL
20:01:15: ISDN BR0/0: HOST_INCOMING_CALL: (non-POTS) DATA
20:01:15: ISDN BR0/0: HOST_INCOMING_CALL: (1) call_type = DATA
20:01:15: ISDN BR0/0: HOST_INCOMING_CALL: voice_answer_data = FALSE call type is DATA
20:01:15: ISDN BR0/0: Event: Received a DATA call from 12345678 on B1 at 64 Kb/s
20:01:15: ISDN BR0/0: Event: Accepting the call id 0x11
20:01:15: BR0/0:1 DDR: Caller id 12345678 matched to profile xyz
20:01:15: Di2 DDR: callback to xyz already started
20:01:15: ISDN BR0/0: process_disconnect(): call id 0x11, call type is DATA, b_idb 0x80FA2C38, ces 1, cause Call rejected(0x15)
20:01:15: ISDN: get_isdn_service_state(): idb 0x80FA2C38 bchan 2 is_isdn 1 Not a Pri
20:01:15: ISDN BR0/0: HOST_INCOMING_CALL: DIALER ERROR 1: bchan 0, call id 11
20:01:15: CCBRI_Go Fr Host InPkgInfo (Len=13) :
20:01:15: 5 0 1 0 11 3 8 1 95 8 2 80 95

Share this post


Link to post
Share on other sites

Hi Hr_Rossi,

 

Danke habe ich schon gefunden, aber meine Konfig ist doch deiner ähnlich und auf die Gegenseite habe ich keinen Einfluss.

Share this post


Link to post
Share on other sites

Hi,

 

lass doch mal beim dialer caller xxx callback die führende 0 weg bzw. schau mit

 

show isdn act

 

bzw.

 

show isdn hist

 

 

ob und wie der router eingehende rufnummern sieht!

 

 

gruss

 

rob

Share this post


Link to post
Share on other sites

Hallo,

 

laut Cisco gibt es ein Konflikt zwischen ISDN-caller und Dialer-caller....

 

Restrictions

The ISDN caller ID callback feature conflicts with the dialer callback security feature for the Dialer Profiles feature for DDR. If dialer callback security is configured, it takes precedence; ISDN caller ID callback is ignored.

 

 

more

 

http://www.cisco.com/en/US/products/sw/iosswrel/ps1828/products_configuration_guide_chapter09186a0080087218.html

 

markber

Share this post


Link to post
Share on other sites

22:09:32: ISDN BR0/0: Event: Received a DATA call from 12345678 on B1 at 64 Kb/s
22:09:32: ISDN BR0/0: Event: Accepting the call id 0x1D
22:09:32: BR0/0:1 DDR: Caller id 12345678 matched to profile
22:09:32: Di2 DDR: callback to 12345678 already started

Der Rückruf ist scheinbar schon aktiv?

Wie kann man Dialer-caller deaktivieren?

Share this post


Link to post
Share on other sites
Hi, funktioniert doch!

 

Der Nutzen ist nur nicht sehr hoch, da auf der Gegenstelle der Rückruf nicht ankommt bzw. eingeht,

Verbindung kommt also nicht zustande.

Share this post


Link to post
Share on other sites

hi,

 

das callback funktioniert, aber mit dem ausgehenden ruf gibts ein problem! also debug isdn q931 und debug ppp authentication anschalten und mal monitoren! DEIN DIALER STRING HAT HOFFENTLICH NOCH ALLE BENÖTIGTEN NULLEN VOR DER NUMMER?!

 

 

gruss

 

rob

Share this post


Link to post
Share on other sites

Hi,

 

ok werden wir morgen sehen, ich habe fast den Eindruck das die Anfragen von der Gegenstelle

zu schnell kommen und deshalb der Callback erst gar nicht aufgebaut werden kann.

 

Wir haben die Verbindung nämlich nur per ping zwischen den Routern getestet.

 

rob_67 schon mal vielen Dank für die seelische Unterstützung,

beim ersten Ausflug in die Cisco Welt. ;)

Share this post


Link to post
Share on other sites

Hi, das macht nichts, wenn der router mit calls bombardiert wird, unter umständen macht er eben gleich 2 kanäle auf (multilink aktiv), wenn er mit calls bombardiert wird... man kann aber auch einstellen, dass der gegenrouter weniger oft anwählt.

 

gruss

 

rob

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...