Jump to content
Sign in to follow this  
bluter

Remote ISDN Einwahl auf einen Cisco Router 801

Recommended Posts

Hallo,

 

wer kann mir helfen?

 

Ich verwende zuhause einen Cisco router 801 und möchte mit diesem sowohl ins Internet, als ihn auch für Remote einwahlen nutzen:

 

Internet geht.

 

Wenn ich aber versuche mit auf meinen Router von aussen einzuwählen bekomm ich stets den Fehler, dass Benutzername oder Kennwort falsch sind.

Da kann man doch nicht so viel falsch eingeben?

 

 

Ich schick einfach mal die Config mit geänderten Passwörtern mit:

Current configuration : 2350 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname ISDN-Router

!

boot system flash c800-oy6-mw.122-31.bin

 

!

ip subnet-zero

!

no ip domain-lookup

isdn switch-type basic-net3

!

!

!

interface Ethernet0

ip address 192.168.50.1 255.255.255.0

no ip proxy-arp

ip nat inside

load-interval 30

no cdp enable

!

interface BRI0

no ip address

encapsulation ppp

load-interval 30

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

!

interface Dialer1

ip address negotiated

no ip proxy-arp

ip nat outside

encapsulation ppp

ip tcp header-compression

ip tcp compression-connections 64

dialer pool 1

dialer idle-timeout 30 either

dialer string 019167

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname ###Hostname###

ppp chap password ###Passwort###

!

interface Dialer2

ip unnumbered Ethernet0

no ip proxy-arp

encapsulation ppp

no ip split-horizon

no keepalive

dialer pool 1

dialer remote-name ###Name###

dialer idle-timeout 100

dialer called 921676

dialer-group 1

peer default ip address pool GinTonic

no cdp enable

ppp authentication ms-chap chap callin

ppp chap hostname ###Hostname###

ppp chap password ###Passwort###

ppp multilink

!

ip local pool GinTonic 192.168.50.10 192.168.50.11

ip nat inside source list 101 interface Dialer1 overload

ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 192.168.100.0 255.255.255.0 192.168.50.2

!

access-list 101 permit ip 192.168.100.0 0.0.0.255 any

access-list 102 deny udp any eq netbios-dgm any

access-list 102 deny udp any eq netbios-ns any

access-list 102 deny udp any eq netbios-ss any

access-list 102 deny udp any range snmp snmptrap any

access-list 102 deny udp any range bootps bootpc any

access-list 102 deny tcp any eq 137 any

access-list 102 deny tcp any eq 138 any

access-list 102 deny tcp any eq 139 any

access-list 102 permit ip any any

dialer-list 1 protocol ip list 102

snmp-server engineID local 00000009020000500F0277AC

snmp-server community bluter RO

snmp-server enable traps tty

!

line con 0

exec-timeout 0 0

stopbits 1

line vty 0 4

access-class 101 in

 

login

!

no rcapi server

!

!

end

 

 

Kann mir jemand helfen?

 

Wofür steht der dialer remote-name?

 

Gruß alex

Share this post


Link to post
Share on other sites

Hallo Alex,

 

auf dem bri sollte auf jeden fall ppp authentication ms-chap chap stehen und auf dem dialer läßt du das callin weg... wen du dich einwählen willst, solltest du user anlegen und den dialer mit dialer remote-name xxx oder dialer caller an den eigehenden ruf binden, dann klappts auch mit dem nachbarn, ms chap authentication brauchst du für pcs...

 

 

gruss

 

rob

Share this post


Link to post
Share on other sites

Hallo,

 

leider habe ich mich zu früh gefreut.

 

Ich kann mich zwar jetzt am Router per ISDN einwählen und bekomme auch eine IP Adresse, 192.168.50.10, leider komme ich aber jetzt im Netz nirgendwo hin.

 

Ich wollte meinen Rechner auf der 192.168.50.2 pingen, geht aber leider nicht - Timeout.

 

Hat noch jemand eine Idee?

Danke.

 

Gruß Alex

Share this post


Link to post
Share on other sites

Ich habs mit ner 801 so gemacht, weiss nich ob dir das so passt, mal n Denkanstoss:

 

username remotehostname password 7 xxxxxxxxxxxx

[...]

isdn switch-type basic-net3

[...]

interface Loopback0

ip address 172.20.0.1 255.255.255.0

[...]

interface BRI0

no ip address

encapsulation ppp

no ip mroute-cache

dialer pool-member 1

dialer pool-member 2

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

ppp multilink

!

interface Dialer1

ip address negotiated

encapsulation ppp

no ip mroute-cache

dialer pool 1

dialer remote-name hostwohinverbinden

dialer string 0190666666

dialer load-threshold 20 either

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname login#bla#huhu

ppp chap password 7 xxxxxxxxxxxxxx

ppp multilink

!

interface Dialer2

ip unnumbered Loopback0

encapsulation ppp

dialer pool 2

dialer remote-name remotehostname

dialer-group 2

no cdp enable

ppp authentication chap pap callin

ppp multilink

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

Share this post


Link to post
Share on other sites

Hallo Bluter, wo willst du denn hin? ich denk, da fehlen noch ein paar routing oder NAT geschichten. eine kleine zeichnung wäre schick! :cool:

 

 

oder meinst du mit netz internet? dann auf dem dialin dialer ip nat inside hinzufügen! und die acl 101 für das nat auf das netz 192.168.50.xxx erweitern!

 

Gruss

 

rob

Share this post


Link to post
Share on other sites

Hallo,

 

ok hier die Zeichnung:

 

Nein wenn ich von außen komm (über den Dialer 2) will ich nicht ins Internet nur auf mein internes Netzwerk.

 

 

Gruß alex

post-35199-13567389337219_thumb.jpg

Share this post


Link to post
Share on other sites

Hi,

 

dann braucht dein internes netz den router entweder als default gateway oder eine route zum netz 192.168.50.0 / 24, leider ist die skizze noch nicht freigeschaltet, auf denen fall sind es intern zwei verschiedene netze der router hat lokal 192.168.50.x und vergibt auch adressen aus diesem bereich per isdn einwahl, das interne netz, dass du natest ist jedoch 192.168.100.x, was ist die 192.168.50.2 - eine firewall oder ein anderer router?

 

 

gruss

 

rob

Share this post


Link to post
Share on other sites

Hallo,

 

Erst mal Dank für die schnellen Antworten.

 

also die 192.168.50.2 ist normalerweise meine Firewall.

 

Da ich die FW aber als Problem ausschließen wollte, hab ich die Firewall abgesteckt, und mein Notebook direkt an den 801 Router angeschlossen, und dem NB die IP 192.168.50.2 vergeben.

 

Ich wollte eigentlich nur per ISDN einwählen (das klappt soweit, ich bekomm die 192.168.50.10 zugewiesen) und über die Einwahl auf das NB zugreifen (einfach das Ding pingen).

 

Leider geht das nicht.

Idee???

 

Gruß alex

Share this post


Link to post
Share on other sites

hi,

 

 

versuch doch mal vom router direkt auf das notebook zu pingen ob das geht (xp firewall oder sonstiges?)?! wenn das geht, sollte der andre ping auch gehen, wenn keinerlei filter existieren... ansonsten schalt mal ip proxy arp auf e0 an.

 

 

gruss

 

rob

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...