Jump to content
Sign in to follow this  
trojan

zu viele Pakete / sec

Recommended Posts

moinmoin

 

ich habe bei STRATO einen win-rootserver.

 

Dieser wurde am Samstagabend vom Netz genommen, da zu viele Pakete pro sec vom Server ausgingen (knapp 20k pro sec) bei einer Auslastung von ca 75Mbit.

 

Aktuelle Konfiguration :

win 2003 sp1 32bit, alle patches

apache 2.0.55 + php5

gene6 ftp

avg 7 av

 

aktuell hat der Server eine Auslastung von 31Mbit und dabei 8700 Pakete / sec.

 

Die aktuelle Auslastung kann man sich hier anschauen >

http://openFTP.de/traffic.php

 

Wenn die Anzahl der Packete noch deutlich höher wird, wäre es durchaus möglich, dass Ihr Server erneut gesperrt wird.

 

Eine dermaßen hohe Anzahl an Paketen pro Sekunde läßt auf eine fehlerhafte/schlecht konfigurierte Anwendung auf dem Server schließen. Die übliche MTU im Internet liegt bei 1500 Byte pro Paket, das entspricht 12000 Bit. Wenn Sie nun die 100 MBit Ihrer Server-Anbindung durch diese 12000 teilen, erhalten Sie ca. 8333 Pakete pro Sekunde. Das heißt, bei voller Ausnutzung der möglichen Bandbreite dürfte Ihr Server ca. 8000-9000 Pakete/s versenden, evtl. auch etwas mehr. Wenn die Paketanzahl aber bereits bei ca. 35Mbit/s deutlich darüber liegt, zeigt das, dass der Server eindeutig zu viele zu kleine Pakete versendet.

 

der apache ist eigentlich in der standard-konfiguration, habe ihn nur bedingt an meine Bedürfnisse angepasst.

 

die config dazu gibts hier > http://openFTP.de/files

 

hab mit Dr. TCP (weiß nicht ob das beim 2003er überhaupt greift) die MTU auf 1500 gesetzt, reboot gemacht aber es hat sich nichts verändert.

 

wie schaffe ich es die pakete pro sec auf ein normales Niveau zu schrauben?

 

wäre super wenn jemand eine Lösung für das Problem hat :)

 

thx & cya

trojan

Share this post


Link to post
Share on other sites

ich vermute, dass ich das problem gefunden habe :D

 

in der registry ist bei jedem LAN-adpater ein MTU (maximum transmission unit) gesetzt (standard 1500) , aber es gibt da noch einen Wert der nennt sich "PMTUDiscovery", dieser war auf 0 gesetzt.. dies hat folgenden effekt >

 

Wenn zu 1 gesetzt (Wahr), versucht TCP, den MTU automatisch vom REMOTE HOST zu ermitteln. Das Setzen auf 0 verursacht, daß der MTU fest auf 576 gesetzt wird, was aber die gesamte durchschnittliche Performance bei HIGH-SPEED-VERBINDUNGEN (ISDN und besser) reduziert. Beachten Sie, daß diese Einstellungsempfehlung unter WIN2000 anders ist als die Empfehlung für WIN9X.

 

nun ist der auf 1 :) und es gibt 1/2 bis 1/3 weniger pakete :D

 

hoffe das war der knackpunkt :)

 

cya

trojan

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...