Jump to content
Sign in to follow this  
maho

Frage zu trunk native vlan

Recommended Posts

Hallo,

 

habe momentan eine VLAN-Konstrukt mit einem Router und Switch laufen. Router und Switch sind über vlan 1 verbunden. ich würde das nun gerne auf vlan 240 ändern. Sollte das trotzdem funktionieren? Ist eine Produktivumgebung und habe momentan keine entsprechenden Geräte da, um das auszutesten.

Vielleicht hat das jemand so schon am Laufen.

 

Danke schon mal im Voraus!

 

Grüße, Maho

 

 

Details:

Alt

Router

interface FastEthernet0/0

no ip address

duplex full

speed 100

 

interface FastEthernet0/0.1

description Inside

encapsulation dot1Q 1 native

 

Switch

interface FastEthernet0/45

description trunk zum Router

duplex full

speed 100

switchport trunk encapsulation dot1q

switchport mode trunk

 

 

Neu

Router

interface FastEthernet0/0

no ip address

duplex full

speed 100

 

interface FastEthernet0/0.1

description Inside

encapsulation dot1Q 240 native

 

Switch

interface FastEthernet0/45

description trunk zum Router

duplex full

speed 100

switchport access vlan 240

switchport trunk encapsulation dot1q

switchport mode trunk

Share this post


Link to post
Share on other sites

Statt "switchport access vlan 240" muesste es glaub ich "switchport trunk allowed vlan 240" sein, weil 1 im Trunk default dabei is. Vielleicht 240 auch wenns native is, hab ich bis jetzt noch nie probiert.

 

 

 

EDIT: sorry, hab grad noch mal die Doku vom 2950 und 3550 durchgeblaettert. Vergiss das mit dem trunk allowed und access vlan, so stehts drin:

switchport trunk native vlan 240.

Share this post


Link to post
Share on other sites

Wo ist der Sinn, dass der Router überhaupt ein Tag bekommt ?

 

Auf jeden Fall o.g. Switchkonfiguration kann nicht funktionieren, weil ein Port nicht gleichzeit ein Trunk sein kann und gleichzeitig ein Access-Port.

Möglich ist es aber dem Switch zu sagen, dass das VLAN240 ab jetzt native VLAN ist und nicht das VLAN1.

Share this post


Link to post
Share on other sites

>Möglich ist es aber dem Switch zu sagen, dass das VLAN240 ab jetzt native VLAN ist und nicht das VLAN1.

 

Wie mache ich das?

 

Momentan habe ich 2 VLAN-Domänen. Einmal die 6000'er mit den Access-Switches und einmal einen Router und Switch. Nun möchte ich die zwei unabhängigen Layer2 Domänen verheiraten. Weil es aber in beiden Domänen ein VLAN1 gibt, möchte ich auf Router-Seite das VLAN1 canceln.

Share this post


Link to post
Share on other sites

Hola Maho,

 

hier ein Versuch.

 

Das Native VLAN definiert ein nicht getaggtes VLAN auf einem 802.1Q Trunk. Dieses VLAN wurde nach IEEE Standard definiert, da immer eine Abwährtkompabilität mit "alten" (in diesem Fall nicht 802.1Q devices) bestehen muss. In diesen Fall geht man von einem

shared Medium aus, dass in einer geswitchten Umgebung so nicht mehr existiert.

 

==>

Because 802.1Q is defined as a type of Ethernet frame, it does not require that every device on a link speaks the 802.1Q protocol. Because Ethernet is a shared media and more than two device could be connected on this media, all devices on the link must still be capable of communicating even if they do not speak the 802.1Q protocol. For this reason, 802.1Q also defines a Native VLAN.

<==

 

Das Native VLAN kann jedoch auch getagged werden (set dot1q-all-tagged | vlan dot1q tag native). Dies ist sinnvoll, wenn ein Q-in-Q Tagging oder 802.1Q Tunnel gebildet werden soll, der z.B. zwei Firmen über einen 802.1Q Trunk mit den gleichen VLANs transportieren kann.

 

Ciao

 

Thomas

Share this post


Link to post
Share on other sites

Hola Maho,

 

Das VLAN 1 wird nicht benötigt (obe jetzt VLAN 1 ,2,3x = wurst).

 

Vom Design her ist es sinnvoll das Inter VLAN Routing am CoreSwitch 6K zu lösen und nur eine default Route für externe Netze zum Router zu setzen. Ist dies nicht möglich, da der CoreSwitch wirklich nur switched und nicht routen kann, ist ein 802.1Q Trunk zum Router nötig:

 

Router:

 

interface FastEthernet0/0

no ip address

duplex full

speed 100

 

 

!

ip cef

!

-->VLAN A (MGMT)

interface FastEternet0/0.100

description --> Management VLAN

encapsulation dot1Q 100 native

ip address x.x.x.x x.x.x.x

no ip proxy-arp

no ip unreachables

no ip directed-broadcast

no ip redirects

!

-->VLAN B (Data)

interface FastEternet0/0.10

description --> Data VLAN

encapsulation dot1Q 10

ip address x.x.x.x x.x.x.x

no ip proxy-arp

no ip unreachables

no ip directed-broadcast

no ip redirects

!

-->VLAN B (Data)

interface FastEternet0/0.20

description --> Voice VLAN

encapsulation dot1Q 20

ip address x.x.x.x x.x.x.x

no ip proxy-arp

no ip unreachables

no ip directed-broadcast

no ip redirects

!

-------------------------------------------------------------------------

Switch:

 

interface FastEthernet 0/10

description --> Uplink to Router XX

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 100

switchport trunk allowed vlan 10,20,x..

switchport nonegotiate

speed 100

duplex full

spanning-tree link-type point-to-point

 

!

 

Gruß

 

Thomas

Share this post


Link to post
Share on other sites

Hallo Thomas,

 

ich habe ehrlich gesagt noch nicht verstanden, was die Auswirkung wäre, wenn ich das "native" weglassen würde.

Habe zur zeit eine Testumgebung am Laufen, 3 vlan's konfiguriert -ohne "encapsulation dot1Q x native". Der Routing zwischen den VLANs funktioniert.

 

Maho

Share this post


Link to post
Share on other sites

Hola Maho,

 

du kannst das Native VLAN nicht weglassen, da es nach Standard auf jeden .1Q Trunk vorhanden sein muss. Das einzige was wichtig ist, dass das Native VLAN auf beiden Seiten gleich ist.

 

IMHO macht das Native VLAN in 100% der (sinnvoll geplanten) Umgebungen keine Probleme.

 

Gruß

 

Thomas

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...