Jump to content
Sign in to follow this  
crisirius

Inet Probleme mit Wic-1Enet Interface

Recommended Posts

Hallo zusammen,

 

vielleicht kann mir jemand helfen ich habe folgendes Problem:

 

Aufbau:

 

Inet----Wic-1ENET---Cisco 1721 --- 10/100 Mbit Card----Lan

 

Das Inet ist mit 8 MBit von Kabeldeutschland versorgt (kabelmodem).

Der Download über den Cisco bleibt immer bei ca 550 KByt/s hängen schließe ich einen Rechner direkt an das Kabelmodem bekomme ich Downloadraten von 1 Mbyt/s

 

Config:

 

Current configuration :

!

version 12.4

service config

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

interface Ethernet0

ip address dhcp

ip nat outside

ip virtual-reassembly

ip tcp adjust-mss 1452

no ip mroute-cache

half-duplex

!

interface FastEthernet0

ip address 192.168.0.5 255.255.255.0 secondary

ip address 172.20.1.10 255.255.255.0

ip nat inside

ip virtual-reassembly

speed auto

!

interface Serial0

no ip address

shutdown

!

interface Serial1

no ip address

shutdown

!

ip classless

ip http server

ip http secure-server

!

ip nat translation timeout 120

ip nat translation tcp-timeout 1000

ip nat translation udp-timeout 30

ip nat translation icmp-timeout 30

ip nat translation max-entries 2500

ip nat inside source list 1 interface Ethernet0 overload

access-list 1 permit 172.0.0.0 0.255.255.255

access-list 1 permit 192.0.0.0 0.255.255.255

 

Ethernet0 is up, line protocol is up

Hardware is PQUICC Ethernet, address is 0004.dd0d.4eeb (bia 0004.dd0d.4eeb)

Internet address is

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 5/255, rxload 3/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Half-duplex, 10BaseT

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 3/75/356/0 (size/max/drops/flushes); Total output drops: 69

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 139000 bits/sec, 72 packets/sec

5 minute output rate 221000 bits/sec, 35 packets/sec

7731410 packets input, 855413253 bytes, 9 no buffer

Received 7029267 broadcasts, 0 runts, 0 giants, 0 throttles

327 input errors, 120 CRC, 167 frame, 33 overrun, 7 ignored

0 input packets with dribble condition detected

738124 packets output, 410519984 bytes, 7 underruns

7 output errors, 66714 collisions, 6 interface resets

0 babbles, 0 late collision, 12869 deferred

 

Hat jemand dazu eine Idee??

 

Grüße

 

Crisirius

Share this post


Link to post
Share on other sites

327 input errors, 120 CRC, 167 frame, 33 overrun, 7 ignored

7 output errors, 66714 collisions, 6 interface resets

 

Stell mal auf Full-Duplex und schau immer wieder mal mit sh int eth0 ob sich die Counter fuer die Errors erhoehen.

Share this post


Link to post
Share on other sites

Ich würde sagen das Problem hängt mit der alten Karte zusammen, ein typisches Duplexproblem.

"Die Karte kann keine Autonegotiation. Wenn die andere Seite damit arbeitet (ist heute quasi immer so) und keine Antwort erhält fällt sie in den Half-Duplex betrieb zurück."

 

Bei dir ist jetzt ein ähnlicher Fall, du sendest Halb-Duplex bekommst aber die Daten mit Full-Duplex. Hat zur Folge das dein Modem sendet auch wenn es bereits Daten vom Cisco kriegt woraufhin der Cisco eine Kollision erkennt und das senden abbricht und erneut versucht.

 

CSMA/CD halt... wann gibt endlich nurnoch 10Gb/s Ethernet..

Share this post


Link to post
Share on other sites

Hallo zusammen,

 

nun folgendes Problem.

Laut Cisco kann diese Krate auch im full-duplex betrieben werden.

Wenn ich dies nun umstelle kann ich zwar Surfen aber Download von Seiten sind nicht möglich auch das Serven ist langsamer alsim half-duplex Betrieb.

 

Kann sich dasJemand erklären??

 

Ps: Es sind keine Fehler mehr auf der Karte zu erkennen.

 

 

Bin etwas Sprachlos

 

Grüße

 

Crisirius

Share this post


Link to post
Share on other sites

Vielleicht passt die MTU noch nicht so ganz. Keine Ahnung wie das bei Kabelmodem so ist, stell doch mal 1400 ein und ip tcp adjust-mss auf 1300, wenns besser geht dann nach oben anpassen, die Werte sind schon etwas niedrig.

Share this post


Link to post
Share on other sites

Es ist vermutlich kein MTU Problem.

Die TCPMSS ist normalerweise nur 20+20 byte (also 40byte (von IP und TCP Header - 60 mehr nur wenn noch IPSec drauf kommt ;))) kleiner als die IPMTU. falls du eine MTU einstellen möchtest solltest du eine IPMTU auf dem Dialerinterface einstellen und die TCPMSS 40 kleiner wählen.

 

Das ist das andere Duplex-Problem das ich oben beschrieben habe.

 

entweder hängst du einen managebaren Switch dazwischen auf dem du die Ports einstellen kannst

 

aber viel einfacher wäre es das DSL-Modem mit an das interne LAN zu hängen und PPPoE über das 100MBit/s Interface zu machen. Dann solltest du keine Probleme mehr haben ;)

Da der Verkehr eh getunnelt ist macht das auch keinen Sicherheitsunterschied.

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...