Jump to content
Sign in to follow this  
Ikarus2k

Problem mit Non-Cisco-IP-Telefonen an Catalyst 3750

Recommended Posts

Hallo,

 

ich habe derzeit ein Problem bezüglich der Konfiguration von Non-Cisco-IP-Telefonen an meinem Cisco Catalyst 3750. Ich soll IP-Telefone von Alcatel an den Switch anschliessen, so daß diese eine Verbindung mit dem Alcatel-Call-Manager herstellen und sich selbst via DHCP konfigurieren können.

Wenn die Telefone direkt an den Call-Manager angeschlossen werden klappts, hänge ich den Switch dazwischen funktioniert nichts mehr!

 

Ich habe hier im Forum daraufhin den Artikel Non-Cisco IP Phone on Catalyst Trunk with DHCP gelesen, der mich aber nur einen Teil weitergebracht hat.

 

Derzeit habe ich den Port zum "Uplink" zum Call-Manager wie folgt konfiguriert:

 

interface GigabitEthernet1/0/14

switchport acess vlan 4

switchport trunk encapsulation dot1q

switchport trunk native vlan 4

switchport mode trunk

switchport nonegotiate

switchport voice vlan 4

priority-queue out

mls qos trust qos

spanning-tree-portfast

 

Da an den Switch ausschliesslich IP-Telefone angeschlossen werden sollen, habe ich Vlan 4 sowohl als Access- wie auch als Voice-Vlan genommen, denke das müsste ja möglich sein.

 

Daten empfange ich zumindest nun fleissig über den Port und auch die MAC vom Call-Manager bekomme ich via show mac-adress-tables auf diesem Port angezeigt.

 

Für den Port wo ich das Alcatel-IP-Telefon angeschlossen habe, läuft derzeit folgende Konfig:

 

interface GigabitEthernet1/0/16

switchport acess vlan 4

switchport voice vlan 4

 

Nur scheint dies das Teelfon reichlich wenig zu interessieren! Ich bekomme nicht einmal die MAC vom Telefon rein!

 

Daher nehme ich mal an, daß bei dem Port wo das Telefon angeschlossen ist noch was gemacht werden muss, nur leider weiss ich nicht was!

 

Bin noch recht neu im VoIP-Bereich, daher wenns geht so erklären, daß es nen frisch gebackener CCNA (die kein VoIP in der Prüfung haben) auch versteht ;)

 

Danke,

Markus

Share this post


Link to post
Share on other sites

Mal ne Frage da ich Alcatel nicht kenne:

Macht der CallManager 802.1q? Wieso hast du überhaupt einen Trunk auf dem Port konfiguriert?

 

Ist das "switchport voice vlan" nicht cisco eigen?

 

Wenn an dem Switch nur VoIP soll und die Geräte alle im VLAN 4 sind wieso dann nicht

 

switchport acess vlan 4

spanning-tree-portfast

 

den QoS kannst du ja später machen wenn der Rest läuft und für einen Trunk sehe ich keinen Sinn (sowohl am Telefon als am CallManager)

Share this post


Link to post
Share on other sites

Hola,

 

es gibt bei Alcatel keinen Callmanager, sondern entweder eine Alcatel OmniPCX Enterprise (OXE) oder die kleinerer Version OmniPCX Office.

 

Die Alcatel Telefone IP Touch (grosses LCD) oder TSCP IP V1, V1S oder V2 (zwei Zeilen Display) verstehen natürlich nicht CDP. Du musst also entweder den VLAN ID fest einstellen oder Alcatel AVA verwenden.

 

Die Konfiguration sieht dann so aus:

 

interface fas x/y

description -->VoIP n Data

switchport mode access

switchport access vlan <Data VID>

switchport voice vlan <VoIP VID>

switchport nonegotiate

spanning-tree portfast

[mls] qos trust cos

+

qos params....

+

secruity params ala port sec

 

Ciao

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...