Jump to content
Sign in to follow this  
xyCruiseryx

Frage Vlan Konfiguration 3750 und 2970

Recommended Posts

Hallo,

 

ich habe mal ne Frage zu ner Vlan Konfiguration auf beiden Geräten.

 

1.) Muss ich auf beiden Geräten die Vlan IDs erst in der Vlan database erzeugen mit Name etc ? oder reicht auch der Befehl :

 

switch(config)# int vlan x aus ??? (Komme mit dem Befehl auch ohne ich das Vlan erzeuge in das Vlan Interface).

 

 

2.) Wenn ich mehrere Vlans auf dem Switch 3750 konfiguriere habe ich die Möglichkeit:

 

a) Das Trunking /alle Vlans auf alle andere 2970 (die am 3750) angeschlossen sind automatisch zu übertragen ? Ohne das ich auf den 2970er noch extra die Vlans mit der Hand erzeugen muss ? (glaube das nett sich VTP oder )

 

b) oder ist es besser das manuel zu machen und vtp auszuschalten ?

 

c) Wie kann ich auf den Switchen VTP deaktivieren so das mit das Protokoll nicht im Netz rumkreist ?

 

 

Ich danke euch für eure Antworten

Share this post


Link to post
Share on other sites

Hallo

2.)a) Ja das geht mit VTP, es sollte ein Gerät als Server konfiguriert werden(auf dem alle VLANs sind) und eine domain muss auch eingestellt werden. Grundsätzlich sollten alle anderen Geräte Clients sein und natürlich die gleiche domain haben. Ich empfehle auch dringend ein Passwort zu vergeben (immer gleich) damit nicht jeder vtp senden kann.

 

b) Es erleichtert die Konfiguration enorm und wenn es mit passwort betrieben wird ist es auch sicher. Also benutzen!

 

c) hmm gute frage...

Share this post


Link to post
Share on other sites

Erstmal vielen Dank für die Infos,

 

A) wenn ich VTP wie beschrieben konfiguriere. Ist es dann erforderlich den Uplinkport (2970)zum VTP Server (3750) als Trunk mit ISL/ 802.1q zu konfigurieren ? oder passiert das alles automatisch, so dass alle vlans übertragen werden ?

 

 

B) was ist mit einem Password im VTP gemeint ? meinst du evtl das ena , vty ena sec pw oder gibts da noch was an pw´s was ich nicht kenne :)

 

c) Wenn man VTp nicht deaktivieren kann, muss es ja so sein das eine statische Vlan Konfiguration ja vorrangt haben muss oder ??

 

 

Ich danke euch schonmal.........

Share this post


Link to post
Share on other sites

A) erforderlich ist das flasche wort, 802.1q is der standard bei neuen systemen und musst soweit ich weiss nicht explizit konfiguriert werden (ohne gewaehr)

 

C) da bin ich mir nicht ganz sicher, also wenn du "vtp mode transparent" hast, dann ist der catalyst nicht im client mode, von daher gibts auch kein vorrang.

Share this post


Link to post
Share on other sites

VTP deaktivieren geht mit "vtp mode transparent". Das heisst hier läuft kein VTP.

 

802.1q muss soweit ich weiss konfiguriert werden, weil der Switch kann ja nicht davon ausgehen, dass der andere Switch überhaupt mit in die Domain soll.

 

Man sollte vielleicht nur prunning auf on schalten, das bewirkt, dass alle Switche nur den Broadcast der VLANs abbekommen, in welchem überhaupt Ports sind.

 

Das VTP Passwort ist nur für die VTP domaine da. Ein Client bekommt nur dann die VLAN-Informationen, wenn er neben der Domain auch das richtige Passwort hat.

Share this post


Link to post
Share on other sites

Mensch leute ihr habt mir sehr geholfen,

 

Aber eine Frage hätte ich noch:

 

ich habe eben 2 2950 konfiguriert. Habe dann Swtich 1 als VTP-Server und Swtich 2 als VTP Client konfiguriert.

 

===> Beide Switches mit Port 1 verbunden und alle vlans wurden vom VTP Server auf den VTP Client übertragen. (habe ich in der vlan database gesehen). OK

 

Dann habe ich jeweils 2 Pcs auf den Master und 2 Pcs auf den client in 2 unterschiedliche vlans konfiguriert. Ping der beiden unterschiedlichen Netze auf die jeweiligen pcs war erfolgreich.

 

 

Was mir aber auffiel war:

 

Frage 1: Vlan x und Vlan y waren nun auf beiden switchen funktionsfähig und wurden über den Port 1 sw1 und port 1 sw2 übertragen. Nur warum ? Ich habe kein Trunking auf einem der beiden fa 0/1 konfiguriert . Wie kann das sein ? Erkennen die switche von alleine unter dem VTP das es sich bei port 0/1 um ein trunking handelt der in allen vlans ist?

 

Frage2: Wenn ich in der oben beschriebenen Situation ein #show run mache sehe ich nur vlan 1 down in der Liste. Wenn ich jedoch ein ein #show vlan mache sehe ich alle meine vlans mit status activ. Ist das auf einem Layer2 Swtich normal ? Erst wenn ich Vlan 1 eine IP-Adresse für Management Zwecke verpasse geht der Status des Vlan 1 auf up. Will ich jedoch das Vlan 3 zum Management Vlan machen ,sehe ich nach dem # int vlan 3 ENTER IP ADDRESSS X.X.X.X Y.Y.Y.Y Vlan 3 als Up und Vlan 1 als Down. Ist es so das nur das Vlan mit der Management Ip Adresse bei einem Layer 2 Switch ein Up bekommt ? Ich habe immer gedacht das es notwenig sei, auch die vlans die in der vlan dat stehen als # Int Vlan X und einem no shut aufzurufen damit das vlan arbeitet. Jedoch zeigen meine Test das es ausreicht die vlans in der vlan dat zu haben und dann dementsprechend auf die access ports zu konfiguieren. ( ich bin nun etwas verwirrt)

 

Ich danke für eure hilfe... :)

Share this post


Link to post
Share on other sites

Also zu 2) Kann ich dir definiv sagen:

Richtig die werden per VTP in die VLAN Database geschrieben und das reicht auch aus damit sie aktiv sind.

Wenn du ein Interface Vlan x hast kann man damit dem Switch eine IP geben, ist aber nicht zwingend notwendig.

Macht das Verwalten größerer Netzwerke schon erheblich bequemer dieses VTP ;)

 

Zu 1) Hö? Ich verstehe zwar wie du die Switche jetzt verkabelt hast aber nicht genau wie du das mit den Clients getestet hast und der Kommunikation vom einen zum anderen Switch...

Share this post


Link to post
Share on other sites
Also zu 2) Kann ich dir definiv sagen:

Richtig die werden per VTP in die VLAN Database geschrieben und das reicht auch aus damit sie aktiv sind.

Wenn du ein Interface Vlan x hast kann man damit dem Switch eine IP geben, ist aber nicht zwingend notwendig.

Macht das Verwalten größerer Netzwerke schon erheblich bequemer dieses VTP ;)

 

Zu 1) Hö? Ich verstehe zwar wie du die Switche jetzt verkabelt hast aber nicht genau wie du das mit den Clients getestet hast und der Kommunikation vom einen zum anderen Switch...

 

 

Da geht hier ja wie aufm bahnhof mit den antworten. Klasse Forum :D

 

 

Also Ich habe:

 

Sw1: Pc1 mit IP 192.168.0.1 auf Port 2 im Vlan 10 Pc2 mit IP 192.168.5.1 auf Port 3 im Vlan 20

 

Sw2: Pc3 mit IP 192.168.0.2 auf Port 2 im Vlan 10 Pc 4 mit Ip 192.168.5.2 Port 3 im Vlan 20

 

Sw1 und Sw2 sind mir einem CrossPatchkabel auf jeweils Port 1 verbunden. Ohne das ich auf dem Port von sw1 und sw2 fa0/1 sage das dieser ein trunk port ist, läuft das trunking von alleine. Is das normal ???

Share this post


Link to post
Share on other sites

Das liegt daran, dass VTP-Informationen auf dem native VLAn übertragen werden, sprich defaultmäßig im VLAN1. Der Uplink ist kein Trunk nur beide sind im VLAN1.

 

Lege mal beide Uplink Port 1 ins VLAN2 und es sollte danach nicht mehr funktionieren.

Share this post


Link to post
Share on other sites

und wieso können die Workstations dann kommunizieren wenn es kein Trunk ist?

Ich meine nur weil VTP die VLANs verteilt wird der Verkehr ja nicht ankommen...

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...