Jump to content

VLan einstellungen


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

das ist ein IOS Switch?

im Prinzip ginge es so per CLI ->

 

switch> enable

switch# config terminal

switch(config)# interface range fastethernet 0/1 - 12

switch(config-if)# switchport mode access

switch(config-if)# switchport access vlan 100

 

... fügt interfaces 1-12 ins vlan 100. Danach nochmal Zeilen 3-5 für die entsprechenden anderen interfaces und ein anderes Vlan. etc

 

Link: http://www.cisco.com/en/US/products/hw/switches/ps672/products_tech_note09186a0080093f8f.shtml

Meinst Du sowas?

 

Gruss

Robert

Link to comment

die catalyst Kommandos hab ich nicht so im Kopf. Statt dem Config-Modus benutzt man den set-Befehl, die interfaces heißen im CatOS Port

 

so könnte es gehen:

set vlan 200 name cisco

set vlan 200 0/1 [vielleicht geht auch 1 - 12]

 

catOS Link: http://www.cisco.com/en/US/products/hw/switches/ps663/products_configuration_guide_chapter09186a00800d81aa.html

 

Gruss

Robert

 

PS: guter CISCO Titel zum Thema: http://www.amazon.de/exec/obidos/ASIN/1587050439/qid=1116843771/sr=1-2/ref=sr_1_0_2/028-5755262-3514113

sowas kann man sich als Admin mal ins Regal stellen, behandelt IOS und CatOS Software

Link to comment

Werde dies mal ausprobieren mit einem kollegen sollte es klappen werde ich es posten.

 

sollte noch einer irgendwie wissen wie man ein inter-VLan routing macht wäre es super

 

Es geht sich hier um ein cisco catalyst 2948g (OS)

er hat 48 ports und wir haben vor sie in 4 virtuelle a 12 ports zu machen.

Link to comment

Also ohne trunk (was ist trunk?) wenn es geht bin gerade in der ausbildung zum mcse also noch net soviel erfahrung.

 

Was wir vorhaben ist den catalyst 2948g mit seinen 48 ports in 4 virtuelle switche mit je 12 ports zu konfigurieren nur haben wir im moment nicht die leiseste ahnung wie dies gehen soll.

 

Da der switch noch nicht mal über ein webinterface verfügt.

Link to comment

Ein Trunk kann auf einem Port/Link mehrere VLAN gleichzeitig transportieren. Der Standard heißt dann 802.1q. (Oder ISL - Cisco eigenes Protokoll) Besonders zwischen zwei Switchen ist das von großem Nutzen, da man ansonsten pro VLAN ein Port/Link bräuchte - das kann schnell sehr teuer werden. Diese Standard fügen dem Frame noch einen kleinen Tag hinzu (oder einen extra "Frame beim ISL) die die unterschiedlichen VLANs kennzeichnen.

 

Wenn Du jetzt zwischen den VLANs routen willst, bräuchtest Du ja am Router und am Switch pro VLAN ein Port. Mit nem Trunk reicht ein Port bzw Link.

 

Gruss

Robert

Link to comment

Ich denke chris.m hatte gedacht das Inter-VLAN-Routing auf dem Switch zu belassen? Das geht natürlich nicht.

Die geschickeste Lösung ist m.E. auch einen 802.1q Link auf einen Router zu machen und dort dann das entsprechende Ethernet-Interface in Subinterfaces, wenn jedes VLAN ein eigenes Subnetz bekommt.

 

In etwa so:

 

interface FastEthernet0/0

description dot1q-Verbindung zu Switch

no ip address

no ip directed-broadcast

full-duplex

!

interface FastEthernet0/0.5

description VLAN 5

encapsulation dot1Q 5

ip address 192.168.0.1 255.255.255.0

!

interface FastEthernet0/0.36

description VLAN 36

encapsulation dot1Q 36

ip address 192.168.1.1 255.255.255.0

Link to comment

Also muss nicht inter-vlan routing sein.

 

es muss nur aus den 48 porst 4 virtuelle lans erstellet werden die jeweils 12 ports haben.

Unser sinn ist es, da wir 4 kleine hubs haben und die wollen wir durch einen großen switch ersetzten. Der switch muss halt 4 virtuelle netzwerke haben (glaube dies ist richtig), bzw die 4 kleinen hubs sind in 4 verschiedene netzwerke angeschlossen. und der switch soll halt die 4 ersetzen.

Das heißt er muss in 4 mal 12 ports geteilt werden bzw er muss zu 4 virtuelle hubs(switche) werden

Link to comment

O.K. Grundätzlich nach dem Muster set vlan (vlan-id) (Ports).

 

Also:

system1> (enable) set vlan 2 0/1-12

system1> (enable) set vlan 3 0/13-24

system1> (enable) set vlan 4 0/24-36

system1> (enable) set vlan 5 0/36-48

 

Bei den Ports musste mal ein show run machen, obs passt wie die Ethernetsport heissen, also 0/1 für den ersten Ethernetport

 

Wenn Du dem VLAN noch ein Namen verpassen möchtest:

system1> (enable) set vlan 2 name Wieauchimmer

 

Kommunikation ist dann entsprechend nur innerhalb jedes VLAN möglich.

 

Der Switch ist aber End-of-Life und man könnte mal nach was aktuelleres Ausschau halten, welcher IOS spricht.

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...