Jump to content

WRR-Queues auf Layer2


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hi,

 

habe hier einige Cat2950-48-SI mit IOS 12.1(19) die auf Layer2 (CoS) mittels weighted round-robin priorisieren sollen.

 

Konfiguration sieht folgendermaßen aus:

 

....

!

wrr-queue bandwidth 255 255 255 0

wrr-queue cos-map 1 0

wrr-queue cos-map 2 1 2

wrr-queue cos-map 3 4 7

wrr-queue cos-map 4 3 5 6

!

.....

!

interface FastEthernet0/1

description HiPath 4000

switchport mode trunk

no ip address

mls qos trust cos pass-through dscp

spanning-tree portfast trunk

!

...

 

Die HiPath auf Port 1 setzt abgehende Pakete auf Layer2 mit den CoS Bits 3,5 und 6 und auf Layer3 mit DSCP 40. Das DSCP 40 wird vom Switch mittels pass-throug an den Router "weitergereicht", was auch funktioniert. Auf Port 1 ankommenden Frames mit CoS sollte der Switch vertrauen und diese dann aufgrund des wrr immer bevorzugt abarbeiten (die queue 4 ist expedit-queue und wird somit immer bevorzugt).

 

Ich bin mir jetzt allerdings überhaupt nicht sicher, ob der Switch

überhaupt etwas priorisiert.

 

Mit "sh mls qos interface" das mls überprüft:

 

FastEthernet0/1

trust state: not trusted

trust mode: not trusted

COS override: dis

default COS: 0

pass-through: dscp

trust device: none

 

Frage: Warum steht er hier auf "not trusted"?

 

 

Mit "sh int fa 0/1" den Port überprüft:

 

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

 

Frage: Warum FIFO? sollte doch wrr-queuing sein?

 

 

Ich bin mir jetzt überhaupt nicht sicher ob die Switches überhaupt

irgendwas priorisiert (sieht ja nicht danach aus). Muss ich sonst

noch etwas konfigurieren das es läuft? Gibt es noch show oder debug-Befehle die ich übersehen habe (oder nicht kenne)?

 

Da die Switches aktuell noch nicht besonders unter Last stehen, ist die Priorisierung noch nicht zwingend notwendig, aber man sollte ja imho nicht warten bis der delay von alleine kommt :shock:

 

Bin für jede Hilfe dankbar

 

Viele Grüße

Link to comment

Hola

 

der DSCP 40 kommt nicht an, da du kein Voice VLAN gesetzt hast. Du solltest auf jeden Fall auf einem Trunk mls qos trust cos benutzen (ausser du verwendest APs mit IOS kleiner 12.2(3).

 

Der 2950 bietet keine Möglichkeit (nach meinen Wissen) queue hits anzuzeigen. Wenn du die COS Values von 3,5 und 6 der p queue des 1p3q1t Designs zugewiesen hast, werden diese Packete auch zu erst abgearbeitet (habe ich mit SmartBits Messungen getetstet).

Auch auf dem Interface wirst du nicht sehen, dass die wrr queue dem Interface zugewiesen ist.

 

Folgende Config sollte io sein:

!

mls qos

wrr-queue bandwidth 5 25 70 0

wrr-queue cos-map 1 1

wrr-queue cos-map 2 0

wrr-queue cos-map 3 2 4 7

wrr-queue cos-map 4 3 5 6

!

interface FastEthernet0/1

description -->HiPath 4000

switchport trunk native vlan <native>

switchport trunk allowed vlan <voice,data,native>

switchport mode trunk

switchport voice vlan <voice>

speed 100

duplex full

mls qos trust cos

spanning-tree portfast trunk

spanning-tree bpdufilter enable

end

 

Warum setzt die HIPATH eigentlich drei Cos Values; gibts da noch was anderes als Signalling(3) und Voice(5)? Auch die DSCP Values sollten dann unterschiedlich sein..?!

 

 

 

Ciao

Link to comment

Hi daking!

 

Danke für diese ausführliche Antwort!

 

Werde versuchen, das mal so umzusetzen. Ein Problem das ich

vorab schon sehe ist, dass es nicht möglich ist auf dem Switch

im global config das mls qos zu aktivieren. Liegt das am SI (Standard Image)? Funktioniert es auch so.

 

Ich hab das Interface übrigens nur auf Trunking gesetzt, weil mir

von Siemens ICN mitgeteilt wurde, das nur dann der Ethernet-Frame mit 802.1p erweitert bzw. richtig interpretiert wird. Ist diese Aussage richtig?

 

In der derzeitigen Konf wird das DSCP ja bereits mittels pass-through mode weitergereicht. Ist das so nicht korrekt oder ist das Voice VLAN einfach eleganter bzw. leistungsfähiger?

 

Eigentlich sollten wirklich nur die CoS 3 und 5 relevant sein. Wurde mir vom ICN Lab in Nürnberg mitgeteilt auch 6 zu priorisieren. Auf DiffServ-Ebene wird derzeit nur 40 verwendet.

Macht es Sinn hier Abstufungen zu treffen?

 

Danke nochmals

 

Beste Grüße und guten Beschluss!

Link to comment

Hola cyberdyne,

 

hier noch mal was zum cat XL.

 

Frage (intern):Was bietet ein Catalyst XL Switch in Bezug auf QoS?

Cisco Catalyst Switche mit der Endung XL stellen reine Schicht 2 Geräte dar, besitzen

das klassische Cisco Router CLI (IOS) und bieten einfachste QoS Funktionen. Es gibt

zwei Baureihen, die in Bezug auf QoS die gleiche Architektur und somit Funktionalität

besitzen:

Catalyst 29xx-XL

Catalyst 35xx-XL

Wie immer gibt es Ausnahmen. Die ersten Geräte mit einem Speicher von nur 4 MB!

DRAM bieten KEIN QoS, Geräte die über Giga-Stack-Verbindungen

zusammengeschaltet sind bieten keine Garantie (Giga-Stack ist Shared-Gigabit-Ethernet

also mit collisions) und Geräte mit alter Software sind für QoS im Vorfeld upzudaten.

 

Die eingehenden Pakete werden entsprechen ihres Schicht 2 CoS-Wertes einem der

beiden Speicherbereiche zugewiesen. Für Pakete ohne Schicht 2 CoS-Wert kann ein

„default“-Wert der Eingangsschnittstelle zugewiesen werden.

C2924(config-if)# switchport priority default 2!!

Alle Pakete mit einem CoS-Wert von 0 bis 3 gehen immer in den unteren Speicher. Alle

übrigen Pakete werden in dem „bevorzugten“ Speicherbereich abgelegt. Pakete im

oberen Speicher (grün) werden immer vor Paketen im unteren Speicher (blau)

ausgegeben. Sollte ein Speicher vollständig gefüllt sein, so werden die neu

ankommenden Pakete verworfen. Einem angeschlossene IP Phone von Cisco kann

„vertraut“ werden, d.h. die vom IP Phone mit CoS-Werten markierten Voice Pakete

werden der entsprechenden Queue zugewiesen. Bei näherer Betrachtung werden die mit

CoS=5 markierten Voice-Bearer Pakete (RTP) oben abgelegt und Voice-Signalisierungs

Pakete mit einem Wert Cos=3 unten. Die Signalisierungspakete teilen sich mit den

Datenpaketen die untere Queue mit den entsprechenden Konsequenzen. Wenn also die

untere Queue durch zu viele Daten gefüllt ist oder zu viele Pakete mit Werten zwischen 4-

7 den oberen Speicher belegen und den unteren Speicher „verhungern“ lassen, dann wird

Voice (Signalisierungspakete) sehr wohl verworfen.

 

 

Also:

 

- Beim Cat29XL musst du Cos Values setzen, wenn du prio willst oder du setzt die Cos Values fest. Nachteil: keine Unterscheidung von Signalling und Voice. Dies sollte in einer reinen Cat29XL umgebung wurst seint, da du eh nur zwei Queues hast.

 

- du brauchst das PassThrough nicht, wenn du das voice vlan setzt. Nach meiner meinung sollten auch die COS Values überschrieben werden, wenn kein Voice Vlan konf ist. musst mal mit dem Sniffer testen. Das passThrough nimmt man denke ich nur her , wenn du ein dscp mutation map konf hat.

 

-Cos 6 ist z.B. HSRP

 

-wenn du keinen Cat29XL switch benutzt wird der DSCP wert aus der internen COS-zu-DSCP Table gesetzt (und umgekehrt!) und sollte im normalfall für Voice Traffic 46 (ef- expidite forwading) und für signalling 24 oder 26. Sind für Signalling und Voice nun die Werte gleich werden beide mit Cos 5 übertragen!

 

 

Ciao

post-24427-1356738926732_thumb.jpg

Link to comment

Hi daking!

 

Also die Switches sind 2950T-48-SI. Also mit dem Standard Software Image. Gibt es in der Baureihe 29xx überhaupt XL?

Hab hier nur die Unterscheidung zwischen dem Standard Image und Enhanced Image gefunden. Das EI bietet viel weitergehendes QoS als das SI. Da ich aber derzeit nur SI-Systeme habe, muss ich mit klar kommen.

 

Ich werde auf jeden Fall mal die Konfiguration mit dem Voice VLAN umsetzen und mitsniffen.

 

Überhaupt ist es am wichtigsten, dass das DSCP richtig am Router ankommt, weil sonst der Delay bei Bursts auf dem E1-Uplink unvermeidbar wäre.

 

Wenn der Switch wie von dir beschrieben mit seinen 2 Queues priorisiert, genügt mir das vorerst.

 

Nochmals Danke!

Link to comment

Hola,

 

die 29XL Reihe hat 2 Queues. Sorry du hast keinen SI also vier queues. habe einige inst mit VoIP wo die obrige config funzt.

 

wenn das nicht klappt oder dur ef als DSCP brauchst kannst du auch ein classify auf dem Router machen:

!Signalling must du in der acl 111 definieren

!optinal kannst du Bandbreite für Telnet/SSH usw. reservieren !(112)

 

class-map mark_VoIP

match ip rtp start-port range

class-map mark_Signalling

match access-group 111

!

class-map VoIP

match ip dscp 46

class-map Signalling

match ip dscp 26

class-map Network_Control

match access-group 112

!

policy-map VoIP-m

class mark_VoIP

set ip dscp 46

class- mark_Signalling

set ip dscp 26

class class-default

set ip dscp default

!

policy-map QOS

class VoIP

priotity percent 33

class Signalling

bandwidth xy

class Network_Control

bandwidth xy

class class-default

fair-queue

!

int fas 0/0

desc -->conn zu 29SI

service-policy input VoIP-Mark

!

int e0/0:15

desc --> conn to remote

service-policy out QOS

!

 

einen guten rutsch

 

Ciao

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...