Jump to content

Windows explorer mit SU oder Runas startet


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Tach zusammen,

Brauche mal Euren Rat:

Wir nehmen uns in der Firma gerade selbst unsere Adminrechte weg aus Sicherheitsgründen und wollen die Administrationsprogramme mit veränderten Verknüpfungen unter Runas laufen lassen um uns nicht ständig an und abzumelden.

 

Das funzt auch bei den meisten Sachen.

 

Was nicht funktioniert ist das starten vom Explorer mit einem angehängten unc -Pfad und der freigabe auf dem Server. (Homedirectorys der Benutzer wo nur der Jeweilige Benutzer lese und Schreibrechte hat bzw. der Domänenadmin.

 

Ach so wir haben noch eine NT40 Domäne mit W2k Clients.

Microsoft sagt, dass es nicht geht, wir haben jedoch Benutzerkennungen wo es geht und manche wo es nicht geht (am selben Rechner! Berechtigungen sind völlig gleich). Woran liegt das? Fehler: Zugriff verweigert

Bei den Kennungen handelt es um normale DomänenBenutzer. Der Benutzer der mit Runas verwendet wird ist lokaler Admin und Domänenadmin.

 

Dann habe ich versucht SU aus dem Reskit von W2K zu benutzen. Geht auch nicht, da bekomme ich eine Fehlermeldung in etwa:

 

CreateProcessAsUser error! (rc=1780) An den Stub wurde ein Nullzeiger übergeben.

 

Was mache ich da wohl falsch?

 

Weiß jemand eine bessere Lösung?

Gruß

Mattes

 

Hat denn keiner eine Ahnung?

Wie administriert Ihr denn so im allgemeinen? Meldet Ihr Euch immer ab oder habt Ihr immer volle Adminrechte und angemappte Laufwerke auf alle Server etc...#

Link to comment

Lösung:

 

1. Das Programm Su und Suss.exe aus dem Ressourcekit sind Fehlerhaft und aus dem Jahr 1999. Die Dateien müssen mindestens vom 28.06.2000 sein.

Der CreateProcess Fehler ist dann wech und das Programm su funzt an sich, aber das mit den Berechtigungen trotzdem nicht.

Wers haben will:

Unter http://www.isorg.net/other_scripts/su/ können die beiden Dateien runtergeladen werden.

 

Habe das ganze jetzt 1 Woche durchexerziert mit domänenkonten löschen anlegen etc.

Löscht man das DomänenKonto und Profil auf lokalem Rechner, nimmt noch die übriggebliebenen Registrypfade raus erstellt das Konto und Profilneu schon funzt es (kurzfristig). Solange, bis man sich lokal mit der Adminkennung anmeldet, die man auch für den runas befehl verwendet; und das war es dann. Schon geht nix mehr (und bleibt auch so).

 

Unter runas und su kann der Explorer nicht zuverlässig gestartet werden. (ist auch offizielle Aussage von MS)

 

 

Es gibt aber eine Alternative:

 

Man kann den Internetexplorer unter runas laufen lassen mit dem Schalter "c:\\"

Das bewirkt, dass der Internetexplorer als Arbeitsplatz aufgerufen wird unter c:\. Man kann dann oben die Menübefehle in der Sybolleiste hinzufügen vom Windowsexplorer und den Freigabepfad eintippen.

Siehe da es klappt:

 

Hier den Befehlspfad für die Verknüpfung:

 

C:\WINNT\system32\runas.exe /user:adminkennung "\"c:\programme\internet explorer\iexplore\" c:\\"

 

oder entsprechend mit Su, ist dann sieht der Befehl aber etwas anders aus als oben.

 

Entweder in der Dos eingabeaufforderung eintippen oder sich eine Verknüpfung auf die Runas.exe auf dem Desktop erstellen und die obige Zeile unter

[Ziel:] kopieren.

 

 

So liebe Leute ich wünsch Euch eine nette Woche

Gruß

Mattes

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...