Jump to content

PPP Authentification mit Cisco803 will nicht


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo!

Ich habe hier einen 803 Router mit ISDN-Interface. Die prinzipielle Anwahl über Dialer1 funktioniert, aber ich kann mich nicht bei meinem Provider anmelden. DEBUG PPP AUTH gibt folgendes aus:

00:33:42951130472: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up
00:33:42949673024: %ISDN-6-CONNECT: Interface BRI0:2 is now connected to 008005355678
00:33:42955967492: BR0:2 PPP: Treating connection as a callout
00:33:10: BR0:2 CHAP: Using alternate hostname [i]*Benutzername*[/i]
00:33:10: BR0:2 CHAP: O CHALLENGE id 50 len 34 from "[i]*Benutzername*[/i]"
00:33:10: BR0:2 CHAP: I CHALLENGE id 29 len 29 from "jellocom"
00:33:10: BR0:2 CHAP: Using alternate hostname [i]*Benutzername*[/i]
00:33:10: BR0:2 CHAP: O RESPONSE id 29 len 34 from "[i]*Benutzername*[/i]"
00:33:10: BR0:2 CHAP: I FAILURE id 29 len 26 msg is "Authentication failure"
00:33:47244640320: %LINK-3-UPDOWN: Interface BRI0:2, changed state to down
00:33:51541065064: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up

Hier die Dialer-Konfiguration:

interface Dialer1
ip address negotiated
no ip directed-broadcast
ip nat outside
encapsulation ppp
no ip split-horizon
dialer in-band
dialer string 008005355678
dialer-group 1
no cdp enable
ppp authentication ms-chap chap pap
!

Das selbe Problem tritt auch auf, wenn ich auf einen Cisco 4500 (der direkt daneben steht) einwählen will. Ich habe auch schon eine Musterkonfiguration mit dem Cisco ConfigMaker erstellt. Damit klappt's noch weniger...

 

Weiß irgendjemand Rat?

Vielen Dank schonmal,

Elwood

Link to comment

Hoppla, da habe ich eine alte Dialer-Config gepostet. Für CHAP hatte ich Hostname und Passwort schon mitgegeben. Für PAP habe ich's jetzt auch noch eingebaut. Geholfen hat es aber nur bedingt.

Nun bekomme ich zwar ein "Success", aber die ISDN-Verbindung wird trotzdem gleich wieder getrennt.

01:40:4301261828: BR0:2 PPP: Treating connection as a callout
01:40:01: BR0:2 CHAP: Using alternate hostname [i]USERNAME[/i]
01:40:01: BR0:2 MS-CHAP: O CHALLENGE id 25 len 26 from "[i]USERNAME[/i]"
01:40:01: BR0:2 CHAP: I CHALLENGE id 15 len 29 from "jellocom"
01:40:01: BR0:2 CHAP: Using alternate hostname [i]USERNAME[/i]
01:40:01: BR0:2 CHAP: O RESPONSE id 15 len 34 from "[i]USERNAME[/i]"
01:40:01: BR0:2 CHAP: I SUCCESS id 15 len 4

Link to comment

Danke für die prompte Antwort! Ich bin leider nicht gleich zum Antworten gekommen.

Ja, der Config-Maker macht nicht allzuviel. Aber das mit der Flatrate ist im Moment nicht so wichtig. Das Teil soll überhaupt erstmal funktionieren.

 

Okay, dann hier mal die Config:

 

Current configuration:
!
version 12.0
hostname Cisco803
!
pots country DE
ip subnet-zero
!
isdn switch-type basic-net3
isdn voice-call-failure 0
!
interface Ethernet0
ip address *.*.*.* 255.255.255.0
no ip directed-broadcast
ip nat inside
!
interface BRI0
no ip address
no ip directed-broadcast
ip nat outside
encapsulation ppp
dialer rotary-group 1
isdn switch-type basic-net3
no cdp enable
!
interface Dialer1
ip address negotiated
no ip directed-broadcast
ip nat outside
encapsulation ppp
no ip split-horizon
dialer in-band
dialer string 008005355678
dialer-group 1
no cdp enable
ppp authentication ms-chap chap pap
ppp chap hostname *****
ppp chap password 7 ***
ppp pap sent-username ***** password 7 ***
!
router rip
version 2
network *.*.*.*
no auto-summary
!
ip nat inside source list 2 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!
end

Ich denke, das Wichtigste von deb ppp xxx ist:

00:23:02: BR0:2 LCP: State is Open
00:23:02: BR0:2 PPP: Phase is AUTHENTICATING, by both
00:23:02: BR0:2 CHAP: Using alternate hostname *****
00:23:02: BR0:2 MS-CHAP: O CHALLENGE id 34 len 26 from "*****"
00:23:02: BR0:2 CHAP: I CHALLENGE id 10 len 29 from "jellocom"
00:23:02: BR0:2 CHAP: Using alternate hostname *****
00:23:02: BR0:2 CHAP: O RESPONSE id 10 len 34 from "*****"
00:23:02: BR0:2 CHAP: I SUCCESS id 10 len 4
00:23:02: BR0:2 LCP: I TERMREQ [Open] id 141 len 4
00:23:02: BR0:2 LCP: O TERMACK [Open] id 141 len 4
00:23:02: BR0:2 PPP: Phase is TERMINATING
00:23:8589934592: %LINK-3-UPDOWN: Interface BRI0:2, changed state to down
00:23:8589934592: BR0:2 LCP: State is Closed
00:23:8596229060: BR0:2 PPP: Phase is DOWN

Und jetzt deb isdn events:

00:28:33: ISDN BR0: Outgoing call id = 0x802A, dsl 0
00:28:33: ISDN BR0: Event: Call to 008005355678 at 64 Kb/s
00:28:33: ISDN BR0: process_bri_call(): call id 0x802A, called_number 008005355678, speed 64, c
all type DATA
00:28:141733961728: CC_CHAN_GetIdleChanbri: dsl 0
00:28:141733961728:     Found idle channel B1
00:28:141740215428: ISDN BR0: received HOST_INFORMATION call_id 0x802A
00:28:146028929024: ISDN Event: dsl 0 call_id 0x802A B channel assigned by switch 1
ISDN BR0: received HOST_CONNECT call_id 0x802A
00:28:146028888076: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up
00:28:146028888128: %ISDN-6-CONNECT: Interface BRI0:2 is now connected to 008005355678
00:28:146035182636: ISDN BR0: Event: Connected to 008005355678 on B2 at 64 Kb/s
00:28:150323855359: ISDN BR0: received HOST_FACILITY_INVOKE call_id 0x802A
       Cause i = 0x8090 - Normal call clearing
00:28:146028929024:         Facility i = 0x91A113020200A5020122300AA1053003020100820101
00:28:146028929024:     - ETSI Supplementary Service, Invoke, AOC-D Charging Units: 0
00:28:146035182724: ISDN BR0: received HOST_DISCONNECT call_id 0x802A
00:28:146028888064: ISDN BR0: Event:  Call to <unknown> was hung up.
00:28:146035182596: ISDN BR0: process_disc_ack(): call id 0x802A, ces 1, call type DATA
00:28:150323855359: %LINK-3-UPDOWN: Interface BRI0:2, changed state to down
00:28:146035182636: ISDN BR0: received HOST_DISCONNECT_ACK call_id 0x802A
00:28:146028888064: ISDN BR0: HOST_DISCONNECT_ACK: call type is DATA

Link to comment

auf brio0 kannst Du "ip nat outside" raus nehmen.

 

auf dialer1 solltest du das einfügen:

ppp authentication chap pap callin

 

ausserdem fehlt die acl 2:

access-list 2 permit *.*.*.* 0.0.0.255

 

ausserdem ist folgender Zusatz ganz sinnvoll:

dialer-list 1 protocol ip list 120

access-list 120 deny udp any eq syslog any

access-list 120 deny udp any eq snmp any

access-list 120 deny udp any eq snmptrap any

access-list 120 deny udp any eq ntp any

access-list 120 deny udp any eq netbios-dgm any

access-list 120 deny udp any eq netbios-ns any

access-list 120 deny udp any eq netbios-ss any

access-list 120 deny udp any eq 123 any

access-list 120 deny udp any range snmp snmptrap any

access-list 120 deny udp any range bootps bootpc any

access-list 120 deny tcp any eq 137 any

access-list 120 deny tcp any eq 138 any

access-list 120 deny tcp any eq 139 any

access-list 120 permit ip any any

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...