Jump to content

Netzwerkumgebungsproblem mit 2 WIN NT 4.0 PDCs und 2 WIN NT 4.0 Workstations


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo,

 

wir haben da ein etwas größeres Problem mit zwei Testumgebungen.

In diesen Testumgebungen sind insgesamt 4 Rechner vorhanden.

Zwei Windows NT 4.0 Workstations und zwei Windows NT 4.0 Server. Die zwei NT Server fungieren als PDC und verwalten jeweils eine eigene Domäne. Jeweils eine der beiden Workstations ist mit einem der Server direkt verbunden und Mitglied der jeweiligen Domäne. Bei den beiden Servern sind zwei Netzwerkkarten eingebaut. Somit gibt es insgesamt 3 Subnetze. Um das ganze jetzt ein wenig zu verdeutlichen schreibe ich mal eine kleine Liste mit den IP Adressen, Subnetmasken und Gateways von allen Rechnern:

 

Domäne A:

 

Workstation A:

IP-Adresse: 192.168.2.50

Subnetmask: 255.255.255.0

Gateway: 192.168.2.1

 

Server A 1.NIC:

IP-Adresse: 192.168.2.1

Subnetmask: 255.255.255.0

Gateway: 192.168.2.1

 

Server A 2.NIC:

IP-Adresse: 192.168.3.1

Subnetmask: 255.255.255.0

Gateway: keins eingetragen

 

Statische Route bei Server A:

192.168.1.0 mask 255.255.255.0 192.168.3.2

 

Server A ist der PDC für die Domäne A. Er hat ebenso einen DHCP-, sowie DNS- und WINS-Server. Die IP-Adressen bekommt die Workstation A über DCHP mitgeteilt.

 

 

Domäne B:

 

Workstation B:

IP-Adresse: 192.168.1.8

Subnetmask: 255.255.255.0

Gateway: 192.168.1.5

 

Server B 1.NIC:

IP-Adresse: 192.168.1.5

Subnetmask: 255.255.255.0

Gateway: 192.168.1.5

 

Server B 2.NIC:

IP-Adresse: 192.168.3.2

Subnetmask: 255.255.255.0

Gateway: keins eingetragen

 

Statische Route bei Server b:

192.168.2.0 mask 255.255.255.0 192.168.3.1

 

Server B ist der PDC für die Domäne B. Er hat ebenso einen DHCP-, sowie DNS- und WINS-Server. Die IP-Adressen bekommt die Workstation B über DCHP mitgeteilt.

 

 

Da bei diesen beiden Testumgebung nur jeweils eine Workstation vorhanden ist, wird demnach auch immer dieselbe IP-Adresse per DHCP vergeben. Was ja auch nichts macht.

 

Die Workstations registrieren sich beide bei ihren jeweiligen WINS-Servern. Beide WINS-Server replizieren ihre Datenbank mit dem jeweils anderen mit PUSH/PULL Parametern. Die Namensauflösung funktioniert auch einbahnfrei und auf allen Rechner. Sprich „ping“ mit NetBIOS Name und FQDN funktioniert alles. Bei beiden PDCs ist auch eine beidseitige Vertrauensstellung eingerichtet worden.

 

Das Problem:

Wenn wir bei den Workstations auf Netzwerkumgebung klicken sehen wir einmal alle Rechner die in der Domäne sind, die der Workstation angehört, sowie alle Rechner der jeweils anderen Domäne.

Bei den Server jedoch sehen wir nur die Server, der jeweils anderen Domänen. Wie lässt sich dieses Browsing Problem, oder wie man es auch immer nennen mag, lösen? Oder wenigstens Ansatzweise lösen?

 

P.S.: Die Forensuche haben wir natürlich schon benutzt und nicht nur diese Forensuche ;)

Link to comment

Hi !

Das Problem hierbei sind die die jeweils 2 Netzwerkkarten in den PDC, die automatisch auch den jweiligen Hauptsuchdienst der Domäne machen.

 

Da sich dieser Hauptsuchdienst laut MS immer nur an eine Netzwerkkarte hängt, sind die Chancen 50/50, welche Karte genommen wird.

 

Wenn ein WinsServer läuft, wie bei Euch, sollte eigentlich der mitabgefragt werden - deshalb wird auf den WS das Netz wohl korrekt angezeigt.

Warum auf den PDC der Wins nicht mithinzu genommen wird, kann ich allerdings nicht sagen.

 

Die Lösung dieses Problems ist aber, nur eine NW-Karte im PDC zu haben ! ;)

Link to comment

Hallo,

 

erst einmal vielen vielen vielen Dank, dass sich jemand gemeldet hat.

 

Also, soweit waren wir auch schon. Dass es dieses Problem mit dem Hauptsuchdienst gibt haben wir auch herausgefunden.

 

Nur ist es jetzt so, dass wir die PDCs unbedingt mit den 2 Netzwerkkarten am laufen haben müssen.

 

Gibt es vielleicht noch irgendetwas anderes was man machen könnte, damit es funktioniert. Weil im Prinzip läuft ja alles so wie es soll, Namensauflösung und so weiter und so weiter, nur sehen halt die beiden Server nicht alle Rechner in ihrerer Netzwerkumgebung.

 

Danke für jeden weiteren Tip.

Link to comment

Hallo,

 

leider haben wir diesen Artikel auch schon gelesen und gefunden gehabt und natürlich auch gleich ausprobiert. jedoch ohne jgelichen Erfolg. Es ist allenfalls schlimmer geworden, bis zu dem Punkt, dass wir gar nichts mehr sahen in der Netzwerkumgebung.

 

Aber trotzdem vielen Dank für Eure Hilfe!

 

 

Somit komme ich zu dem Schluss, dass wir bis zu dem oben beschriebenen Stand gekommen sind und in der Netzwerkumgebung (von den Servern aus) nicht mehr als nur die Server, der jeweils anderen Domäne, zu sehen ist.

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...