Jump to content
Sign in to follow this  
mister2x

RTSP - Protokoll über 1712er

Recommended Posts

Hallo zusammen,

 

ich sollte aktuell einem Streaming Server der sich hinter einem 1712er Router befindet die Möglichkeit zum streamen geben ;) Es wird aktuell nur von einem Client mittels der Quicktime-Software ein Stream zu einem "echten" Streaming Server gesendet - und hier liegt das Problem.

 

Das Problem ist, ich habe ausgehend ein Inspection Rule erstellt (mit rtsp), welches zwar für die Clients funktioniert (wenn der Stream abgefragt wird), aber nicht für den Sender ausgehend.

 

Ich muss immer das Inspection Rule DEaktivieren, den Stream starten, dann das Inspection Rule wieder aktivieren (damit gesurft werden kann etc.) - ?! dann funktioniert die Sache.

 

Hier ein Auszug aus der Config (v.12.2)

 

!

interface FastEthernet0

mac-address xx

ip address xx

ip nat outside

ip route-cache flow

ip inspect DEFAULT100 out

ip access-group 104 in

no ip redirects

no ip unreachables

no ip proxy-arp

duplex auto

speed auto

crypto map mode

no cdp enable

 

 

ip inspect name DEFAULT100 cuseeme

ip inspect name DEFAULT100 ftp

ip inspect name DEFAULT100 h323

ip inspect name DEFAULT100 netshow

ip inspect name DEFAULT100 rcmd

ip inspect name DEFAULT100 realaudio

ip inspect name DEFAULT100 rtsp

ip inspect name DEFAULT100 smtp

ip inspect name DEFAULT100 sqlnet

ip inspect name DEFAULT100 streamworks

ip inspect name DEFAULT100 tftp

ip inspect name DEFAULT100 tcp

ip inspect name DEFAULT100 udp

ip inspect name DEFAULT100 vdolive

ip inspect name DEFAULT100 icmp

 

 

no access-list 104

access-list 104 remark FastEthernet0 inbound

access-list 104 permit udp any any eq domain

!

access-list 104 permit ip host IP-StreamingSV1 any log

access-list 104 permit ip host IP-StreamingSV2 any log

access-list 104 permit ip host IP-StreamingSV3 any log

<snip - hier gehts noch weiter aber für das Problem uninteressant>

 

Deaktiviere ich die DEFAULT100 kurzzeitig, kann ich den Stream starten und dann auch wieder das Inspection Rule aktivieren - der Stream rennt weiter und die Clients können ins Internet etc.

 

Mein Problem ist nur dass ich es nicht schaffe den Stream mit aktiviertem Inspection Rule zu starten.

 

Hat hierzu vielleicht jemand eine Idee?

 

Danke im Voraus

Christian

Share this post


Link to post

Hallo,

 

versuch am FEth: ip inspect DEFAULT100 <IN> anstatt <out> .

 

Mach am Ende der ACL 104:

(conf)#deny ip any any log

wenn du üer telnet drauf ist noch:

#term mon

 

Vielleicht findest du ja was.

 

 

Wenn du während der StreamingSession

#sh ip access-list 104

machst, siehst du die dynamisch angepasste ACL....

 

 

Grüsse

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...