Jump to content
xrated2

RRAS und eigenes Subnet, Probleme mit Namensauflösung

Recommended Posts

Hallo

 

Aufgrund Corona laufen mittlerweile alle Clients über VPN.

Momentan habe ich für VPN Clients ein eigenes Subnet laufen, was aber nicht mehr unbedingt benötigt wird.

Es ist momentan das Problem das die Namensauflösung der Clients nicht funktioniert d.h. der DHCP Server liefert falsche IP Adressen vom Client (als wäre er im LAN Subnet) bei Abfrage.

 

So ist es momentan eingerichtet:

VPN Verbindung am Client per Powershell hinzugefügt:

Add-VpnConnection -Name $vpnname -ServerAddress $vpnserver -TunnelType "Sstp" -EncryptionLevel "Maximum" -AuthenticationMethod "Eap" -EapConfigXmlStream $EAPconfig -RememberCredential -AllUserConnection -SplitTunneling 

 

In RRAS habe ich unter Adressezuweisung einen statischen Adresspool mit dem VPN Range angelegt.

Weiter habe ich unter DHCP-Relay-Agent die IP Adressen von beiden DHCP Servern hinterlegt, damit die DHCP Optionen vom Client bezogen werden.

Im DHCP Server habe ich einen VPN Range mit den entsprechenden DHCP Optionen angelegt. Dort tauchen die Leases aber leider nicht auf, deswegen wohl auch die Probleme mit der Namensauflösung.

 

Bei RRAS gibt es keine Möglichkeit das zu verbessern, ausser die VPN Clients im LAN Subnet laufen zu lassen, richtig?

 

Wenn ich wieder alles auf ein Subnet umstelle, wie setze ich dann die Default Route auf den Clients:

Add-VpnConnectionRoute -ConnectionName "vpn" -DestinationPrefix "192.168.3.0/24"

 

Es gibt bei Win10 zwar die Möglichkeit  wenn die Verbindung als -AllUserConnection angelegt ist, sich gleichzeitig bei Windows + VPN anzumelden, aber funktionieren dann auch CSE wie Logon oder Startup Scripts? Offiziell geht das ja nur über AlwaysOn + Win10 Enterprise über einen Gerätetunnel aber es ist leider nur Pro vorhanden.

Edited by xrated2

Share this post


Link to post
Share on other sites

Niemand da?

 

In Punkto Netzunterbrechungen beim VPN Client wird ja bei IkeV2 das sog. Mobility beworben, wo man in der Standardeinstellung bis zu 30min. Netzausfall überbrücken kann ohne das die Verbindung getrennt wird. Leider scheint das nicht bei NAT auf beiden Seiten zu funktionieren und ich komme da auf ca. 20 Sekunden bis die VPN Verbindung getrennt wird, sobald kein Internet mehr da ist.

 

 

Share this post


Link to post
Share on other sites

Habe nun herausgefunden warum die Namensauflösung nicht ging, man musste nur beim PPP Eintrag die DNS Registrierung aktivieren.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Werbepartner:



×
×
  • Create New...