Jump to content
Melde dich an, um diesen Inhalt zu abonnieren  
Avaatar

Ordnerumleitung auf Client unter Citrix Xenapp 6 Fundamentals

Empfohlene Beiträge

Hallo zusammen,

 

ich beiße mir an einem Problem die Zähne aus und komme nicht weiter und hoffe nun, dass jemand eine Idee hat.

Ich habe hier einen Citrix Server der benötigt wird um eine alte Applikation zu betreiben. Bei dieser Applikation gibt

es folgendes Problem:

Die Anwendung schreibt Dateien (z.B. Druckvorschauen im HTML Format welche sich dann im IE öffnen) auf C:\temp

Leider ist dies hardkodiert. Eine Umprogrammierung kommt nicht in Frage da die Anwendung irgendwann abgelöst

werden soll. Die Dateien landen also immer zwingend in C:\temp.

Leider war man auch so nicht-clever und hat den Dateien keine eindeutigen Namen gegeben. Wenn nun also 2+ User

auf dem Citrix Server arbeiten und die gleiche Druckvorschau aufrufen, überschreiben sie sich gegenseitig.

 

Der alte Citrix Server (2003 mit Presentation Server 4.5) hatte als Windows Laufwerk den Buchstaben X:. Dies hatte

zur Folge dass das Clientlaufwerk sich unter C: verbinden konnte und das Problem war dadurch gelöst.

Unter 2008 R2 gibt es leider nicht mehr die Möglichkeit das Laufwerk C: in X: umzubenennen. Die Clientlaufwerke

werden (z.B. C:) unter V:, U: etc. gemappt.

Ich stehe jetzt also vor dem Problem wie ich C:\temp so umbiegen kann dass er auf das Clientlaufwerk zeigt (V:\temp).

Mit Hardlinks komme ich nicht weit da diese ja nur auf dem gleichen Laufwerk gelten. Mit einer Verknüpfung

(Die temp heisst, auf C: liegt und auf V:\temp zeigt) klappt es leider auch nicht da die Software da Zicken macht, das

ist nicht sauber genug.

Die Ordnerumleitung selber funktioniert meines Wissens nach nur mit Ordnern im Benutzerprofil.

Hat irgendwer noch eine Idee wie ich das Dilemma lösen kann?

 

Die Umgebung sieht wie folgt aus:

Server: VM mit Windows 2008 R2 aktueller Patchstand

Citrix: Citrix Xenapp Fundamentals 6

 

 

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Falls noch jemand mal vor diesem Problem steht:

Ich habe den ganzen Mist jetzt verworfen und Windows mit einer Unattend.xml Datei neu installiert. Hier kann man nämlich den Laufwerksbuchstaben mitgeben, das System läuft nun unter X:

Jetzt muss nur noch das alte Laufwerksmapping in Xenapp installiert werden damit die lokalen Clientlaufwerke mit Buchstaben durchgereicht werden und das war es dann.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden
Melde dich an, um diesen Inhalt zu abonnieren  

Werbepartner:



×