Jump to content

Firewallregeln per Kommandozeile


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo zusammen,

 

es gibt einen Satz Firewallregeln den ich per Kommandozeile ändern möchte da ich dies später für sehr viele Installationen brauche.

 

Ich habe es auch soweit hinbekommen, es klemmt nur an einer Sache. Aber eins nach dem anderen.

 

Ich schaue bei mir auf dem PC in die Windows Firewall und sehe: (Ist nur ein Beispiel)

 

- Netzwerkerkennung (LLMNR-UDP eingehend) Profil Domäne = AUS

- Netzwerkerkennung (LLMNR-UDP eingehend) Profil Privat     = EIN

 

Ich möchte das Profil Domäne, Regel dieses Namens auf EIN gestellt wird.

 

Dann gehe ich hin und gebe folgendes ein:

 

netsh advfirewall firewall set rule name="Netzwerkerkennung (LLMNR-UDP eingehend)" new enable=yes profile=domain

 

Doch leider passiert folgendes:

2 Regel(n) wurde(n) aktualisiert.
OK.

 

Schaue ich nun wieder in die Firewall sehe ich folgendes:

- Netzwerkerkennung (LLMNR-UDP eingehend) Profil Domäne = EIN

- Netzwerkerkennung (LLMNR-UDP eingehend) Profil !!DOMAIN!! = EIN (vorher Privat)

 

Der Befehl geht also hin und setzt die Firewall Regel für das Profil Domain auf ON, dummerweise überbügelt er aber auch das Profil Privat und ich habe danach zwei identische Regeln, beide Domäne.

 

Ich habe den Syntax "profile=domain" so verstanden das nur Regeln des Namens im Profil Domäne geändert werden?


Dann wäre ich auch glücklich.

 

Was kann ich denn da so falsch machen?

 

P.S.

 

Der Ansatz ist ja eine Regel beim Namen zu nennen und diese nur für Profil=X zu ändern.

 

Ich habe es auch schon über den Weg Gruppe probiert, aber dann setzt er mir die Regeln=Name in der Gruppe für alle Profile ON.

 

Ich möchte aber nur EINE Regel, per Name, in Profil=X ändern.

 

Das hatt ja nachher unübersehbare Konsequenzen.

 

Nachtrag:

 

Ich glaube ich habs gefunden =)

 

netsh advfirewall firewall set rule name="Netzwerkerkennung (LLMNR-UDP eingehend)" profile=domain new enable=yes

 

Der Profilename muss VOR dem "new" stehen, was wenn ich darübern nachdenke auch total logisch ist °_O

Edited by PathFinder
Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...