Jump to content
Melde dich an, um diesen Inhalt zu abonnieren  
S.R.

IIS: php 5.5.0 per FastCGI laden

Empfohlene Beiträge

Hallo,

 

ich habe hier einen W2K12 Server mit IIS und habe dort bereits php 5.4.17 am Laufen. Nun möchte ich meine ersten Tests mit php 5.5.0 starten und habe die php-cgi.exe genauso eingebunden, wie auch die der alten Version.

 

Dann habe ich das mini-Script

 

<?php

  phpinfo();

?>

 

angelegt und rufe dies nun auf. Im Browser erhalte ich dann einen 500er-Fehler:

 

HTTP-Fehler 500.0 - Internal Server Error C:\php\php-5.5.0-nts-Win32-VC11-x86\php-cgi.exe - Der FastCGI-Prozess wurde unerwartet abgebrochen.

 

Ich habe ehrlich gesagt keinen blassen Schimmer was ich falsch gemacht habe und leider auch keinen blassen Schimmer, wo ich weiter suchen soll... Finde auch keine Log oder eine Protokollierung, wo weitere Infos stehen...

 

Bin für jeden Tipp dankbar :-)

 

Gruß

 

Stefan

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo Stefan,

 

auch ich habe wochenlang nach einer Lösung gesucht da ich das gleiche Problem hatte dabei ist die Lösung eigentlich logisch und somit simpel. ^^

 

Also da php 5.5 mit c++ 2012 compiliert wurde musst Du natürlich die Libarys dazu installieren.

 

Visual C++ Redistributable for Visual Studio 2012

 

Einfach das installieren und IIS neustarten dann klappts auch. :)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo,

 

vielen, vielen Dank für die Info. Daran hat es natürlich gelegen. Installiert und schon klappts - danke!

 

Gruß

 

Stefan

  • Like 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo Stefan,

 

auch ich habe wochenlang nach einer Lösung gesucht da ich das gleiche Problem hatte dabei ist die Lösung eigentlich logisch und somit simpel. ^^

 

Also da php 5.5 mit c++ 2012 compiliert wurde musst Du natürlich die Libarys dazu installieren.

 

Visual C++ Redistributable for Visual Studio 2012

 

Einfach das installieren und IIS neustarten dann klappts auch. :)

 

Vielen Dank hab mich extra registriert um die das zu sagen. 

War eigentlich total simpel aber du hast meinen ars*** gerettet! :D

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden
Melde dich an, um diesen Inhalt zu abonnieren  

×