Jump to content

IPv6 DNS Auflösung


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo,

 

ich möchte, dass auf meinem Router (1841) auch Domainnamen in IPv6 Adressen aufgelöst werden. Bei IPv4 funktioniert die Namensauflösung prima. Bei IPv6 kann ich zumindest auch im Router selbst (über die Console) "ping ipv6-p-p.z-ipnet.de" ausführen und der Name wird in die Adresse 2001:DB8:BAD:CAFE::2 aufgelöst.

 

Bei meinen Clients funktioniert das jedoch nicht...

 

Die Clients (Windows 7) hängen an einem Speedport, welcher ein /64er Netz per ICMPv6 und ein /56er Netz per DHCPv6 PD von dem 1841 zugeteilt bekommt. Der Speedport bildet dann ein /64 Netz für die Clients.

 

Ich kann vom Client aus den Server 2001:DB8:BAD:CAFE::2 anpingen. Ich kann ihn aber nicht unter der Adresse ipv6-p-p.z-ipnet.de anpingen.

 

Ich bekomme die Fehlermeldung:

 

Ping-Anforderung konnte Host "ipv6-p-p.z-ipnet.de" nicht finden. Überprüfen Sie den Namen, und versuchen Sie es erneut.

 

Ich habe den DNS-Server über DHCPv6 verteilt. Die Konfig ist unten zu sehen:

 

Hat jemand eine Idee, was ich falsch mache oder ob ich etwas vergessen habe? Wenn die Namensauflösung auf dem Router selbst funktioniert, muss ja im DHCP etwas nicht stimmen...

 

Danke :)

 

 

Current configuration : 6409 bytes
!
! Last configuration change at 11:30:54 CEST Wed May 29 2013
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname IPv4_IPv6_BBRAR
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
memory-size iomem 15
clock timezone CET 1 0
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00
dot11 syslog
ip source-route
!
ip dhcp pool VLAN8
 network 172.16.88.0 255.255.255.0
 default-router 172.16.88.254
 dns-server 172.16.88.254 172.16.88.254
!
ip cef
ip host p-p.z-ipnet.de 111.222.111.222
ipv6 host ipv6-p-p.z-ipnet.de 2001:DB8:BAD:CAFE::2
ipv6 unicast-routing
ipv6 cef
ipv6 dhcp pool zms_vlan7_v6
 prefix-delegation pool zms_vlan7_v6_pdpool lifetime 1800 600
 dns-server 2001:DB8:CAFE:BEEF::1
 domain-name ipv6-t-online.de
!
multilink bundle-name authenticated
!
vpdn enable
!
crypto pki token default removal timeout 0
!
username user1 password 7 120D0004065A
username user2 password 7 15060E1F1078
username user3 password 7 0835495D1D4A
!
redundancy
!
bba-group pppoe vlan7
 virtual-template 7
!
interface FastEthernet0/0
 description Daten-Uplink_zum_CiscoSwitch_ohneVLAN
 ip address 172.16.2.254 255.255.255.0
 duplex auto
 speed auto
 ipv6 address 2001:DB8:BAD:CAFE::1/64
 ipv6 enable
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.7
 description Daten_PPPoE-Uplink_zum_CiscoSwitch_VLAN_7
 encapsulation dot1Q 7
 ip address 172.16.77.254 255.255.255.0
 ipv6 address 2001:DB8:CAFE:BEEF::1/64
 ipv6 enable
 pppoe enable group vlan7
!
interface FastEthernet0/1.8
 description Daten_PPPoE-Uplink_zum_CiscoSwitch_VLAN_8
 encapsulation dot1Q 8
 ip address 172.16.88.254 255.255.255.0
!
interface Virtual-Template7
 ip unnumbered FastEthernet0/1.7
 peer default ip address pool zms_vlan7
 peer default ipv6 pool zms_vlan7_v6_pool
 ipv6 unnumbered FastEthernet0/1.7
 ipv6 enable
 ipv6 nd other-config-flag
 no ipv6 nd ra suppress
 ipv6 dhcp server zms_vlan7_v6
 ppp authentication pap chap
 ppp ipcp dns 172.16.77.254 172.16.77.254
!
ip local pool zms_vlan7 172.16.77.10 172.16.77.45
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip dns server
ip dns primary z-ipnet.de soa ZMS-7401ASR.z-ipnet.de admin.z-ipnet.de 21600 900 7776000 86400
ip route 172.16.2.0 255.255.255.0 FastEthernet0/0
ip route 111.222.111.222 255.255.255.255 172.16.2.155
ip route 222.111.148.22 255.255.255.255 172.16.2.155
ip route 222.111.148.70 255.255.255.255 172.16.2.155
ip route 222.111.148.102 255.255.255.255 172.16.2.155
ip route 222.111.149.142 255.255.255.255 172.16.2.155
ip route 222.111.149.205 255.255.255.255 172.16.2.155
ip route 222.111.150.51 255.255.255.255 172.16.2.155
ip route 222.111.150.115 255.255.255.255 172.16.2.155
ip route 222.111.150.188 255.255.255.255 172.16.2.155
ip route 222.111.150.205 255.255.255.255 172.16.2.155
ip route 222.111.151.51 255.255.255.255 172.16.2.155
ip route 222.111.151.115 255.255.255.255 172.16.2.155
ip route 222.111.151.142 255.255.255.255 172.16.2.155
ip route 222.111.151.205 255.255.255.255 172.16.2.155
!
ipv6 route 2001:DB8:BAD:CAFE::/64 FastEthernet0/0
ipv6 local pool zms_vlan7_v6_pdpool 2001:DB8:BEEF::/48 56
ipv6 local pool zms_vlan7_v6_pool 2001:DB8:DEAD::/48 64
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 login
 transport input all
!
scheduler allocate 20000 1000
end
 

 

 

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...