Jump to content
Sign in to follow this  
ibicis

Job wird nicht ausgeführt

Recommended Posts

Problem: Ein mit dem Taskplaner erstellter Task, der nach Bedarf bzw. Event eine CMD-Datei aufruft, wird unter Win 7/Server 2008 (NT 6.1/6.0) nicht erwartungsgemäß abgearbeitet. Dieselben Aktionen, die als Task unter Windows XP/Server 2003 (NT 5.1/5.2) definiert wurden, funktionieren unter den NT-Vorgängerversionen einwandfrei. Rufe ich die CMD manuell auf, wird sie unter Win 7/Server 2008 ebenfalls erwartungsgemäß ausgeführt, nur eben nicht als Task.

Die CMD schreibt einige Daten in eine Textdatei, die dann mit einem Tool (Blat.exe) als Mail versendet werden. Die Logdatei des Mail-Tools gibt aus, dass Blat.exe keine Textdatei fand, was korrekt ist, da als Job leider keine erstellt wurde.

Die Syntax des Tasks:

<?xml version="1.0" encoding="UTF-16"?>
<Task version="1.2" xmlns="http://schemas.microsoft.com/windows/2004/02/mit/task">
 <RegistrationInfo>
   <Date>2011-11-29T11:08:34.6012057</Date>
   <Author>DOMAIN\administrator</Author>
 </RegistrationInfo>
 <Triggers />
 <Principals>
   <Principal id="Author">
     <UserId>DOMAIN\Administrator</UserId>
     <LogonType>Password</LogonType>
     <RunLevel>HighestAvailable</RunLevel>
   </Principal>
 </Principals>
 <Settings>
   <IdleSettings>
     <Duration>PT10M</Duration>
     <WaitTimeout>PT1H</WaitTimeout>
     <StopOnIdleEnd>true</StopOnIdleEnd>
     <RestartOnIdle>false</RestartOnIdle>
   </IdleSettings>
   <MultipleInstancesPolicy>IgnoreNew</MultipleInstancesPolicy>
   <DisallowStartIfOnBatteries>false</DisallowStartIfOnBatteries>
   <StopIfGoingOnBatteries>true</StopIfGoingOnBatteries>
   <AllowHardTerminate>true</AllowHardTerminate>
   <StartWhenAvailable>false</StartWhenAvailable>
   <RunOnlyIfNetworkAvailable>false</RunOnlyIfNetworkAvailable>
   <AllowStartOnDemand>true</AllowStartOnDemand>
   <Enabled>true</Enabled>
   <Hidden>false</Hidden>
   <RunOnlyIfIdle>false</RunOnlyIfIdle>
   <WakeToRun>false</WakeToRun>
   <ExecutionTimeLimit>PT1H</ExecutionTimeLimit>
   <Priority>7</Priority>
 </Settings>
 <Actions Context="Author">
   <Exec>
     <Command>C:\temp\mail.cmd</Command>
     <Arguments>/profile /user:DOMAIN\administrator</Arguments>
   </Exec>
 </Actions>
</Task>

 

Die Syntax der CMD:

echo Test-Mail > "mail-body.txt"
echo Datum: %date% >> "mail-body.txt"
echo Zeit: %time% >> "mail-body.txt"
echo Computer: %computername% >> "mail-body.txt"
echo Test-Mail1 >> "mail-body.txt"

rem *E-Mail Versenden mittels "Blat"*
cd /d "C:\temp"
Blat -install server01.DOMAIN sysadmin@domain.de
Blat "mail-body.txt" ^
-to user1@domain.de -server mail.domain.de -u sysadmin@domain.de -pw password ^
-debug -timestamp -log blatSMTPlog.txt ^
-subject "Test"

 

Beide Dateien, sowohl die XML der Tasksyntax, als auch die CMD, liegen im ZIP-Anhang, falls jemand die Settings nachvollziehen mag.

Wo liegt mein Denkfehler beim Konzept? Ich habe bereits alle (un)möglichen Settings im Task selbst ausprobiert, nichts funktionierte bisher.

Danke vorab.

Share this post


Link to post
Share on other sites

Bist Du sicher, dass das Script weiß, wohin "mail-body.txt" gespeichert werden soll?

Ich würde mal testweise absolute Pfade angeben, also

echo Test-Mail > "c:\temp\mail-body.txt"

Share this post


Link to post
Share on other sites
Bist Du sicher, dass das Script weiß, wohin "mail-body.txt" gespeichert werden soll?

Ich würde mal testweise absolute Pfade angeben, also

echo Test-Mail > "c:\temp\mail-body.txt"

Genau das war das Problem. Wollte mein Erstpost gerade editieren, da ich es durch probieren zufällig selbst gefunden hatte. Komisch nur, dass es unter den NT 5.x ohne Pfadangabe funktioniert bzw. komisch, dass es ab NT 6.x halt nicht mehr funktioniert.

Danke trotzdem.

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...