Jump to content
Sign in to follow this  
chrisys

Problem Einrichtung zusätzlicher DC

Recommended Posts

Hallo Zusammen,

 

hiermit würde ich bei folgendem Problem um Hilfe bitten:

Es ist mir nicht möglich einen Windows Server 2003 R2 in einem Nachbargebäude mit 'dcpromo' zu einem zusätzlichen DC einzurichten.

 

Umgebung:

Es existiert bisher in der Domäne ein DC auf Basis von Windows Server 2003 R2. Ein zusätzlicher DC ist im Nachbargebäude vorgesehen, da die Anbindung zw. den Gebäuden nicht die schnellste ist. Der Server ist bereits in der Domäne aufgenommen.

 

Bisher durchgeführte Schritte:

Es wurde ein zusätzlichen AD-Standort in "Active Directory Standorte und Dienste" einrichtet

Es wurde ein Subnetz anlegt und mit diesem Standort verknüpfen

Es wurde eine 'Reverse Lookup Zone' für den neuen Standort bzw. das Subnetz im DNS einrichtet

Der DNS-Server wurde installiert, aber noch nicht konfiguriert.

 

Fehlerverhalten:

Beim Ausführen von 'dcpromo' bricht dieses nach einiger Zeit mit einem unbekannten Fehler ab.

 

Im DCPROMO.LOG ist folgendes zu finden:

01/12 10:43:38 [iNFO] Die Schemaverzeichnispartition wird repliziert.

01/12 10:43:40 [iNFO] Replikation von CN=Schema,CN=Configuration,DC=xxx,DC=local: 1000 Objekte von ungefähr 1121 Objekten empfangen.

01/12 10:43:40 [iNFO] Replikation von CN=Schema,CN=Configuration,DC=xxx,DC=local: 1373 Objekte von ungefähr 1373 Objekten empfangen.

01/12 10:43:40 [iNFO] Der Schemacontainer wurde repliziert.

01/12 10:43:40 [iNFO] Active Directory hat den Schemacache aktualisiert.

01/12 10:43:40 [iNFO] Die Konfigurationsverzeichnispartition wird repliziert.

01/12 10:43:42 [iNFO] Replikation von CN=Configuration,DC=xxx,DC=local: 999 Objekte von ungefähr 3337 Objekten empfangen.

01/12 10:43:43 [iNFO] Replikation von CN=Configuration,DC=xxx,DC=local: 1544 Objekte von ungefähr 3337 Objekten empfangen.

01/12 10:43:43 [iNFO] Der Konfigurationscontainer wurde repliziert.

01/12 10:43:43 [iNFO] Wichtige Domäneninformationen werden repliziert.

01/12 10:43:44 [iNFO] Replikation von DC=xxx,DC=local: 93 Objekte von ungefähr 149 Objekten empfangen.

01/12 10:43:44 [iNFO] Die wichtigen Objekte im Domänencontainer wurden repliziert.

01/12 10:43:44 [iNFO] Error - Bei der Installation von Active Directory ist ein unbekannter Fehler

aufgetreten. (8200)

01/12 10:43:44 [iNFO] NtdsInstall for xxx.local returned 8200

01/12 10:43:44 [iNFO] DsRolepInstallDs returned 8200

01/12 10:43:44 [ERROR] Failed to install to Directory Service (8200)

01/12 10:43:48 [iNFO] Der Dienst NETLOGON wird gestartet. 01/12 10:43:48 [iNFO] Configuring service NETLOGON to 2 returned 0

01/12 10:43:48 [iNFO] Der Domänencontrollervorgang wurde abgeschlossen. 01/12 10:43:48 [iNFO] DsRolepSetOperationDone returned 0

 

In der Ereignisanzeige (Verzeichnisdienst) finden sich folgende zwei Fehler:

 

NTDS Database

Ereigniskennung: 1168

Interner Fehler: Active Directory Fehler aufgetreten.

Zusätzliche Daten

Fehlerwert (dezimal):

8333

Fehlerwert (hexadezimal):

208d

Interne Kennung:

2020eae

 

NTDS General

Ereigniskennung: 1168

Interner Fehler: Active Directory Fehler aufgetreten.

Zusätzliche Daten

Fehlerwert (dezimal):

5

Fehlerwert (hexadezimal):

5

Interne Kennung:

3000e72

 

Für Hinweis wäre ich sehr dankbar.

Share this post


Link to post

Huhu,

 

[ERROR] Failed to install to Directory Service (8200)

 

zu diesem String finden sich bei Google nahezu nur hits zu domaenen mit 2003er und 2000er servern.

 

zur eventid 1168 finden sich bei Troubleshooting Microsoft Windows Event Logs massig tips, die meisten scheinen richtung korrupter/ nicht ausreichender Speicher oder verwaiste objekte im AD zu gehen.

 

Da ich aus spass an der freude hier bin einfach nur die frage ob die Domäne mal eine 2000er Domäne war die nach 2003 migriert wurde?

Share this post


Link to post

Danke für die Antworten!

 

@dmetzger: Komprimierung ist nicht aktiviert.

@Jim di Griz: Das ist mir bei meiner stundenlangen Suche auch aufgefallen. Es handelt sich um eine frisch aufgesetzte 2003er-Domäne, sprich es wurde nicht migriert.

Share this post


Link to post

Versuchst Du den zweiten DC direkt am neuen Standort heraufzustufen, gibt es Firewalls zwischen diesen Standorten, gibt es möglicherweise relevante Logs auf diesen Firewalls?

 

Hast Du auch bereits versucht, den neuen DC am Standort des bestehenden heraufzustufen?

Share this post


Link to post
Danke für die Antworten!

 

@dmetzger: Komprimierung ist nicht aktiviert.

@Jim di Griz: Das ist mir bei meiner stundenlangen Suche auch aufgefallen. Es handelt sich um eine frisch aufgesetzte 2003er-Domäne, sprich es wurde nicht migriert.

 

hm, brachte das abarbeiten der hinweise auf eventid.net keinerlei neue erkenntnisse?

Share this post


Link to post

@dmetzger: Ich habe im Firewall-Log keine Einträge zu dem Zeitpunkt. Leider ist der Vorschlag nicht mehr zu realisieren, da der Server schon im dortigen Netz als Fileserver integriert ist.

@Jim di Griz: Dieser Eintrag scheint ähnlich zu klingen, ich habe aber leider Account:

Anonymous

In my case, this event occurred while trying to add a new domain controller. I had two errors: -1073741823(c0000001) and 183(b7). Article M232070 helped me solve the problem.

Click if the comment is good! x 2

 

Danke und Gruß

Share this post


Link to post

Hallo,

 

du kannst in der MS KB von Hand nach den angegebenen artikelnummern suchen,

am besten nur nach den Zahlen. (wenn es M321456 ist nach 321456 suchen)

Edited by Jim di Griz
schreibfehler

Share this post


Link to post

naja werd mir eh wieder Schellen einholen aber:

 

"Es wurde ein zusätzlichen AD-Standort in "Active Directory Standorte und Dienste" einrichtet

Es wurde ein Subnetz anlegt und mit diesem Standort verknüpfen

Es wurde eine 'Reverse Lookup Zone' für den neuen Standort bzw. das Subnetz im DNS einrichtet"

 

wurde das sitelinkobjekt ueberprüft?

ab und an werden hier automatisch neue objekte erstellt (sitelinks)

eher unwahrscheinlich das es hier hakt weil der Rechner recht weit zu kommen scheint aber es kostet nur ein paar Klicks.

Aber das wars auch von mir, evtl. noch nach packetloss schauen auf der Verbindung.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...