Jump to content
Sign in to follow this  
jussi

Catalyst migration 3550 > 6500

Recommended Posts

hallo,

 

bei der migration vom C3550er (kleiner layer3) switch auf 6500 (modularer layer3) habe ich einige Probleme.

 

netzwerk sieht so aus:

 

3550 ist der core switch/router an den 12 Gbit ifs liegen jeweils auf getrennte ip nummernkreise. der 3550 routet dann zwischen den netzen.

 

entscheidende konfig exemplarisch

---------------------------------------------------

[...]

 

interface GigabitEthernet0/1

description trallala

switchport access vlan X

no ip address

no cdp enable

 

[...]

 

interface Vlan X

description <egal X>

ip address x.y.a.b 255.255.0.0

ip helper-address <egal>

ip helper-address <egal>

 

-----------------------------------

 

Die Ports auf dem 3550 waren knapp, daher sind dann ein Abteilungsswitch hinter den nächtsen gebastelt. Das funktioniert ist aber natürlich extrem ausfallkritisch, wenn der erste in der Kette ausfällt sind alle dahinter down.

Aus diesem Grund wurde ein modularer 6500 beschafft, An diesen sollen nun wieder zum echten Stern die vorher nachgelagerten Switche in eigene Anschlüsse angeschlossen werden. Wenn ich die Konfig nun so übertrage:

 

-----------------------------

[...]

 

gi 1/1

switchport

switchport mode access vlan 20

no ip adress

 

[...]

 

gi 3/7

switchport

switchport mode access vlan 20

no ip adress

 

[...]

interface Vlan 20

description <egal 20>

ip address x.y.a.b 255.255.0.0

 

--------------------------------------------

 

das funktioniert nicht, im cdp kann ich die nachbarn sehen aber im 'sh vlan brief' werden regelmässig angeschlossene ports der betreffenden vlans nicht angezeigt. im oben gewählten beispiel wäre also im vlan 20 nur einer der beiden ports und auf ip kann ich auch nur einen strang erreichen. was mache ich falsch?

 

ausserdem weigert sich der 6500er diese gbics zu fressen welche wieder auf kupfer umsetzen (habe zwei uralte ipx router an dem 3530, der mit 2x kupfer kommt). kann ich da konfigseitig irgendwas dran machen?

 

danke im voraus

Share this post


Link to post

hallo,

 

danke für deine antwort.

 

ich habe erst mal so übernommen weil ich möglichst 1zu 1 übernehmen wollte. aber ich hgebe dir recht, dass das mit dem 6500er besser geht.

 

schlägst du vor dann mit dot1q zu taggen? die nachgelagerten abteilungsswitche können aber im default vlan bleiben oder? muss dann jeder der ports auf dem 6500er im gleichen vlan eine eigene ip bekommen?

 

noch ne spezialfrage auf dem abgelösten 3550er gabs eine brigde-group (für alte ipx ********) kann ich das irgendwie im 6500er abbilden?

Share this post


Link to post

Du gibst auf dem 6500er "no switchport" ein, da gibts dann nix mehr mit VLANs :)

Solang du die VLANs nicht ueber Switchgrenzen hinweg betreibst, voll ok.

 

IPX? Ist das dein ernst? :confused:

Share this post


Link to post

ich will aber vlans haben, es ist ein weitverzweigtes netz mit hunderten ips in verschiedenen nummernkreisen angeschlossen an hintereinandergekettete switche, diese ketten will ich auflösen und dann zum beispiel port x, y und z mit dem einen vlan belegen und port a,b und c mit dem anderen die clients bekommen alle als gw das bein des 6500er im jeweiligen vlan,

 

wenn ich deinen vorschlag mache und die switchports auflöse und nur vlan ifs für die ips konfiguriere liegen doch alle teilnehmer in einer bc domain, oder nicht?

 

 

oder meinst du doch sowas hier:

 

interface gi 1/3

description <whatever>

encapsulation dot1Q 25

ip address 1.2.3.4 x.y.0.0

 

dann muss ich doch alle übrigen ports die auch im vlan 25 liegen sollen mit anderen ips belegen, oder nicht?

 

wahrscheinlich habe ich gerade ne denkblockade weil ich vom layer 3 switch auf so nen fetten edel router umsteigen will

Share this post


Link to post

Hi,

 

so ganz habe ich nicht verstanden - was du da baust. Du hast den 6500er als Core - und hast da dann x Switche (per Stern) dran - jeder Switch hat ein eigenes VLAN zur Zeit ?

 

Dann kannst du das mit Routet Ports machen - da hast du dann auch pro Netz nen Broadcast Domain - das Default GW ist immer der zugehörige Port im 6500er.

Share this post


Link to post

hi black,

 

soweit richtig wie du es dir vorstellst ausser das bei einigen "abteilungen" eben x pL2 switche an ebensovielen ports des 6500ers hängen sollen. soweit ich weiss kann ich das nur machen wenn ich die betreffenden ports in ein vlan hänge.

 

ich gleube ein ip interface kreieren und da dann die switchports reinhängen ist genau der richtige weg, aber ich denke ich habe know-how probleme bei der konfig von PVST und MST, denn warum sollte der 6500er sonst port abschalten sobald ich was reinstecke (port ist up connected, aber im sh vlan brief taucht er nicht mehr auf)

Share this post


Link to post

das hört sich sehr danach an, das auf dem Port ein "VLAN-Trunk" ist - dann trauchen die da nicht mehr auf - da es ja kein VLAN zugeordnet ist.

Share this post


Link to post

black, hier mal ein beispiel eines problemports, ohne kabel drin auf dem 6500

 

Switchport: Enabled

Administrative Mode: dynamic desirable

Operational Mode: down

Administrative Trunking Encapsulation: negotiate

Negotiation of Trunking: On

Access Mode VLAN: 27 (VLAN0027)

Trunking Native Mode VLAN: 1 (default)

Administrative Native VLAN tagging: enabled

Operational Native VLAN tagging: disabled

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

 

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Share this post


Link to post

Hi,

 

unter dem Port solltest du noch switchport mode access setzten

[ebenfalls switchport nonegotiate]

 

Wie sieht die Config der BG für IPX auf dem 3550 aus?

==> sollte via fallback bridging realisierbar sein. denke ich :-)

 

ciao

Edited by daking

Share this post


Link to post

@daking

 

danke für deine tips, das werde ich ausprobieren. ich habe das "trocken" konfiguriert, umstekcne kann ich erst wieder zum vereinbarten termin, mal sehen ob es die wende bringt.

 

und das funktioniert auch wenn ich das mit mehren switchports im selben access vlan mache? also gi 1/1 und gi 1/3 und 3/7 sind dann alle

 

switchport

switchport mode access

switchpoirt nonnegotiate

switchport access vlan XY

 

die bridge group config muss ich nachreichen, da ich gerade keinen zugriff auf das gerät habe. ich arbeite aber schon daran diesen zopf einfach abzuschneiden. evtl ist das also kein killerkriterium mehr für die migration dennoch wär eich erfreut was in dieser hinsicht zu lernen.

 

@black,

 

solange keine kabel in den optiken sind, ist natürlich alles gut, und in der "sh vlan brief" übersicht alles sichbar, sobald ich kabel einstecke werden einzelne ports aus verschiedenen vlans im 6500er deaktiviert und es fließt null traffic.

 

es ist eine historisch gewachsene umgebung. es exitieren alte 3508er und 2950er und neuere 2960/70er. wenn nich die anfangs beschriebenen ketten auflöse und alle mit dem neuen core switch verbinde, gehen "die alten" scheinbar sofort, "die neuen" eben nicht. ich habe inzwischen verstanden, dass es ein trunking problem ist und dass der 6500er schlauer ist als der alte core 3550er und deshalb ports mit groben unfug einfach abschaltet.

 

ports die nach dem verbinden auftauchen haben gegenüber immer alte switche die scheinbar einen default in den switchports haben haben: "Trunking VLANs Enabled: NONE" und da wo ports abgeschaltet werden hat es neuere switche mit der einstellung "Trunking VLANs Enabled: ALL"

 

dies kann ich aber scheinbar nicht erzwingen (zumindest trocken auch nicht mit den befehlen von daking)

 

da der 3550 aber mit dieser heterogenen umgebung null probleme hatte, muss das imho auch auf dem 6500er irgendwie gehen,

 

Danke für eure Zeit!

Share this post


Link to post

Hi,

 

zwischen den VLANs kannst du wie gesagt den IPX Traffic via Fallback Bridging weiterleiten:

 

bridge 1 protocol vlan-bridge

!

int vlan 10

ip add x.x.x.x

bridge-group 1

!

int vlan 20

ip add x.x.x.x

bridge-group 1

!

6k#sh bridge 1

 

Total of 300 station blocks, 298 free

Codes: P - permanent, S - self

 

Bridge Group 1:

 

Address Action Interface Age RX count TX count

ca01.0b58.001c forward Vlan20 0 1 0

ca00.0b58.001c forward Vlan10 0 1 0

-------------

1#ping ipx

Target IPX address: AA.ca01.0b58.001c

Repeat count [5]: 1000000000

Datagram size [100]:

Timeout in seconds [2]:

Verbose [n]:

Type escape sequence to abort.

Sending 1000000000, 100-byte IPX Novell Echoes to AA.ca01.0b58.001c, timeout is 2 seconds:

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!...................... --> Bridge raus

............!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! --> Bridge rein

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.

Success rate is 89 percent (305/340), round-trip min/avg/max = 12/38/-1 ms

 

Das ist also technisch möglich. Aber Vorsicht: der Traffic wird im Software Pfad weitergeleitet. Wenn es sich hier um sehr sehr viel Traffic handelt könnte das eher suboptimal sein. Um wie viele IPX Clients handelt es sich?

 

cheers

 

//

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...