Jump to content
Sign in to follow this  
flooo

nslookup liefert localhost bei unbekannten IP Adressen zurück

Recommended Posts

Hallo,

 

normalerweise würde man ja "Unknown" als Antwort auf eine Abfrage nach einer unbekannten IP Adresse (z.B. nicht vergebene IP) vom DNS Server erhalten, wenn diese nicht als Eintrag gefunden wird. Wir erhalten seit kurzem immer "localhost" (getestet von verschiedenen Rechnern) zurück. Hat jemand eine Idee woran das liegen könnte?

Share this post


Link to post

Hier die Konfiguration. Es handelt sich aber nicht um das Problem eines einzelnen Rechners, von Windows und Linux besteht zum Beispiel das gleiche Problem und es trat erst seit dem 3. Dezember auf.

 

Wenn ich NSLOOKUP auf eine unbekannte bzw nicht vergebene IP in einem bekannten IP Bereich mache, dann bekomme ich die entsprechende Antwort zurück, also "Unknown". Wenn ich jedoch eine IP aus einem undefinierten lokalen (z.B. 192.168.191.123) Addressbereich benutze, bekomme ich als Antwort "localhost".

 

Windows IP Configuration

 

Host Name . . . . . . . . . . . . : <Rechnername>

Primary Dns Suffix . . . . . . . : domain.eu

Node Type . . . . . . . . . . . . : Hybrid

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No

DNS Suffix Search List. . . . . . : domain.eu

trusteddomain.ad.local

ad.local

anothertrusteddomain.com

 

Ethernet adapter Local Area Connection:

 

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Controller

Physical Address. . . . . . . . . : <Mac Adresse>

DHCP Enabled. . . . . . . . . . . : No

Autoconfiguration Enabled . . . . : Yes

IPv4 Address. . . . . . . . . . . : 10.51.64.250(Preferred)

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 10.51.64.98

 

DNS Servers . . . . . . . . . . . : 10.51.64.2

10.51.64.25

NetBIOS over Tcpip. . . . . . . . : Enabled

Share this post


Link to post

Ist die 192.168.x.x der Bereich, den Du immer probiert hast ? Hast Du es auch schon mal mit einer unbekannten Adresse aus dem 10er Bereich versucht ?

Was für ein DNS-Server ist das eigentlich (der interne) ?

Share this post


Link to post

Hallo,

 

wenn ich wirklich eine nicht vergebene IP aus einem Bereich anpinge, in dem auch Geräte vorhanden sind, d.h. ein Bereich der auch genutzt wird, bekomme ich die Antwort "Unbekannt" zurück. Nehme ich z.B. 192.168.29.x oder 10.51.49.x (beide werden nicht genutzt, d.h. sind auch nirgends definiert), bekomme ich "Localhost" zurück.

Alle DNS Server sind Active Directory 2003 Domain Controller.

Share this post


Link to post

Mit "Bereich" meinst Du, dass für diesen IP-Kreis auch eine Reverse Lookup Zone existiert ?

Poste bitte mal die Ausgabe des NSLOOKUP-Aufrufes, der erfolgreich ist und der nicht erfolgreich ist ...

Share this post


Link to post
C:\Users\<Benutzername>>nslookup 192.168.15.45

Server: <domaincontroller>.<domain>.eu

Address: 10.51.64.2

 

*** <domaincontroller>.<domain>.eu can't find 192.168.15.45: Non-existent domain

 

Für diesen Bereich bekomme ich auch die erwartete Antwort, eine Reverse-Lookup-Zone existiert.

 

C:\Users\<Benutzername>>nslookup 192.168.16.45

Server: <domaincontroller>.<domain>.eu

Address: 10.51.64.2

 

Name: localhost

Address: 192.168.16.45

 

Für diesen Bereich bekomme ich "localhost" zurück, es existiert im DNS KEINE Reverse-Lookup-Zone.

Share this post


Link to post

Wenn eine Abfrage für einen Eintrag angefordert wird, für den der Server nicht autoritativ ist, leitet er weiter. Welche Weiterleitungen sind eingetragen ?

Share this post


Link to post

Hallo,

 

weitergeleitet wird an unseren ISA Server, der wiederum als Weiterleitungen die DNS Server unseres Providers eingetragen hat.

Share this post


Link to post

Hm, ich probiere das hier an x-verschiedenen Servern aus und kann das Verhalten nicht reproduzieren. Setze bitte die Weiterleitung mal auf ein nicht existentes Ziel und deaktiviere die Root-Auflösung (Haken "Keine Rekursion" in der Weiterleitung). Ändert sich das Verhalten ?

Share this post


Link to post

Hi,

 

danke erstmal für deine Antworten und deine Bemühungen! Wenn ich die Einstellung setze, ändert sich in der Tat etwas. Erst kommt diese Antwort:

 

C:\Users\<Benutzername>>nslookup 192.168.19.23

Server: <domaincontroller>.<domain>.eu

Address: 10.51.64.2

 

*** <domaincontroller>.<domain>.eu can't find 192.168.19.23: Server failed

 

Und dann nach nochmal probieren (eine Minute später):

 

C:\Users\<Benutzername>>nslookup 192.168.19.23

Server: <domaincontroller>.<domain>.eu

Address: 10.51.64.2

 

(root) nameserver = l.root-servers.net

(root) nameserver = k.root-servers.net

(root) nameserver = g.root-servers.net

(root) nameserver = a.root-servers.net

(root) nameserver = e.root-servers.net

(root) nameserver = m.root-servers.net

(root) nameserver = i.root-servers.net

(root) nameserver = d.root-servers.net

(root) nameserver = h.root-servers.net

(root) nameserver = f.root-servers.net

(root) nameserver = b.root-servers.net

(root) nameserver = j.root-servers.net

(root) nameserver = c.root-servers.net

a.root-servers.net internet address = 198.41.0.4

b.root-servers.net internet address = 192.228.79.201

*** No internal type for both IPv4 and IPv6 Addresses (A+AAAA) records available

for 192.168.19.23

 

Wenn ich den Haken dann wieder setze, erscheint wieder das alte Bild:

 

C:\Users\<Benutzername>>nslookup 192.168.19.23

Server: <domaincontroller>.<domain>.eu

Address: 10.51.64.2

 

Name: localhost

Address: 192.168.19.23

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...