Jump to content
Sign in to follow this  
loadme

FTP über DynDNS

Recommended Posts

Hallo Zusammen,

 

ich versuche zur Zeit einen eigenen Server via FTP zu erreichen.

Dieser Server hängt jedoch an einer Fritzbox im Netzwerk und diese wiederrum nutzt den DynDNS.com - Free Domain Name, Managed DNS, Email Services Service.

 

im Konto von Dyndns.org wurde "Webserver" aktiviert (ich vermute, dass dann Port 21 forwarded wird?)

 

Nun zum Server:

Das FTP Feature wurde via Konsole komplett aktiviert:

C:\Users\Administrator>dism /Online /Enable-Feature /FeatureName:IIS-FTPServer /FeatureName:IIS-FTPSvc /FeatureName:IIS-FTPExtensibility

 

Autostart für den FTP Service ist auch aktiv.

 

Eine FTP Seite habe ich auch erstellt (IIS Manager -> Sites -> Rechtsklick-> Add FTP Site

 

 

 

Hier kommts dann schon zum Stirnrunzeln.

Wie lautet in diesem Falle die korrekte Bindung der Seite?

ist es die DynDNS Seite?

xyz.dyndns.org:21 ?

 

in der Fritz.Box hab ich nun noch den Port eingetragen und lass ihn an den Server weiterleiten.

 

 

Mein FTP Programm findet jedoch keine Verbindung.

Habt ihr da eventuell eine Idee? Leider gibts vom aktuellen Provider keine Möglichkeit auf eine Standleitung. Damit kommen wir um dyndns momentan nicht herum.

 

 

Bin dankbar für jeden Tip!

 

Gruß,

loadme

 

edit: auch über die aktuelle IP der Fritzbox bekomme ich keine Verbindung via FTP

Wie muss die Bindung lauten?

IP:21?

habe ich irgendwas übersehen?

 

Gruß

Share this post


Link to post

1. Klappt der Zugriff vom LAN aus?

2. Ist das Portforwarding korrekt? Eventuell musst du zusätzlich noch den Passivportrange auf den Server weiterleiten.

3. Stimmt die externe IP bei Dyndns mit der wirklichen überein?

4. Ich musst bei Dyndns noch nie etwas bezüglich Webserver einrichten.

5. Was meldet dein FTP-Client für einen Fehler? Falls der "Client" der IE ist, verwende Filezilla zum testen.

Share this post


Link to post
1. Klappt der Zugriff vom LAN aus?

2. Ist das Portforwarding korrekt? Eventuell musst du zusätzlich noch den Passivportrange auf den Server weiterleiten.

3. Stimmt die externe IP bei Dyndns mit der wirklichen überein?

4. Ich musst bei Dyndns noch nie etwas bezüglich Webserver einrichten.

5. Was meldet dein FTP-Client für einen Fehler? Falls der "Client" der IE ist, verwende Filezilla zum testen.

 

Hallo,

 

 

1. ich erreiche den Server via RemoteDesktop von außerhalb (Fritzbox: RemDesktop Port an Server weitergeleitet)

 

2. ich hoffe. In der Fritzbox wird via TCP Port 21 weitergeleitet an den Server (an 21)

Innerhalb des Netzwerks wird der Server ebenfalls gefunden und verwendet

Nun habe ich noch die passiveports zum Server forwarded (49152-65535)

 

3. Ja, funktioniert via automatischem Update bei reconnect der Fritzbox. Filezilla bestätigt das dann bei der Adress-Aufschlüsselung der dyndns Adresse

 

4. man kann sich bei Dyndns einloggen und dort ein paar Optionen aktivieren. Der "Webserver Service" ist meiner Meinung nach bereits aktiv gewesen.

 

5. ich verwende ausschließlich Filezilla. FileZilla meldet:

Auflösen der IP-Adresse für xyz.dyndns.org

Verbinde mit 91.43.xxx.xxx:21...

Fehler:Zeitüberschreitung der Verbindung

Fehler:Herstellen der Verbindung zum Server fehlgeschlagen

 

 

 

 

 

Eigentlich möchte ich den passiveMode garnicht gestatten?

Auch habe ich den sog. Datenport (20?) nicht weitergeleitet. Ist das denn notwendig? Ich dachte innerhalb der F.B. reicht die Nummer 21 an den Server@21

und soweit ich das verstehe muss man bei einem passiveFTP auch eine feste IP einstellen, da hier eine dynamische nicht akzeptiert wird. (was wohl aber via script gehen würde)

 

 

ich bleibe ratlos :[

Share this post


Link to post

Ich habe jeweils den Dataport (20) auch weitergeleitet und den Passivmode aktiviert. So wie ich das verstanden habe, ist der Passivmode nötig wenn sowohl der Server als auch der Client-PC hinter einem NAT-Router sind. Ich habe dabei aber jeweils den Bereich eingeschränkt, z.B auf die Ports 10000 - 10020 und dann nur diese weitergeleitet. Du hast ja jetzt einen riesigen Bereich weitergeleitet.

Share this post


Link to post

hm, habe ich das vielleicht an der falschen Stelle konfiguriert?

Wo genau hast du denn den PassiveMode aktiviert?

 

 

IIS Manager

ServerName -> FTP Firewall Unterstützung

 

DatenKanal Portbereich: 1000-10020

 

 

dann noch im IIS Manager

klick auf FTP SeitenName

-> FTP Firewall Unterstützung: Ports werden vererbt

aber ich muss noch die externe IP der FW einstellen.

ist das hier nicht die IP der Fritzbox?

oder bleibt es bei der lokalen ServerIP (192.168.. ) weil es ja die BuiltIn Firewall nutzt (vom OS)

 

 

Gruß!

Share this post


Link to post

nachtrag:

 

 

LICHT IM DUNKELN

 

ich habe soeben endlich die richtige Firewall Regel eingebaut

netsh advfirewall firewall add rule name="FTP (non-SSL)" action=allow protocol=TCP dir=in localport=21

sowie

netsh advfirewall set global StatefulFtp enable

 

 

nun wirft mir FileZilla so einiges um die Ohren und scheitert schlussendlich beim Verzeichnisinhalt.

Status: Verbindung hergestellt, warte auf Willkommensnachricht...

Antwort: 220 Microsoft FTP Service

Befehl: USER anonymous

Antwort: 331 Anonymous access allowed, send identity (e-mail name) as password.

Befehl: PASS **************

Antwort: 230 User logged in.

Befehl: SYST

Antwort: 215 Windows_NT

Befehl: FEAT

Antwort: 211-Extended features supported:

Antwort: LANG EN*

Antwort: UTF8

Antwort: AUTH TLS;TLS-C;SSL;TLS-P;

Antwort: PBSZ

Antwort: PROT C;P;

Antwort: CCC

Antwort: HOST

Antwort: SIZE

Antwort: MDTM

Antwort: REST STREAM

Antwort: 211 END

Befehl: OPTS UTF8 ON

Antwort: 200 OPTS UTF8 command successful - UTF8 encoding now ON.

Status: Verbunden

Status: Empfange Verzeichnisinhalt...

Befehl: PWD

Antwort: 257 "/" is current directory.

Befehl: TYPE I

Antwort: 200 Type set to I.

Befehl: PASV

Antwort: 227 Entering Passive Mode (xx,xx,xx,xx,216,144).

Befehl: LIST

Antwort: 150 Opening BINARY mode data connection.

Fehler: Zeitüberschreitung der Verbindung

Fehler: Verzeichnisinhalt konnte nicht empfangen werden

 

(ich habe bei "entering passive mode" die werte der IP Adresse durch xx ersetzt)

LIST wird nicht richtig ausgeführt.

Leider bin ich hier nun am Ende meines Latein

 

 

Gruß

Share this post


Link to post

Nochmal Kommando zurück

 

ich habe die gleiche Verbindung in FileZilla mal im "aktiv" Mode versucht und schon wurde ich nach einer Firewallregel gefragt (Clientseitig).

Diese kurz bestätigt und schon funktionierte es.

 

 

Könnte mir eventuell noch jmd kurz eine Erklärung geben, warum es nun im aktiv und nicht im passiv Modus funktioniert?

 

Und was google bisher nicht ausspucken wollte:

einen Anhaltspunkt, wie man innerhalb einer FTP Seite serverseitig noch berechtigungen für die einzelnen Verzeichnisse erstellt.

Löse ich das über die Verzeichnisse direkt? Oder über den IIS Manager?

 

Gruß! :)

Share this post


Link to post

- Was hast du im FTP-Server als externe IP eingetragen? Da sich diese immer ändert musst du dort deine Dyndns-Adresse eintragen.

 

- Stimmt die unter "Antwort: 227 Entering Passive Mode (xx,xx,xx,xx,216,144)" angezeigte IP mit der externen IP des Servers überein?

 

- Versuchst du von intern auf die externe IP zu verbinden? Dies wird von einigen Routern geblockt (Loopback oder so ähnlich).

Share this post


Link to post
- Was hast du im FTP-Server als externe IP eingetragen? Da sich diese immer ändert musst du dort deine Dyndns-Adresse eintragen.

Ich wollte dort die dyndns eintragen. Leider gab es die Meldung, dass das nicht möglich sei und man eine echte IP eintragen solle.

Darauf hin nutzte ich die aktuelle IP der Fritzbox - mit Erfolg.

Später habe ich diese Feld wieder >gelöscht< und es funktionierte trotzdem.

Scheinbar ist das Feld in diesem Falle nicht relevant.

 

 

- Stimmt die unter "Antwort: 227 Entering Passive Mode (xx,xx,xx,xx,216,144)" angezeigte IP mit der externen IP des Servers überein?

- ja! die IP wurde von dyndns richtig aufgeschlüsselt.

 

 

- Versuchst du von intern auf die externe IP zu verbinden? Dies wird von einigen Routern geblockt (Loopback oder so ähnlich).

Nein. Es kann in seltenen Fällen vorkommen, dass zbsp ein mobiles Gerät, das normalerweise von außerhalb zugreift, sich auch mal im gleichen Netzwerk aufhält.

Hier muss ich noch testen, ob es sich dann via Internet postwendend über dyndns wieder zurück zur Fritzbox und weiter zum Server verbinden kann.

 

 

 

 

 

Nun habe ich alles fertig eingerichtet und es funktioniert.

 

Ich bin noch nicht ganz sicher, ob meine Konfiguration dem System nicht irgendeine Sicherheitslücke eingebrockt hat und habe ein wenig Bedenken bei den ganzen Konfigurationen.

 

Die FTP Seite läuft momentan über ein reines FTP Protokoll.

FTPs werde ich noch testen.

 

Auch habe ich anonyme User und anonyme zugriffe geblockt und die Seite nur noch zugänglich gemacht für bekannte Benutzer und deren Passwort.

 

 

 

Falls jemand von euch noch einen Tip hat, eine Checkliste oder irgendeinen "SicherheitsGuide" mit dem ich Stück für Stück mal das System auf grundlegende Sicherheitslücken prüfen könnte (sofern es soetwas überhaupt gibt), dann würde ich mich sehr darüber freuen.

 

 

 

 

schon mal vielen Dank fürs Mitdenken!

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...