Jump to content
Sign in to follow this  
steyze

statische Routen werden "vergessen"

Recommended Posts

Hi!

 

Ich habe folgendes Problem:

Windows merkt sich nicht die genaue Konfiguration der permanenten Routen!

 

 

 

Wir haben ein W2K-System in einem PC-Labor stehen.

Da kommen wir nur über unser LAN via VPN rein.

Das System soll zusätzlich über einen VPN-Router mit ISDN-Wählleitung auf ein externes Netzwerk konnektieren.

 

Soviel nur zur Rahmengeschichte.

 

 

 

Wir haben zwei NIC's eingebaut. Beide im selben Subnet. Ein Standardgateway ist für das interne Netz konfiguriert.

 

#1: 192.168.21.104 (extern -> VPN-Router)

 

#2: 192.168.21.105, GW 192.168.21.254 (intern -> LAN-Gateway)

 

 

NIC #1 ist direkt via Cat5 an dem VPN-Router angeschlossen.

Um nun alle Anfragen an das externe Netz weiterzuleiten (W2K kann ja leider nur ein GW benutzen) haben wir eine statische Route dorthin über NIC #1 (route -p ...) erstellt.

 

Das dumme ist nur, dass diese Route nach einem Neustart des Systems aufs falsches Interface zeigt, obwohl bei der Erstellung expliziet die #1 angegeben wurde.

Anscheinend sucht sich W2K das NIC des GW aus. (laut W2K-Doku aber nur wenn kein Interface bei der Erstellung angegeben wird!)

 

W2K speichert sich diese Angabe, welches Interface genommen werden soll, anscheinend auch gar nicht in dem dafür vorgesehen Registry-Schlüssel.

 

[HKEY_LOCAL_MACHINE]\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\PersistentRoutes

 

 

 

Wir haben jetzt ein Startskript erstellt, das die Route beim Startup löscht und neu anlegt.

 

Ist das die letzte Möglichkeit oder kann man W2K doch noch vermitteln das richtige Interface zu nutzen?

 

 

Gruss, Stefan

 

 

p.s.

Ich hab keine Ahnung, ob dieses Thema hier schonmal diskutiert wurde. Also vergebt mir ein ggf. Doppel-Posting. ;-)

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...