Jump to content
Sign in to follow this  
Bob the Builder

Problem mit der unattended Installation

Recommended Posts

Hallo, ich bin neu hier aber ich hoffe ich finde hier jemanden der mir mit meinem Problem weiterhelfen kann.

Ich versuche im Moment mir eine unattended Installation zu basteln die komplett von CD läuft (ohne Diskette). An sich wäre das nicht weiter schwer, wenn nicht meine Festplatten auf einem Epox 8KRA2+ mit OnBoard Raid Controller hängen würden. Und ich kriege es nicht gebacken die Treiber bei der Installation einzubinden (muss an der Stelle passieren an der normalerweise F6 für die Installation von SCSI/RAID Treiber eines Drittanbieters zu drücken ist). Das sollte ja eigentlich mit dem Eintrag unter [MassStorageDrivers] und [OEMBootFiles] funktionieren. Leider klappt das nicht. kriege immer die Meldung "Fehler in Datei txtsetup.oem unerwarteter Fehler (18) in Zeile 1044 in D:\nt\private\ntos\boot\setup\oemdisk.c"

(In meiner TXTSETUP.OEM gibt es keine Zeile 1044 und den angegebenen Pfad finde ich nirgends)

 

Hier mal meine Winnt.sif:

 

[Data]

AutoPartition=1

MsDosInitiated="0"

UnattendedInstall="Yes"

 

[unattended]

UnattendMode=FullUnattended

TargetPath=\WINNT

Filesystem=ConvertNTFS

ExtendOemPartition=1

Repartition=no

KeyBoardLayout="Deutsch (Deutschland)"

OemPreinstall=Yes

NtUpgrade=No

Win9xUpgrade=No

DriverSigningPolicy = Ignore

OemPNPDriversPath = "WINDOWS\TMP\DRV\Via4in1\Inf;WINDOWS\und noch ein paar Treiber..."

OemSkipEula=Yes

 

[MassStorageDrivers]

"HighPoint HPT3xx ATA RAID Controller (Win2000)" = "OEM"

 

[OEMBootFiles]

hpt3xx.sys

hptpro.sys

hpt3xx.inf

hpt3xx.cat

TXTSETUP.OEM

 

[GuiUnattended]

AdminPassword="*"

EncryptedAdminPassword=NO

AutoLogon=Yes

AutoLogonCount=3

OEMSkipRegional=1

OEMSkipWelcome=1

TimeZone=110

 

[userData]

FullName="."

OrgName="."

ComputerName=*

ProductID="Hier Product ID eingeben"

 

[branding]

BrandIEUsingUnattended=Yes

NoFavorites=1

 

[identification]

JoinWorkgroup=Workgroup

 

 

[Networking]

InstallDefaultComponents=Yes

 

[Components]

autoupdate=off

rootautoupdate=off

msmsgs=off

 

[shell]

DefaultStartPanelOff=Yes

DefaultThemesOff=Yes

 

[NetAdapters]

Adapter1=params.Adapter1

Adapter2=params.Adapter2

 

[NetClients]

MS_MSClient=params.MS_MSClient

 

[NetServices]

MS_SERVER=params.MS_SERVER

 

[NetProtocols]

MS_TCPIP=params.MS_TCPIP

 

*hier etwas gekürzt da Text zu lang.

 

 

Und hier die von mir etwas angepasste TXTSETUP.OEM:

 

#

# TXTSETUP.OEM for HPT3xx UDMA/ATA100 RAID Controller

#

 

[Disks]

d3 = "HPT3xx ATA RAID Controller Driver Diskette", \

 

[Defaults]

scsi = hpt3xx2K

 

[scsi]

hpt3xx2K = "HighPoint HPT3xx ATA RAID Controller (Win2000)", hpt3xx

 

[Files.scsi.hpt3xx2K]

driver = d3, hpt3xx.sys, hpt3xx

driver = d3, hptpro.sys, hpt3xx

inf = d3, hpt3xx.inf, hpt3xx

 

[Config.scsi.hpt3xx2K]

value = "", Tag, REG_DWORD, 1

value = "Parameters\PnpInterface", 5, REG_DWORD, 1

 

[HardwareIds.scsi.hpt3xx2K]

id = "PCI\VEN_1103&DEV_0005","hpt3xx"

id = "PCI\VEN_1103&DEV_0004","hpt3xx"

 

 

Die sieht im Original so aus (denke aber das da vieles dabei ist was überflüssig ist daher die o.g. Kürzung):

#

# TXTSETUP.OEM for HPT3xx UDMA/ATA100 RAID Controller

#

 

[Disks]

d1 = "HPT3xx ATA RAID Controller Driver Diskette", \Disk1, \

d2 = "HPT3xx ATA RAID Controller Driver Diskette", \Disk1, \win_nt

d3 = "HPT3xx ATA RAID Controller Driver Diskette", \Disk1, \win_2000

d4 = "HPT3xx ATA RAID Controller Driver Diskette", \Disk1, \win_xp

 

[Defaults]

scsi = hpt3xx2K

 

[scsi]

hpt3xx2K = "HighPoint HPT3xx ATA RAID Controller (Win2000)", hpt3xx

hpt3xxXP = "HighPoint HPT3xx ATA RAID Controller (WinXP)", hpt3xx

hpt3xxNT = "HighPoint HPT3xx ATA RAID Controller (WinNT 4.0)", hpt3xx

 

[Files.scsi.hpt3xxNT]

driver = d2, hpt3xx.sys, hpt3xx

inf = d2, hpt3xx.inf, hpt3xx

 

[Config.scsi.hpt3xxNT]

value = "", Tag, REG_DWORD, 1

value = "Parameters\PnpInterface", 5, REG_DWORD, 1

 

[Files.scsi.hpt3xx2K]

driver = d3, hpt3xx.sys, hpt3xx

driver = d3, hptpro.sys, hpt3xx

inf = d3, hpt3xx.inf, hpt3xx

 

[Config.scsi.hpt3xx2K]

value = "", Tag, REG_DWORD, 1

value = "Parameters\PnpInterface", 5, REG_DWORD, 1

 

[HardwareIds.scsi.hpt3xx2K]

id = "PCI\VEN_1103&DEV_0005","hpt3xx"

id = "PCI\VEN_1103&DEV_0004","hpt3xx"

 

[Files.scsi.hpt3xxXP]

driver = d4, hpt3xx.sys, hpt3xx

driver = d4, hptpro.sys, hpt3xx

inf = d4, hpt3xx.inf, hpt3xx

 

[Config.scsi.hpt3xxXP]

value = "", Tag, REG_DWORD, 1

value = "Parameters\PnpInterface", 5, REG_DWORD, 1

 

[HardwareIds.scsi.hpt3xxXP]

id = "PCI\VEN_1103&DEV_0005","hpt3xx"

id = "PCI\VEN_1103&DEV_0004","hpt3xx"

 

 

Hat jemand von Euch einen Plan wo ich den Fehler drin habe? Wäre sehr dankbar für Tipps weil ich schön langsam am verzweifeln bin

 

Und sorry für die Länge des Postings, hoffe es kämpft sich trotzdem jemand durch...

 

Viele Grüße,

Bob

Share this post


Link to post

Ich vermute, im Bereich [OEMBootfiles] fehlt der Eintrag des Controllers und die Treiberdateien müssen nicht aufgeführt werden. Hast Du den Eintrag in der vorherigen Sektion mit allen Leerzeichen übernommen?

 

Schau auch mal hier nach. Da geht es zwar um RIS, aber vielleicht hilft es trotzdem.

Share this post


Link to post

Danke für den Tipp, laut Technet müssen zwar die Treiberdateien aufgeführt werden, aber ich werde es mal mit dem Controllereintrag versuchen... und falls es klappt fall ich Dir virtuell um den Hals... :D

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...