Jump to content

Mehere PPPOE-Sessions über eine Leitung


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Empfohlene Beiträge

Ich hab jetzt beispielsweise versucht explizit zu routen:

ip route vrf incoming 0.0.0.0 0.0.0.0 Serial0/0/0:0 permanent
ip route vrf incoming 192.168.1.0 255.255.255.0 10.0.0.1
ip route vrf incoming 192.168.2.0 255.255.255.0 10.1.0.1
ip route vrf phone 0.0.0.0 0.0.0.0 10.2.0.1
ip route vrf lan 0.0.0.0 0.0.0.0 10.2.0.1

Die einzige Route die auch wirklich arbeitet ist die erste, alle anderen werden einfach ignoriert.

 

Auch probiert habe ich

ip vrf incoming
description Incoming Interface for Serial E1
rd 3:3
route-target export 3:3
route-target import 1:1
route-target import 2:2
route-target import 3:3
!
ip vrf lan
description LAN-Instanz
rd 1:1
route-target export 1:1
route-target import 1:1
route-target import 2:2
route-target import 3:3
!
ip vrf phone
description Phone-Instanz
rd 2:2
route-target export 2:2
route-target import 1:1
route-target import 2:2
route-target import 3:3

Auch das führte zu keinem Erfolg.

 

Ebenfalls probiert habe ich den Code-Schnipsel, den du verlinkt hast. Führt auch nicht zum Erfolg.

 

Muss ich vielleicht Inter-VRF-Routing seperat aktivieren?

Link zu diesem Kommentar

Die aktuelle Config:

 

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco_VRF
!
boot-start-marker
boot-end-marker
!
no logging buffered
no aaa new-model
!
resource policy
!
ip cef
!
ip vrf incoming
description Incoming Interface for Serial E1
rd 3:3
!
ip vrf lan
description LAN-Instanz
rd 1:1
!
ip vrf phone
description Phone-Instanz
rd 2:2
!
ip name-server 212.6.108.140
ip name-server vrf incoming 212.6.108.140
ip name-server vrf lan 212.6.108.140
ip name-server vrf phone 212.6.108.140
!
!
!
username sdm privilege 15 password 0 ***
!
!
controller E1 0/0/0
channel-group 0 timeslots 1-31
!
!
!
interface Loopback0
description VRF-Phone
ip vrf forwarding phone
ip address 10.0.0.1 255.255.255.0
!
interface Loopback1
description VRF-LAN
ip vrf forwarding lan
ip address 10.0.0.2 255.255.255.0
!
interface Loopback2
description VRF-Incoming
ip vrf forwarding incoming
ip address 10.0.0.3 255.255.255.0
!
interface FastEthernet0/0
description Phone
ip vrf forwarding phone
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
description LAN
ip vrf forwarding lan
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0:0
description LAN
ip vrf forwarding incoming
ip address negotiated
encapsulation ppp
no fair-queue
ppp pap sent-username *** password 0 ***
!
ip route 192.168.1.0 255.255.255.0 10.0.0.1
ip route 192.168.2.0 255.255.255.0 10.0.0.2
ip route vrf incoming 0.0.0.0 0.0.0.0 Serial0/0/0:0 permanent
ip route vrf incoming 192.168.1.0 255.255.255.0 10.0.0.1
ip route vrf incoming 192.168.2.0 255.255.255.0 10.0.0.2
ip route vrf lan 0.0.0.0 0.0.0.0 10.0.0.3
ip route vrf phone 0.0.0.0 0.0.0.0 10.0.0.3
!
!
no ip http server
no ip http secure-server
!
disable-eadi
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
password ***
login
transport input telnet ssh
!
scheduler allocate 20000 1000
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
end

Link zu diesem Kommentar

Dann hier einmal die Ausgabe von sh ip route.

 

Cisco_VRF#sh ip route vrf incoming

Routing Table: incoming
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

    80.0.0.0/32 is subnetted, 1 subnets
C       80.228.102.4 is directly connected, Serial0/0/0:0
    212.6.119.0/32 is subnetted, 1 subnets
C       212.6.119.208 is directly connected, Serial0/0/0:0
    10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, Loopback2
S    192.168.1.0/24 [1/0] via 10.0.0.1
S    192.168.2.0/24 [1/0] via 10.0.0.2
S*   0.0.0.0/0 is directly connected, Serial0/0/0:0

 

Cisco_VRF#sh ip route vrf lan

Routing Table: lan
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.0.0.3 to network 0.0.0.0

    10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, Loopback1
C    192.168.2.0/24 is directly connected, FastEthernet0/1
S*   0.0.0.0/0 [1/0] via 10.0.0.3

 

Cisco_VRF#sh ip route vrf phone

Routing Table: phone
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.0.0.3 to network 0.0.0.0

    10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 10.0.0.3

 

Leider komme ich immer noch nicht von LAN bzw. Phone hinaus in die weite Welt und auch zwischen den beiden fließen keine Daten.

Link zu diesem Kommentar

Die Anbindung muss unabhängig von der Technologie sein, also DSL, Frame-Relay und was es da so im Felde gibt.

 

Hintergrund des ganzen ist, dass es ein VPN für Telefonie gibt, eines für Daten und zusätzlich eines für Management. Der Zugang zu den beiden VPN wird über PPPoE geregelt. Dabei ist der Router nur über eine einzige Leitung an das Internet angebunden. Alles weitere muss virtuell erfolgen. Bandbreitenmanagement soll über QoS erfolgen.

 

Chef wünscht sich eine Lösung, bei der die beiden Zugänge als VRF Lite realisiert werden, da es sich dabei um vertraulichen Datenverkehr handelt(sowohl Daten als auch Telefonie) muss das strikt von einander abgeschottet werden.

Link zu diesem Kommentar

So, es klappt mit 2 PPPoE-Sessions und zwei getrennten VRF Lites.

 

Falls nochmal jemand so etwas baut, hier die funktionierende Config meines 1841:

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco_VRF
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5 *** 
!
no aaa new-model
!
resource policy
!
ip cef
!
!
!
!
ip vrf lan
description LAN-Instanz
rd 1:1
route-target export 1:1
route-target import 2:2
!
ip vrf phone
description Phone-Instanz
rd 2:2
route-target export 2:2
route-target import 1:1
!
ip name-server 212.6.108.140
ip name-server vrf lan 212.6.108.140
ip name-server vrf lan 217.237.148.33
ip name-server vrf phone 212.6.108.140
!
!
!
username *** privilege 15 password 0 *** 
!
!
controller E1 0/0/0
channel-group 0 timeslots 1-15
channel-group 1 timeslots 16-30
!
!
!
!
!
interface FastEthernet0/0
no shutdown
description Phone
ip vrf forwarding phone
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
no shutdown
description LAN
ip vrf forwarding lan
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/0/0:0
description LAN
ip vrf forwarding lan
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
no fair-queue
ppp pap sent-username ***  password 0 ***
!
interface Serial0/0/0:1
description Phone
ip vrf forwarding phone
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
no fair-queue
ppp pap sent-username *** password 0 ***
!
ip route vrf lan 0.0.0.0 0.0.0.0 Serial0/0/0:0 permanent
ip route vrf phone 0.0.0.0 0.0.0.0 Serial0/0/0:1 permanent
!
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface Serial0/0/0:0 vrf lan overload
ip nat inside source list 1 interface Serial0/0/0:1 vrf phone overload
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
disable-eadi
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
password ***
login
transport input telnet ssh
!
scheduler allocate 20000 1000
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
end

Link zu diesem Kommentar
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Schreibe einen Kommentar

Du kannst jetzt antworten und Dich später registrieren. Falls Du bereits ein Mitglied bist, logge Dich jetzt ein.

Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Only 75 emoji are allowed.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Editor-Fenster leeren

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.

×
×
  • Neu erstellen...