Jump to content
Sign in to follow this  
Whitewater

OWA über ISA und Dyndns

Recommended Posts

Hi ihr alle!

Ich habe hier folgendes Problem:

 

Ich möchte gerne, daß ich auf mein OutlookWebAccess über meine Dyndns-Adresse zugreifen kann.

 

Meine Konfiguration ist die folgende:

 

Router (192.168.1.1)

ISA-Server (extern 192.168.1.2) (intern 192.168.0.2)

Exchange mit OWA (intern 192.168.0.3)

 

Ich möchte nun, daß ich z.B. über folgende URL's Verbindung mit dem OWA aufnehmen kann:

Entweder: irgendwas.dyndns.org/exchange/Benutzername

Oder: owa.irgendwas.dyndns.org

 

Hat irgendwer schonmal eine solche Config hinbekommen?

Freue mich über jede Hilfe! :)

 

Viele Grüße,

Whitewater

Share this post


Link to post

Hallo Whitewater,

irgenwdie fehlt mir bei deiner Config der Internetteil.

Aber allgemein muss deine Internet IP, die dann über

irgendwas.dyndns.org erreichbar ist, an deinem ISA Server ankommen.

Der ISA muss dann ein Portforwarding zur 192.168.0.3 vornehmen.

Und die 192.168.0.3 muss über den ISA ins Internet antworten können.

 

thorgood

Share this post


Link to post

Hallo,

 

Erstmal thx für deine Antwort! :)

 

ich habe vielleicht vergessen zu sagen, daß ich eine Web Site vorher auf dem ISA Server hab laufen lassen. Diese war dann über http://www.irgendwas.net (Strato macht einen Forward auf irgendwas.dyndns.org) erreichbar. (Im ISA-Server durch einen Paketfilter Port 80 "freigegeben")

 

Ich hab auch mal versucht ein Web Publishing (Zielsatz: Alle Ziele)des WebServers auf 192.168.0.3 zu machen, was anscheinend nicht funktioniert, nur, um mal auszuprobieren, ob ich überhaupt irgendeine Web Site auf 192.168.0.3 ansprechen könnte.

Wenn ich dann versuche, die Seite aufzurufen, ruft er immer noch die Web-Seite auf, die auf dem ISA läuft und forwarded nicht an 192.168.0.3.

Irgendeine Idee?

 

 

Viele Grüße,

Whitewater

Share this post


Link to post

Hi Grizzly,

 

jap, was da steht hab ich schon probiert.

Was ich bis jetzt gemacht habe:

 

Ich habe den OWA-Server mit Hilfe des Assistenten veröffentlicht.

Ich habe bei dem Assistenten folgenden Zielsatz eingetragen:

 

http://gold-nuggets.dyndns.org/exchange/'>http://gold-nuggets.dyndns.org/exchange/

 

Diesen Zielsatz hat er auch angelegt:

Name: OutlookWebAccess

Ziele:

gold-nuggets.dyndns.org /exchweb*

gold-nuggets.dyndns.org /public*

gold-nuggets.dyndns.org /exchange*

 

Wars das denn wirklich schon? Denn wenn ich jetzt http://gold-nuggets.dyndns.org/exchange/ von einem Client ausserhalb meines Netzes eingebe meldet er nur "Seite konnte nicht gefunden werden".

 

Viele Grüße,

Whitewater

Share this post


Link to post

Und der Listener für die entsprechende Webveröffentlichung ist auch eingerichtet? Und die Namensauflösung vom Hostheader auf den Exchange passt auch?

 

grizzly999

Share this post


Link to post

Nun, da kommt ein Paket, das im Hostheader an den Rechner gold-nuggets.dyndns.org gerichtet ist. Der ISA muss wissen, das dieses Paket aber an die interne IP-Adresse des Exchange weitergeleitet werden muss.

 

Also sollte der DNS des ISA noch eine primäre Zone "gold-nuggets.dyndns.org" erhalten, wo die ihm die A-Records für public, exchange und exchweb mit der IP-Adresse des internen Exchange-Servers einträgst.

 

grizzly999

Share this post


Link to post

Hm...da hast du Recht. Das werde ich noch machen.

Das komische ist nur, wenn ich ein "einfaches" WebPublishing des WebServers vom OWA-Server mache, er diesen auch nicht findet, bzw. die Pakete nicht weiterleitet. Im Protokoll des ISA zeigt er dann bloß eine blockierte Anfrage am Port 80 an, so als ob er gar nicht merken würde, das eine WebPublishingRule existiert...

Share this post


Link to post

Hey!

Ich habs gerade hinbekommen! Ich hab vergessen, den IIS aufm ISA abzuschalten, bzw. auf nem anderen Port als dem Port 80 laufen zu lassen. Nachdem ich ihn deaktiviert hatte, routet er schön an den internen OWA weiter!

Tausend dank!

 

Whitewater

 

P.S.: Das einzigste Problem, was ich jetzt noch habe, ist, daß ich mich mit meinen Userdaten nicht am OWA anmelden kann, das Login-Fenster geht dann wiederholt auf...hm...

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...