Jump to content
Sign in to follow this  
Shemeneto

Cisco 836 - Cause: Memory fragmentation

Recommended Posts

Hallo zusammen,

 

habe mir einen Cisco Router 836 gekauft und wollte diesen für DSL-Zugang konfigurieren.

Ich konfiguriere zum 1. Mal einen Cisco Router und habe mich, so gut es geht, an die Anleitung auf Cisco Systems, Inc gehalten.

Leider bekomme ich, wenn ich NAT für die Schnittstelle Ethernet0 (ip nat inside) bzw. für Dialer1 (ip nat outside) konfigurieren möcht folgende Fehlermeldung:

 

% NBAR ERROR: parsing stopped
% NBAR Error : Activation failed due to insufficient dynamic memory
% NBAR Error: Stile could not add protocol node
%NAT: Error activating CNBAR on the interface ATM0
colin(config-if)#
*Mar  1 18:38:15.383: %SYS-2-MALLOCFAIL: Memory allocation of 10260 bytes failed                from 0x80495758, alignment 0
Pool: Processor  Free: 18776  Cause: Memory fragmentation
Alternate Pool: None  Free: 0  Cause: No Alternate pool
-Process= "Exec", ipl= 0, pid= 3 -Traceback= 0x802BD2B0

 

Danach musste ich den Router zurücksetzen als ich das ganze in den NVRAM geschrieben und diesen beim Starten des Routers geladen habe (Konfig-Register 2102).

hier die Daten:

 

Cisco IOS Software, C836 Software (C836-K9O3S8Y6-M), Version 12.4(6)T2, RELEASE SOFTWARE (fc1)
ROM: System Bootstrap, Version 12.2(11r)YV3, RELEASE SOFTWARE (fc2)

Memory:
Head                             Total(b)      Used(b)       Free(b)       Lowest(b)   Largest(b)
Processor   825B2D5C    20868772    11787220     9081552     5589844     6502856
         I/O    3999C00     6710272     1301264      5409008     5409008     5408468

 

Current configuration : 1520 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname colin
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxx
enable password xxxxxx
!
no aaa new-model
!
resource policy
!
!
!
!
!
ip cef
no ip domain lookup
vpdn enable
!
!
!
!
!
!
!
!
!
!
interface Ethernet0
ip address 192.168.2.254 255.255.255.0
!
interface Ethernet2
no ip address
shutdown
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn point-to-point-setup
!
interface ATM0
mtu 1492
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode annexb-ur2
pvc 1/32
 pppoe-client dial-pool-number 1
!
!
interface FastEthernet1
speed auto
half-duplex
!
interface FastEthernet2
speed auto
half-duplex
!
interface FastEthernet3
speed auto
half-duplex
!
interface FastEthernet4
speed auto
half-duplex
!
interface Dialer1
mtu 1492
bandwidth 384
ip address negotiated
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap calin
ppp pap sent-username xxxx@t-online.de password 0 xxxxx
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit any
access-list 1 permit 192.168.2.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
password s34WRt9o
login
!
scheduler max-task-time 5000
!
end

colin#

 

Ich verstehe das ganze nicht. Wieso läuft der Speicher voll, wenn ich NAT aktiviere?

Habe zwar gelesen das es einen Bug gibt, der dieses auslöst, aber dort steht auch das würde mit der IOS Version 12.4 behoben.

 

Gruss,

Shemeneto

Share this post


Link to post
Share on other sites

Hi,

 

laut deinem ios ist nbar zwar nicht aktiv, versuch doch trotzdem nochmal, es auszuschalten:

 

no ip nbar protocol-discovery

 

ansonsten solltest du vielleicht ein aktuelleres ios suchen...

 

gruss

 

rob

Share this post


Link to post
Share on other sites

Poste mal ein "sh ver". Vielleicht ist das Featureset vom IOS nicht mit der Groesse des RAMs kompatibel. Gibt naemlich 836er mit 48MB und 64MB RAM.

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...