Jump to content
Sign in to follow this  
mymicha

Restore Exchange 2oo3

Recommended Posts

Hallo Leute.

 

Ich habe ein Problem mit meiner Rücksicherung Exchange 2003. Momentan spiele ich ein paar Szenarien durch, um für einen Ernstfall gewappnet zu sein. Jetzt habe ich versucht ein Backup einer Exchangesicherung (mit NTBACKUP.EXE von Win2003 Server) zurückzuspielen und bekomme eine Fehlermeldung im Ereignisprotokoll.

Nach langem hin und her habe ich herausgefunden, dass der Organisationsname des Exchange identisch sein muss, vom Orginalsystem, welches gesichert wurde.

 

http://support.microsoft.com/default.aspx?scid=kb;en-us;296841

 

Die Bedingung habe ich jetzt erfüllt. Allerdings klappt es immer noch nicht. Er bricht mit der gleichen Meldung ab. Was muss denn auf dem System noch alles gleich sein.

Der Store heißt gleich bei mir, der Postfachspeicher ... steht nämlich alles auf default! Der Servername hat sich nur geändert und auch die Domäne ... ich nehme an, da liegt der Fehler, oder?

Gibt es noch Einstellungen, die man bei NTBACKUP.EXE beachten muss, wenn man einen RESTORE des Exchange fahren möchte?

 

Vielen DANK!

Gruß

Michael.

Share this post


Link to post

Hallo Michael,

 

ich kann dir jetzt zwar leider nicht auf Anhieb eine Lösung präsentieren, aber zumindest kann ich dir einen Link geben, der dir evtl. weiterhilft ;)

Schau dich mal auf http://www.msexchangefaq.de um, da gibt es unzählige Tipps zum Betrieb von Exchange.

Insbesondere steht auf http://www.msexchangefaq.de/admin/backup.htm einiges zum Backup und Restore von Exchange Servern.

 

HTH,

JohnDie

Share this post


Link to post

Erst mal Danke, doch diese Seite(n) habe ich schon durchgekaut ohne Ende. Stehen viele hilfreiche Informationen drinnen, aber es klappt trotzdem irgendwie nicht.

Werde heute auf dem Testsystem die Domäne und den Servernamen ändern, doch ich erwarte mir nicht sonderlich viel. Ich hab so das Gefühl, dass er den Store-Namen nicht auflösen kann. In der Ereignisanzeige steht, dass er den Namen des Stores nicht finden kann bzw. dass in der Sicherung ein anderer Namen angegeben ist. Wäre ich jetzt am PC würde ich klar die genau Meldung einkopieren, doch ich bin unterwegs :(

Im Prinzip steht da: In der Datensicherung steht der Name c8823-232488cca2-2232adda und auf dem System heißt der Store EMSERVER3 (Store) ..... oder so ähnlich.

Ich sorge dafür, dass ich den genauen Wortlaut auftreibe.

 

Gruß

Michael.

Share this post


Link to post

Okay, ich hab mir gerade mal die Eventlog geholt. Also es stehen folgende fehler drinnen:

 

------

 

Vorgang starten

 

------

 

Ende der Wiederherstellung zu 'EMSERVER1\Microsoft Information Store\First Storage Group' 'Fehlgeschlagen'

 

Überprüfen: Off

 

Einzelheiten finden Sie im Sicherungsbericht.

 

------

 

Information Store (2916) Aufruf ErrESECBRestoreGetDestination der Rückruffunktion endete mit Fehler 0xC7FE1F46 Die Datenbank kann nicht durch Wiederherstellung überschrieben werden.

 

------

 

Die wiederherzustellende Datenbank konnte nicht in Microsoft Active Directory gefunden werden.

 

Die auf dem Sicherungsmedium angegebene Speichergruppe lautet c3aaa15d-4489-4b03-9967-5c84754dcb20.

 

Die auf dem Sicherungsmedium angegebene Datenbank lautet Mailbox Store (EMSERVER1), Fehler: 0xc7fe1f46.

 

------

 

Wer mir sachdienliche Hinweise ;-) zu diesen Meldungen geben kann, ist mein persönlicher Held!

 

Noch mal kurz das Szenario:

- Exchange 2003 Restore auf einem neuen Server

- Organisationsname gleich

- Namen der Speichergruppen etc. nicht geändert

- MSExchangeFAQ habe ich bis zum Umfallen gelesen

- Knowlegde Base von MS sagt auch nix dazu

- Michael am Ende ;-(

 

Gruß

Michael

Share this post


Link to post

ich bekomme auch die meldung "Die datenbank kann nicht durch wiederherstellung überschrieben werden". wir spielen hier zu 2. schon ne halbe stunde dran rum und bekommen diese meldung einfach nicht weg.

 

auch den informationsspeicher offline zu stellen und alle dateien im 'mdbdata' verzeichnis zu löschen bringt nichts.

ntbackup schreibt dann 94mb und bricht dann mit o.g. fehler ab.

 

n klein wenig unfair von microsoft... denn gerade die wiederherstellung von backup-daten sollte doch einfach und auf jeden fall funktionieren.

 

bin gespannt auf die lösung...

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...