Jump to content
Sign in to follow this  
pknies

Problem mit "net use" Befehl

Recommended Posts

Ein großes HALLO an ALLE!!

 

Ich hätt da mal ein Problem! :D

 

Problem:

Ich möchte mir an einen Windows 2000 Server (ohne SP) von einem DOS 6.22 Rechner ein NetShare anhängen und bekomme dabei den "Systemfehler 66" "Falscher Typ der Netzwerkressource".

 

Konstellation:

1 x MS-DOS 6.22 Rechner mit Namen "b1" und Freigabe "b1-c" und dem User "KASSE"

 

1 x Windows 2000 Server (ohne SP) mit dem User "KASSE" und installierten Netbui Protokoll (benötigt man ja für DOS)

 

Beide Rechner sind über ein Hub (RJ45) miteinander verbunden.

 

Versuche:

Auf einem Windows 98 ausgeführter Befehl: net use x: \\b1\b1-c

wird "Erfolgreich ausfgeführt".

 

Auf einem Windows 2000 Server ausgeführter Befehl: net use x: \\b1\b1-c endet mit "Systemfehler 66" und "Falscher Typ der Netzwerk Ressource"

 

Wenn ich net use x: \\b2\b1-c ausführe bekomme ich "Netzwerkpfad wurde nicht gefunden" das bedeutet ja das er den Rechner "b1" schon mal findet aber mit der Freigabe nichts anfangen kann. Weiß jeman was der Systemfehler 66 bedeutet????

 

Achso wenn ich einen WINS Server installier bringt das auch keine Besserung.

 

Im vorraus schon mal vielen Dank!!!

Share this post


Link to post

Danke für die Antwort!

 

Ich habe das natürlich gleich ausprobiert! :D

 

Mit dem Ergebnis: Systemfehler 50 "Die Netzwerkanforderung wird nicht unterstützt.

 

Bei dem Win98 Rechner hats mal wieder funktioniert!

 

Bei Windows 2000 Prof gehts bis zum SP3.

 

Bei Winddows 2000 Prof mit SP4 kommt "Systemfehler 58"

"Der Server konnte den angeforderten Vorgang nicht durchführen" ???

 

Wo bekomme ich den eine Übersicht der Systemfehler bei Windows 2000?

 

Laut diesem Artikel müsste es aber funktionieren:

http://support.microsoft.com/default.aspx?scid=kb;en-us;118653

 

Noch ne Idee ??

Share this post


Link to post

Unter http://support.microsoft.com/default.aspx?scid=kb;en-us;163520 gibt es einen Hinweis darauf, daß der Fehler 58 dann vom Client gemeldet wird, falls ein anderer Grund beim Server vorliegt.

 

Deshalb: Dein Server unterstützt doch keine Passwörter, W2KSP4 dürfte jedoch standardmäßig ein möglichst hohes Sicherheitslevel nutzen. Ferner gab es mit den ursprünglichen Lanman-Anmeldungen diverse Möglichkeiten, Informationen über Nutzer, Ablaufdaten von Passwörtern und ähnlichem über anonyme Anmeldungen auszulesen. Microsoft hat deshalb die noch in WinNT standardmäßig vorhandene LM Authentifizierung durch NTLM und NTLM2 ergänzt, ferner gibt es fünf LMCompatibilityLevel, das erste läßt hauptsächlich LM zu, das letzte verweigert alles außer NTLM2.

 

Also wird Dir nichts anderes übrig bleiben als Deinen Rechner 'unsicherer' zu machen, das geht, solange er nicht mit fremden Rechnern im Netzwerk kommuniziert, die diese Lücken ausnutzen könnten.

 

1. Den LMCompatibilityLevel-Wert auf 0 setzen - der ist unter HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa zu finden, steht bei mir (XP) auf 5, alles ab 2 (oder 1) bedeutet, daß das wahrscheinlich von Deinem Server benötigte LM nicht mehr gesendet wird. Bis NT4 SP3 gab es diesen Schlüssel noch gar nicht, nur weil es dann diverse Sicherheitsprobleme damit gab, wurde er eingeführt.

 

2. Explizit eine anonyme Verbindung herstellen, auf daß der 'starke W2K-Client' nicht Passwort-Hashes mitschickt und der schwache Server einen Fehler meldet:

net use \\Rechnername\Freigabe /user:"" ""

 

----------

Gruß, Auer

Share this post


Link to post

Habe das mit LM Einstellung in der Registry versucht! Leider ohne Erfolg.

 

Bei mir war im Windows 2000 Prof mit SP4 der Wert auf 0 schon gesetzt. Ich habe mal alle Werte bis auf 5 ausprobiert leider auch ohne Erfolg.

 

Aber ist auch egal wir setzten in Zukunft nur noch auf den Rechnern SP3 ein, bei den funktionierts.

 

Jedefalls Danke für die Hilfe.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...