Jump to content
Sign in to follow this  
maverick82

Exchange 2007 - Enable-Mailbox failed

Recommended Posts

Hallo zusammen,

 

der Versuch eine Mailbox für einen existierenden Benutzer über den Assistenten im Exchange 2007 anzulegen schlägt fehl.

Fehlermeldung: "There are multiple primary SMTP addresses. Please ensure there is only one primary address for each address type."

 

Der Fehler tritt nur bei einem bestimmten Benutzer auf. Für alle anderen bestehenden Benutzer konnten Mailboxen per Skript angelegt werden. Set-EmailAddressPolicy haben wir noch nicht ausgeführt. Es existiert bisher nur die default-EmailAddressPolicy.

 

Meine Vermutung ist, dass der Fehler entweder mit einem Mail-Kontakt, den wir vorher testweise für diesen Benutzer angelegt hatten, zusammenhängt oder dass die E-Mail-Adresse vorher schon eingetragen war, obwohl noch kein Postfach für den Benutzer existierte.

 

Die E-Mail-Adresse im AD-Konto haben wir herausgenommen und den Mail-Kontakt gelöscht, aber das Postfach lässt sich leider immer noch nicht anlegen.

 

Gibt es eine Möglichkeit die alten Objekte wirklich zu löschen (cleanup)? Ich vermute, dass diese noch im Hintergrund existieren und nur als gelöscht markiert sind (tombstoneLifetime beträgt bei uns 180). Über "csvde -f smtadressen.csv -r (objectClass=User) -l proxyAddresses" habe ich nämlich nichts angezeigt bekommen, was auf eine doppelte E-Mail-Adresse hindeutete. Oder gibt es eine andere Idee woran das Problem liegen könnte?

 

Hier ein paar Infos zur Umgebung:

Exchange 2003 english SP2 (nur zur Kompatibilität mit der Telefon-Anlage; keine Benutzer-Postfächer), Exchange 2007 english RollupPack3, 1 Windows-Domäne, 5 Internet-Domänen (bereits als accepted Domains eingetragen)

Share this post


Link to post
Share on other sites

Hallo

 

Die Tombstone Lifetime ist unrevelevant selbst wenn da das Objekt drin wäre.

 

Ich muss annehmen, dass der Benutzer in der Ex2007 gui nicht sauber gelöscht (entfernen) wurde. Wenn du das Tool reconnect Mailbox startest, meldet er die Mailadresse noch ?

 

Könntest du bitte die ganuen Fehlermeldung (ctrl-c) von der Ex2007 posten, dies hilft manchmal weiter (das notwendige vorher editieren).

 

Gruss,

Matthias

Share this post


Link to post
Share on other sites

Hi Matthias,

 

Wenn du das Tool reconnect Mailbox startest, meldet er die Mailadresse noch ?

meinst du in der Exchange Management Console von Exchange 2007 unter Recipient Configuration den Punkt Disconnected Mailbox? Dort wird nichts angezeigt.

Zur Information: Alle Benutzer hatten vorher kein Postfach auf irgendeinem Exchange-Server, sondern in einem anderen Mailsystem.

 

Könntest du bitte die ganuen Fehlermeldung (ctrl-c) von der Ex2007 posten, dies hilft manchmal weiter (das notwendige vorher editieren).

Hier ist die komplette Fehlermeldung, die beim anlegen des Postfaches über den Assistenten erscheint:

"Summary: 1 item(s). 0 succeeded, 1 failed.

Elapsed time: 00:00:00

 

 

BENUTZER-ANZEIGENAME

Failed

 

Error:

There are multiple primary SMTP addresses. Please ensure there is only one primary address for each address type.

 

Exchange Management Shell command attempted:

Enable-Mailbox -Identity 'FIRMA.int/OU/OU/BENUTZER-ANZEIGENAME' -Alias 'SAMID' -Database 'CN=DB2,CN=SG1,CN=InformationStore,CN=EXCHANGE07,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=FIRMA,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=FIRMA,DC=int'

 

Elapsed Time: 00:00:00"

Share this post


Link to post
Share on other sites

Wir haben einen Weg gefunden, die Mailbox für den Benutzer doch noch anlegen zu können:

1. auf dem Exchange Server 2003 die Mailbox angelegen

2. auf dem Exchange Server 2007 per "get-mailbox SAMID | Move-Mailbox -TargetDatabase 'DB2'" die Mailbox auf dem richtigen (den Exchange Server 2007) Server verschieben

Share this post


Link to post
Share on other sites

Super. Glückwunsch. Sorry musste mich ein bissel zurücklehnen, schlag mich grad mit Public Folders und enabled Mailfunction auf dem Kriegspfad rum ...

 

Gruss,

Matthias

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...