Jump to content
Sign in to follow this  
jani_brb

Exchange 2007 - SendConnector

Recommended Posts

Hallo zusammen,

 

ich bin irgendwie am ende meines wissens! Leider habe ich das Problem, das E-Mails größer als 10MB nicht den Exchange verlassen. Ich hab bereits div. Einstellungen auf der Shell veruscht, leider ohne erfolg... vielleicht kann mir jemand helfen, der das selbe Problem hatte.

 

folgendes habe ich bereits durchgeführt (ind er exchange shell):

Set-SendConnector "ConnectorName" -MaxMessageSize unlimited

 

Get-TransportConfig ergibt:

MaxDumpsterSizePerStorageGroup : 18MB
MaxDumpsterTime                : 7.00:00:00
MaxReceiveSize                 : unlimited
MaxRecipientEnvelopeLimit      : unlimited
MaxSendSize                    : unlimited

 

und Get-Mailbox ergibt:

Name                      Alias                ServerName       ProhibitSendQuota
----                      -----                ----------       ---------------
Administrator             Administrator        mailserver       unlimited

 

 

Für mich steht alles auf 'unlimited' jedoch bekomme ich folgenden Fehler beim versenden:

exchangefehlerxw1.jpg

 

Um hilfe wäre ich dankbar,

 

gruss

Share this post


Link to post
Share on other sites

Hallo

 

Das ist leider nicht so einfach, da die Mailsize an mehreren Orten hinterlegt ist. Keinenfalls mit dem ADSI Edit den Eintrag manuell ändern, so gibts Neuinstallationen.

 

Die folgende Parameterrubrik

MaxDumpsterSizePerStorageGroup : 18MB

MaxDumpsterTime : 7.00:00:00

MaxReceiveSize : unlimited

MaxRecipientEnvelopeLimit : unlimited

MaxSendSize : unlimited

 

kannst Du Dir schenken, denn das ist der Dumpster des Hub, welcher lediglich im ClusteringUmfeld von Ex2007 eine grössere Rolle spielt.

 

Schau mal unter You Had Me At EHLO... : Capacity and transactional IO requirements for Exchange 2007 Edge Transport and Hub Transport servers da müsste auf der Teamsite irgendwo erklärt werden wie die Attachmentgrsse verändert wird, denn diese muss an mehreren Stellen, da mehrere Rollen relevant sind, verändert werden. (Sowohl usersettings, wie auch Transportserver).

 

Gruss,

Matthias

Share this post


Link to post
Share on other sites

Hallo Matthias,

 

danke für deine Antwort! Ich habe nun alles durchstöbert dort, finde aber keine Anleitung welche Settings man alles einstellen muss, damit man größere Dateien versenden darf.

 

hast du evtl einen dirketen link zu dem blog-eintrag?

 

gruss

Share this post


Link to post
Share on other sites

Ich bekomme beim eingeben dieses Befehls

Set-ReceiveConnector –IDENTITY -MaxMessageSize 50MB

 

immer die Fehlermeldung das ich eine –IDENTITY eingeben muss. Soweit so gut.

Wenn ich die Identity eingebe bekomme ich die Medlung, dass die Identity im AD nicht gefunden werden kann.

 

Was muss ich den Tun, dass der Exchange mit dem AD kommuniziert? Steh da gerade voll auf dem Schlauch.

 

Gruß Hindin

Share this post


Link to post
Share on other sites

Ok so weit so gut.

 

Wen ich nun aber

Get-ReceiveConnector | List

eingebe, dann bekome ich ja die IDENTITY angezeigt.

Wenn ich dann nun den Set Befehel mit dieser Identity angebe, kommt immer noch der Hinweis dass die Identity nicht auf dem Domänencontoler gefunden werden kann.

Wo kann ich den noch die Richtige Identity auslesen?

 

Gruß Hindin

Share this post


Link to post
Share on other sites

Hallo

 

Die Identidity ist der Servername\Storagegroup oder Storagegroup\Datenbank. Ist leider nicht so konsistent implementiert. Was ergibt denn "help Set-ReceiveConnector". Achtung manchmal ist PowerShell auch gross-klein Schreib emfpindlich.

 

Der Receive Connector ist nur die halbe Miete, denn Du hast dazwischen noch den Mailtransport. Die Mails werden sonst angenommen und wegen übergrösse von dem TransportAgent direkt gemüllt.

 

Nochmals: Lies Dir meinen Post: How to Modify Exchange 2003 Global Message Size Limits.

 

Gruss,

Matthias

Share this post


Link to post
Share on other sites

So nun habe ich deinen Post durchgearbeitet.

 

Aber wenn ich nun:

[PS] C:\>Get-TransportConfig | fl max*


MaxDumpsterSizePerStorageGroup : 18MB
MaxDumpsterTime                : 7.00:00:00
MaxReceiveSize                 : unlimited
MaxRecipientEnvelopeLimit      : unlimited
MaxSendSize                    : unlimited

 

bekomme ich oben dargestelltes.

 

Beim Sendconnector:

[PS] C:\>Get-SendConnector | fl max*


MaxMessageSize : 50MB

 

Auch Ok.

 

Nur beim Recieveconnector kommt: Folgendes:

[PS] C:\>Get-ReceiveConnector | fl max*


MaxInboundConnection                    : 5000
MaxInboundConnectionPerSource           : unlimited
MaxInboundConnectionPercentagePerSource : 100
MaxHeaderSize                           : 64KB
MaxHopCount                             : 30
MaxLocalHopCount                        : 3
MaxLogonFailures                        : 3
MaxMessageSize                          : 10MB
MaxProtocolErrors                       : 5
MaxRecipientsPerMessage                 : 5000

MaxInboundConnection                    : 5000
MaxInboundConnectionPerSource           : 100
MaxInboundConnectionPercentagePerSource : 2
MaxHeaderSize                           : 64KB
MaxHopCount                             : 30
MaxLocalHopCount                        : 3
MaxLogonFailures                        : 3
MaxMessageSize                          : 10MB
MaxProtocolErrors                       : 5
MaxRecipientsPerMessage                 : 200

 

Und da stehen nun immer noch die 10MB drin.

Wenn ich die nunn ändern will auf 50 MB kommt folgender Fehler:

[PS] C:\>Set-ReceiveConnector -MaxMessageSize  50MB

cmdlet Set-ReceiveConnector at command pipeline position 1
Supply values for the following parameters:
Identity:
Set-ReceiveConnector : Cannot bind parameter 'Identity'. Cannot convert value "
" to type "Microsoft.Exchange.Configuration.Tasks.ReceiveConnectorIdParameter".
Error: "Der Parameterwert dieses Typs Microsoft.Exchange.Configuration.Tasks.R
eceiveConnectorIdParameter darf nicht leer sein.
Parametername: identity"
At line:1 char:21
+ Set-ReceiveConnector  <<<< -MaxMessageSize  50MB

 

Was muss ich da bei Identity eingeben?????

 

Diese Identity gibt es:

[PS] C:\>Get-ReceiveConnector | fl i*


Identity : FEMAIL01\Default FEMAIL01
IsValid  : True

Identity : FEMAIL01\Client FEMAIL01
IsValid  : True

 

Kann aber beide eingeben, dann kommt jeweils nur der Text:

[PS] C:\>Set-ReceiveConnector -MaxMessageSize  50MB

cmdlet Set-ReceiveConnector at command pipeline position 1
Supply values for the following parameters:
Identity: "FEMAIL01\Default FEMAIL01"
Set-ReceiveConnector : Der Vorgang konnte nicht ausgeführt werden, weil das Obj
ekt '"FEMAIL01\Default FEMAIL01"' nicht auf dem Domänencontroller 'fedc01.feinl
er.priv' gefunden wurde.
At line:1 char:21
+ Set-ReceiveConnector  <<<< -MaxMessageSize  50MB
[PS] C:\>"FEMAIL01\Default FEMAIL01"
FEMAIL01\Default FEMAIL01
[PS] C:\>Set-ReceiveConnector -MaxMessageSize  50MB

cmdlet Set-ReceiveConnector at command pipeline position 1
Supply values for the following parameters:
Identity: "Default FEMAIL01"
Set-ReceiveConnector : Der Vorgang konnte nicht ausgeführt werden, weil das Obj
ekt '"Default FEMAIL01"' nicht auf dem Domänencontroller 'fedc01.feinler.priv'
gefunden wurde.
At line:1 char:21
+ Set-ReceiveConnector  <<<< -MaxMessageSize  50MB

 

Weis nun nicht mehr weiter. :-(

 

Gruß Hindin

Share this post


Link to post
Share on other sites

Hallo

 

Also dann wollen wir doch mal schauen :D

 

Get-TransportConfig | fl max*

MaxDumpsterSizePerStorageGroup : 18MB

MaxDumpsterTime : 7.00:00:00

MaxReceiveSize : unlimited

MaxRecipientEnvelopeLimit : unlimited

MaxSendSize : unlimited

 

Das ist so okey. Falls es ein Cluster wäre müsste der Dumpster auf die MaxSendSize gesetzt werden. Da wir kein Cluster haben wird innerhalb der Transportrolle die Dumpstergrösse nach best practice nicht verändert. Gut so.

 

Beim Sendconnector:

MaxMessageSize : 50MB

[/quote ]

Auch Ok.

 

Nur beim Recieveconnector kommt: Folgendes:

Get-ReceiveConnector | fl max*

MaxInboundConnection : 5000

MaxInboundConnectionPerSource : unlimited

MaxInboundConnectionPercentagePerSource : 100

MaxHeaderSize : 64KB

MaxHopCount : 30

MaxLocalHopCount : 3

MaxLogonFailures : 3

MaxMessageSize : 10MB

MaxProtocolErrors : 5

MaxRecipientsPerMessage : 5000

MaxInboundConnection : 5000

MaxInboundConnectionPerSource : 100

MaxInboundConnectionPercentagePerSource : 2

MaxHeaderSize : 64KB

MaxHopCount : 30

MaxLocalHopCount : 3

MaxLogonFailures : 3

MaxMessageSize : 10MB

MaxProtocolErrors : 5

MaxRecipientsPerMessage : 200[/code]

 

Diese Identity gibt es:

[PS] C:\>Get-ReceiveConnector | fl i*
Identity : FEMAIL01\Default FEMAIL01
IsValid  : True
Identity : FEMAIL01\Client FEMAIL01
IsValid  : True

 

 

Kann aber beide eingeben, dann kommt jeweils nur der Text:

[PS] C:\>Set-ReceiveConnector -MaxMessageSize 50MB

Es ist zwingend den Connector anzugeben. Ich hatte da auch Probleme weiss aber nicht grad wie ich es löste. Meinte der Syntax müsste heissten

set-receiveConnector -Identity "Default Femail01" -maxMessageSize 50m

 

Die Connectoren gelten Organsisationsweit. es kann auch sein "first administrative group\Client Femail". Leerzeichen müssen auch bei PSH immer in Anführungszeichen stehen.

 

Gehen tut es jedenfalls sicherlich.

 

Gruss

Matthias

Share this post


Link to post
Share on other sites

So habs nun raus. Der Befehl muss so aussehen dann funzt es:

Set-ReceiveConnector "FEMAIL01\Default FEMAIL01" -MaxMessageSize  50MB

 

Ohne Identity, das war des Rätsels Lösung.

 

Thx to all.

Share this post


Link to post
Share on other sites

HI zusammen,

 

ich habe mir Artikel von MSExchange.org mal zu herzen genommen und durchgearbeitet. Leider habe ich immer noch das selbe Problem, das mein Outlook sofort die Meldung bringt, das die maximale Nachrichtengröße für diesen Benutzer bei der übermittelten Nachricht überschreitet.

 

Wenn ich mir nun mit dem Befehl 'Get-Mailbox -Identity MailboxName | List' ein Benutzer anschaue, kommt folgendes bei rau:

 

MaxSendSize : unlimited

MaxReceiveSize : unlimited

 

Überprüfe ich mit dem Befehl 'get-SendConnectors | fl max*' kommt dies bei raus:

 

MaxMessageSize : unlimited

 

bei 'get-receiveconnector' das selbe, abgesehen das ich dem empfang auf 30MB beschränkt habe:

 

[PS] Get-ReceiveConnector | fl max*

 

 

MaxInboundConnection : 5000

MaxInboundConnectionPerSource : unlimited

MaxInboundConnectionPercentagePerSource : 100

MaxHeaderSize : 64KB

MaxHopCount : 30

MaxLocalHopCount : 3

MaxLogonFailures : 3

MaxMessageSize : 30MB

MaxProtocolErrors : 5

MaxRecipientsPerMessage : 5000

 

MaxInboundConnection : 5000

MaxInboundConnectionPerSource : 100

MaxInboundConnectionPercentagePerSource : 2

MaxHeaderSize : 64KB

MaxHopCount : 30

MaxLocalHopCount : 3

MaxLogonFailures : 3

MaxMessageSize : 30MB

MaxProtocolErrors : 5

MaxRecipientsPerMessage : 200

 

Bei dem Befehl 'Get-TransportConfig' kommt dieses heraus:

 

Get-TransportConfig

 

 

ClearCategories : True

GenerateCopyOfDSNFor : {5.4.8, 5.4.6, 5.4.4, 5.2.4, 5.2.0, 5.1.4}

InternalSMTPServers : {}

JournalingReportNdrTo : <>

MaxDumpsterSizePerStorageGroup : 18MB

MaxDumpsterTime : 7.00:00:00

MaxReceiveSize : unlimited

MaxRecipientEnvelopeLimit : unlimited

MaxSendSize : unlimited

TLSReceiveDomainSecureList : {}

TLSSendDomainSecureList : {}

VerifySecureSubmitEnabled : False

VoicemailJournalingEnabled : True

Xexch50Enabled : True

 

 

Was habe ich nun vergessen?! Wieso weiss er nicht das 'unlimited' beim senden vergeben habe?

 

Um hifel oder Tipp wäre ich dankbar...

 

gruss

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...