Jump to content
Sign in to follow this  
adowoMAC

VRF VPN-Bildung

Recommended Posts

Hallo,

 

ich brauche mal eine Beschreibung, wie ich mittels VRF eine Art VPN aufbauen kann. Ich habe einen 1841er Router als zentrale und möchte nun jeweils einen anderen Router an die VRF-Instanzen anbinden.

 

Die Instanzen heissen texas und florida.

 

Wie muss ich nun die "Kundenrouter" konfigurieren, die direkt an das Interface fa0/0 bzw. fa0/1 angebunden werden, damit diese in das VRF kommen?

 

Config des zentralen Geräts:

 

Current configuration : 1128 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
ip vrf florida
rd 2:2
route-target export 2:2
route-target import 2:2
!
ip vrf texas
rd 1:1
route-target export 1:1
route-target import 1:1
!
no ip domain lookup
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 2
ip vrf forwarding texas
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.1
encapsulation dot1Q 3
ip vrf forwarding florida
ip address 192.168.2.1 255.255.255.0
!
router ospf 1 vrf texas
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
!
router ospf 2 vrf florida
log-adjacency-changes
network 192.168.2.0 0.0.0.255 area 0
!
!
!         
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end

Share this post


Link to post

Einfach die Interfaces an denen die Router angeschlossen werden ins jeweilige vrf geben (ip vrf forw XYZ). Am Kundenrouter ist keine spezziele Konfig notwendig.

 

 

lg Franz

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...