Jump to content
Sign in to follow this  
MPH

Cisco 801

Recommended Posts

Hallo an alle CISCO Spezialisten,

 

ich kenne mich noch nicht wirklich mit CISO Router’n aus, hoffe aber das wird noch :-)

 

Evtl. kann mir einer von euch bei einem kleinen privaten Problem (Test) helfen.

 

Ich habe über Ostern folgendes Versucht (was mir aber nur teilweise gelungen ist)

 

Ich wollte / würde gerne mein bestehendes Heimnetz in welchem sich der „PC1“ befindet mithilfe zweier CISO 801 ISDN Router mit dem Heimnetz meines Bruders verbinden

(DSL ist nicht verfügbar).

 

Bisher ist es mir gelungen die beiden Netz zu Verbinden, und die PC’s 1 & 2 können sich auch prima miteinander unterhalten. PC 2 kann sogar Internetnamen mithilfe meines DSL Router’s auflösen…..

 

Nur leider habe ich von PC 2 keine Möglichkeit ins Internet zu gelangen.

Die Domainnamen werden zwar prima aufgelöst, man kann jedoch die externe Internet IP nicht anpingen (was auch logisch ist da der CISCO Router keine Ahnung hat wie er dort hingelangen soll)

 

Kann man dieses Problem evtl. über eine Statische Route lösen? Wenn Ja wie müsste diese aussehen. oder gibt es hierfür einen anderen Lösungsansatz.

 

Vielen Dank schon mal für euere Anregungen

Marko

post-42068-1356738945612_thumb.gif

Share this post


Link to post

Hi,

 

ja das geht, ich nehme an auf einem von beiden 801 ist eine internetverbindung konfiguriert? einfach auf dem zweiten cisco eine default route auf den dialer in richtung des ersten 801 und auf dem ersten 801 dialer nat anpassen (ip nat inside auf dem cisco-cisco dialer und access-list fürs nat anpassen, dann sollte es gehen.

 

 

gruss

 

rob

Share this post


Link to post

Hallo Rob,

 

erstmal danke für Deine Antwort.

 

Auf keinem der beiden 801er ist eine Internetverbindung konfiguriert.

(Leider habe ich keine Idee wie ich das machen kann)

 

Es ist nur das Default seitige Dynamische Routing aktiviert

 

Gruß

Marko

Share this post


Link to post

Hallo Marko,

 

 

du könntest z.B. auf einem cisco einen dialer für die internetverbindung anlegen, falls du über den pc direkt ins internet gehst, gehts auch, wenn du auf diesem routing aktivierst. dieser pc wird dann der default gateway.

 

 

gruss

 

rob

Share this post


Link to post

Hallo Rob,

 

danke für Deinen Tipp.

 

Ich werde mal mein Glück versuchen.

 

Gruß

Marko

Share this post


Link to post

Gibt es eigentlich noch eine Möglichkeit dem Router seinen nächsten Hop mitzuteilen?

 

Gruß

MPH

Share this post


Link to post

Hallo,

 

natürlich:

 

 

ip route 0.0.0.0 0.0.0.0 next-hop-ip-adresse (als default gateway)

 

oder ip route 192.168.100.0 255.255.255.0 next-hop-ip-adresse (als Netzroute)

 

Der Router trägt auch Routen ein, wo der Gateway nicht bekannt ist, übernimmt dann aber die Route aber nicht in die Routingtabelle...

 

 

gruss

 

rob

Share this post


Link to post

Hallo nochmal,

 

Ich habe gestern Abend nochmals ein paar Sachen versucht allerdings ohne Erfolg.

 

PC 2 kann über Router 2 & Router 1 prima mit PC 1 kommunizieren.

 

Es gelingt mir allerdings weiterhin nicht das PC 2 über Router 2 & 1 auf das Internet zugreifen kann. Ein ping auf den DSL Router ist möglich und die DNS Auflösung geht auch.

 

Versucht man allerdings von PC 2 einen ping auf z.B. Topmeldungen - Nachrichten - Schlagzeilen - n-tv.de wird zwar der Name aufgelöst der Router 2 meldet jedoch bei einem tracert Zielhost nicht erreichbar.

 

Kann evtl. einer der erfahrenen Router Spezialisten in einer freien Minute mal über meine Konfig schauen oder mir sagen wo ich die gesuchte Info finden kann?

 

PC 2 mit der IP 192.168.1.5 soll über den Router 2 (ETH IP: 192.168.1.1; ISDN IP: 10.0.0.2) und über Router 1 (ETH IP: 192.168.0.3; ISDN IP: 10.0.0.1) auf den DSL Router mit der IP: 192.168.0.1 ins Internet gehen. PC 2 kann den DSL Router ohne Probleme anpingen.

 

 

Vielen Dank im Voraus

Marko

Share this post


Link to post

Anbei die Konfig der beiden Router:

 

***************************************************************************

***Router 1***

 

!

service timestamps debug uptime

service timestamps log uptime

service password-encryption

no service tcp-small-servers

no service udp-small-servers

!

hostname router1

!

enable password pass

username router2 password pass

!

no ip name-server

!

isdn switch-type basic-net3

!

ip subnet-zero

no ip domain-lookup

ip routing

!

interface Dialer 1

description connected to router2

ip address 10.0.0.1 255.255.255.0

no ip split-horizon

encapsulation ppp

dialer in-band

dialer idle-timeout 120

dialer hold-queue 10

dialer map snapshot 1 name router2 broadcast 0123456789

dialer map ip 10.0.0.2 name router2 speed 64 broadcast 0123456789

dialer-group 1

ppp authentication chap

no ppp multilink

snapshot client 15 360 suppress-statechange-update dialer

no cdp enable

!

interface Ethernet 0

no shutdown

description connected to EthernetLAN

ip address 192.168.0.3 255.255.255.0

keepalive 10

!

interface BRI 0

no shutdown

description connected to router2

no ip address

dialer rotary-group 1

!

! Dialer Control List 1

!

no dialer-list 1

dialer-list 1 protocol ip permit

!

router rip

version 2

network 10.0.0.0

network 192.168.0.0

no auto-summary

!

!

ip classless

!

! IP Static Routes

ip route 0.0.0.0 0.0.0.0 Ethernet 0 1

no ip http server

snmp-server community public RO

no snmp-server location

no snmp-server contact

!

line console 0

exec-timeout 0 0

password pass

login

!

line vty 0 4

password pass

login

!

end

***************************************************************************

 

***ROUTER 2***

 

!

service timestamps debug uptime

service timestamps log uptime

service password-encryption

no service tcp-small-servers

no service udp-small-servers

!

hostname router2

!

enable password pass

username router1 password pass

!

no ip name-server

!

isdn switch-type basic-1tr6

!

ip subnet-zero

no ip domain-lookup

ip routing

!

interface Dialer 1

description connected to router1

ip address 10.0.0.2 255.255.255.0

no ip split-horizon

encapsulation ppp

dialer in-band

dialer idle-timeout 120

dialer map snapshot 1 name router1 broadcast

dialer map ip 10.0.0.1 name router1 speed 64 broadcast

dialer-group 1

ppp authentication chap

no ppp multilink

snapshot server 15 dialer

no cdp enable

!

interface Ethernet 0

no shutdown

description connected to EthernetLAN_1

ip address 192.168.1.1 255.255.255.0

keepalive 10

!

interface BRI 0

no shutdown

description connected to router1

no ip address

dialer rotary-group 1

!

! Dialer Control List 1

!

no dialer-list 1

dialer-list 1 protocol ip permit

!

router rip

version 2

network 10.0.0.0

network 192.168.1.0

no auto-summary

!

!

ip classless

!

! IP Static Routes

ip route 0.0.0.0 0.0.0.0 Dialer 1 1

no ip http server

snmp-server community public RO

no snmp-server location

no snmp-server contact

!

line console 0

exec-timeout 0 0

password pass

login

!

line vty 0 4

password pass

login

!

end

Share this post


Link to post

Hi,

Router 1 braucht eine default route auf 192.168.0.1. Ich würde auch RIP abschalten (updates über isdn?!) und nur mit statischen Routen arbeiten, die fehlen allerdings noch (router 1 ip route 192.168.1.0 255.255.255.0 dialer 1, router 2 ist ok, der hat dialer 1 als default gateway), dein dsl router muss das netz 192.168.1.0 / 24 kennen und braucht dafür den cisco 192.168.0.3 als Gateway. den default gateway auf ethernet0 kannst du rauswerfen... brauchst du nur noch nen dsl router, der auch eine richtige routingtable führt... im zweifelsfalle könntest du sogar den einen 801 verwenden, da diese router mit entsprechendem ios auch pppoe sprechen können...

 

 

gruss

 

 

rob

Share this post


Link to post

Hallo rob,

 

danke für Deine Info.

 

Ich werde heute Abend die Konfiguration noch mal anpassen und morgen berichten.

 

Gruß

Marko

Share this post


Link to post

Moin Rob,

 

ich habe mal versucht die Config nach deinen Empfehlungen abzuändern.

 

Die Config für die Statischen Routen sieht jetzt wie folgt aus:

 

- Rip habe ich komplett deaktiviert

- der DSL Router hat eine statische Route in das Netz 192.168.1.0 über die 192.168.0.3 als Gateway

 

Router 1

*******************************************************

! IP Static Routes

ip route 192.168.1.0 255.255.255.0 Dialer 1 1 permanent

no ip http server

snmp-server community public RO

no snmp-server location

no snmp-server contact

!

 

Router 2

*******************************************************

! IP Static Routes

ip route 0.0.0.0 0.0.0.0 Dialer 1 1 permanent

no ip http server

snmp-server community public RO

no snmp-server location

no snmp-server contact

!

 

Das Problem ist, sobald ich RIP abschalte und nur mit den oben aufgeführten statischen Routen arbeite kann ich weder vom 192.168.0.0 Netz ins 192.168.1.0 Netz pingen noch umgekehrt.

 

Gruß

Marko

Share this post


Link to post

Hi, dann schau doch mal, ob die routen da sind (show ip route) bzw. mach mal nen trace vom lan interface des einen cisco zum lan interface des anderen cisco. das ganze in beiden richtungen, da muss eine route fehlen, zumindest in der Routingtable?! welche ios versionen benutzt du genau? die lan interfaces müssen connected und up sein zum testen!

 

 

gruss

 

 

rob

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...