Jump to content
Sign in to follow this  
marzli2

2x3750: bündelung, trunk + vlan und ip konfigurieren

Recommended Posts

hi,

 

bin gerade am erweitern meiner cisco kenntnisse und etwas eingerostet.

jetzt habe ich folgende aufgabe:

 

 

2 x 3750 switch. folgende tätigkeiten müssen durchgeführt werden

 

1. port 1+2 der switches sollen gebündelt werden (channel-group)

2. diese channelgroup soll als trunking leitung genutzt werden.

3. vlan 134 erstellen und diese channelgroup darin aufnehmen

4. ip adressen vergeben, default gateways vergeben

 

letztentlich muss der trunk funktionieren, das vlan 134 funktionieren und ich noch nicht ganz wirr im kopf sein.

 

vergebe ich die ip adresse allgemein für das gerät oder für jedes vlan? wobei das ja layer2 ist... mhhhh

 

naja. das hab ich jedenfalls bis jetzt

 

 

Switch# configure terminal

Switch(config)# interface range gigabitethernet1/0/1 - 2

Switch(config-if-range)# switchport mode on

Switch(config-if-range)# channel-group 1 mode on

Switch(config-if-range)# end

 

Switch(config)# interface port-channel 1

sSwitch(config-if)#switchport trunk encapsulation dot1q

Switch(config-if)# switchport mode trunk

Switch(config-if)#

 

Switch(config)#vlan 134

Switch(config)#exit

 

Switch(config)#vlan 134

Switch(config)# interface port-channel 1

 

 

bitte um support

Share this post


Link to post
Share on other sites

Hi,

 

moechtest du einen Layer 2 oder Layer 3 Etherchannel?

 

Du kannst einen Etherchannel mit IP Addressierung versehen oder du machst einen Etherchannel der Vlans transportiert.

 

Ohne pruning werden defaultmaessig alle Vlans ueber den Trunk geschickt. Trunk Encapsulation gibt es dot1q und isl.

Beide taggen, wobei nur dot1q das nativ vlan nicht taggt.

 

Du kannst einzelne Vlans vom Trunk nehmen, sodas sie nicht ruebergehen duerfen.

 

Damit dein Vlan ueber den Trunk geht, musst du kein SVI( switched virtual interface) konfigurieren. Das Vlan muss dazu nur in der VTP domain angelegt sein.

 

Ich nehme an, du moechtest nur die beiden Switches ueber einen Etherchannel verbinden und dann die Vlans daruber laufen lassen.

Dazu musst du nur den Etherchannel konfigurieren.

 

Auf beiden Seiten:

 

Rack1SW4(config)#int ra f0/13 - 15

Rack1SW4(config-if-range)#channel-group 3 mode on

 

Rack1SW4(config)#int po3

Rack1SW4(config-if)#switchport trunk encapsulation dot1q

Rack1SW4(config-if)#switchport mode trunk

 

Rack1SW4(config-if)#do sh int tru

 

Port Mode Encapsulation Status Native vlan

Po3 on 802.1q trunking 1

 

Port Vlans allowed on trunk

Po3 1-4094

 

Port Vlans allowed and active in management domain

Po3 1,3,5,8,10,26,33,52,255,783

 

Port Vlans in spanning tree forwarding state and not pruned

Po3 none

 

 

Fu

Share this post


Link to post
Share on other sites

puh. ich steig da noch nicht durch. auf dem zweiten switch, der bereits eine konfig hat hab ich die zeilen von dir eingegeben. nur mit port1-2 und channel group 1

aber da taucht hiervon ja gar nix auf

 

kann ich irgendwie sehen, welche ports in welcher channel group sind?

 

 

 

Cat3750_s190019_LAB(config-if)#do sh int tru

 

Port Mode Encapsulation Status Native vlan

Gi1/0/11 on 802.1q trunking 1

Po3 auto 802.1q trunking 1

Po4 on 802.1q trunking 1

 

Port Vlans allowed on trunk

Gi1/0/11 1-99,102-4094

Po3 1-99,102-4094

Po4 1-99,102-4094

 

Port Vlans allowed and active in management domain

Gi1/0/11 1,133-135

Po3 1,133-135

Po4 1,133-135

 

Port Vlans in spanning tree forwarding state and not pruned

Gi1/0/11 1

Po3 1,133-134

Po4 1

Share this post


Link to post
Share on other sites

Hi,

 

show etherchannel [detail]

 

oder mach mal ein

 

show run | inc inter|chan

 

Dann hast du auch als Ausgabe die Ports auf denen du einen channel konfiguriert hast.

 

Was passen sollte ist auf beiden Seiten das gleich Protokoll (PAgP/LACP) oder gar keins, dann einfach mit "on", das geht auch.

 

 

Fu

Share this post


Link to post
Share on other sites

2 fragen noch,

 

1 was genau bedeutet diese adresse?

Hardware is EtherChannel, address is 0015.c6c1.3003

was soll ich mir darunter vorstellen. die MAC Adresse?

 

 

2 mein interface ist down auf einem switch.

Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

 

ne idee?

Share this post


Link to post
Share on other sites
2 fragen noch,

 

1 was genau bedeutet diese adresse?

Hardware is EtherChannel, address is 0015.c6c1.3003

was soll ich mir darunter vorstellen. die MAC Adresse?

 

 

2 mein interface ist down auf einem switch.

Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

 

Hi,

 

1. Ja. Versteh die Frage nicht so ganz.

 

2. Schau dir mal an ob die encapulation uebereinstimm auf beiden Seiten und ob die einzelnen Channel-group member auch oben sind. Sonst kann der Etherchannel natuelrich auch nicht oben sein. Und wie gesagt, das Negotiationprotokoll muss das gleich sein.

 

Da der Etherchannel keine MAC Addresse hat, hast du anscheinend eine Etherchannelinterface angelegt aber keine member hinzugefuegt.

Ich hoffe es ist klar, das die Nummer Portchannel Po[1..] mit dem Befehl "channel-group [1...] mode ... zusammenhaengt.

 

Du hast dann ein interface Po1 das deinen Etherchannel bildet. Deine zweite Frage deutet eher darauf hin, das du keine Ports hinzugefuegt hast.

 

Fu

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...